View Full Version : w,h as dm grid size
22nd November 2002, 17:45
It would be usefull if dm grid size could be defined like:
I think the | sign is called div in programing or is it mod? :confused:
22nd November 2002, 18:24
| is usually the OR command, in AVS it's an integral bitwise OR:
15|26 <-convert to integer
00001011|0011010 <-convert to binary
00011011 <-do bitwise OR; if a digit is 1 in either of the numbers, it is 1 in the final number
27 <-convert back to decimal
C++'s TRUE/FALSE OR (||) and AND (&&) go like this:
(a>b||b!=c&&c==a) :: conditional (a is greater than b OR (b is not equal to c AND c is equal to a))
This returns TRUE if a is greater than b, or if b is not equal to c and c is equal to a.
Anyway, I don't think we ned to have that capability with DM gridsizes, since you'd get people like me who had never done DM's before using w and h for gridsizes, and getting 0 fps out of it, then coming to the forum complaining about how crappy AVS's Dynamic Movement component is (except I didn't complain about it, since it wasn't crappy, it just didn't have W and H for gridsize.)
22nd November 2002, 18:56
I wrote it wrong. Its (8|w) and (12|h). For any x,y e N and x>y there are such q,r e N that x/y=y*q+r and r<y. Anyway | is a math sigh and that x|y=q.
I thought it would be usefull for making grid size resolution dependable. I dont really understand yore argument, its the same as someone would say that avs sucks becouse you can sett superscope n to 1000000.
22nd November 2002, 20:50
So your 'DIV' or '|' is just integral division? 'MOD' is the modulus operator btw (% in AVS).
23rd November 2002, 17:48
Unconed: Yes thats that.I knew there was an English word for it.
vBulletin® v3.8.6, Copyright ©2000-2013, Jelsoft Enterprises Ltd.