View Full Version : Relay server

16th May 2003, 01:02
Ok guys I've checked the FAQ and searched the forums but haven't found a thread that explaines how to set up a relay server. I recently added a few line to my web site asking for help from people who might be able to donate a realy server. The problem is, if someone were to give me a mega server today, I wouldn't have the slightest idea of how to go about setting it up.....LOL. Any help would be greatly appreciated.

Thanks in advance!


16th May 2003, 01:28
The remote user would install the DNAS in the normal fashion , but the relay information would need to point to your main DNAS ip and port.

Check out the DNASs sc_serv.ini/conf file:; RelayPort and RelayServer specify that you want to be a relay server.
; Relay servers act as clients to another server, and rebroadcast.
; Set RelayPort to 0, RelayServer to empty, or just leave these commented
; out to disable relay mode.
; RelayPort=8000
; RelayServer=

Their DNAS will use your DNASs portBase for RelayPort and ip for RelayServer.

Also, rememebr to have them remove the comment designator ( ; ) from the beginning of those two lines.

16th May 2003, 01:35
Once again....Thank you Fester! That's all I needed to know.


18th May 2003, 19:03
I have I quersen for you Festerhead......is it posible to controll, and choose the server I wont to relay to me.I couldent find any config file who match my request.Just a option Yes or No -If I wont other shutcast servers be able to connect to me.

And one more thing...
if I relay to a server.is it automatic relay back to me....
When the option is ON


:blah: :confused: :rolleyes:

18th May 2003, 21:59
Hmm just checking in.........no answer yet

18th May 2003, 23:14
Q: is it posible to controll, and choose the server I wont to relay to me?
A: yes; AllowRelay determines whether or not other SHOUTcast servers will be
; permitted to relay this server. The default is Yes.

Set AllowRelay to "No" (without quotes) for the other relay stations.
Of course, your main DNAS that has relays connected to it needs to remain at the default "Yes" (without quotes)

19th May 2003, 06:36
Not the longest answer in history, where in the config do i find it then , or do it.

"And this last thing"
-I was not express my self clearly...but what I meen was that I've not have change anything (Defult)