PDA

View Full Version : 'name not found' queries by winamp


Tmantiko
19th June 2007, 22:07
I lately monitored my system using sysinternals Process Monitor and found that Winamp (while idle) generates 4 queries per second (!) with a 'name not found' result (see the attached screen shot below). Any ideas as to the cause of this repetitive queries?

Using XP SP2 with Winamp lite 5.35

name_not_found.jpg

DJ Egg
19th June 2007, 23:03
Some 3rd-party plugin maybe?
http://forums.winamp.com/showthread.php?threadid=161361#specs
http://forums.winamp.com/showthread.php?threadid=161361#plugins

Tmantiko
20th June 2007, 07:08
Below is the output of the One for Nunz v2.83 plugin. Please let me know if anything else would be of help:

Installed Winamp plugin list
Generated by 'One for Nunz v2.83' on 20-Jun-07 at 09:00:37

<< Winamp Information >>

Winamp.ini path is: E:\Program Files\Winamp\Winamp.ini
Plugin directory is: E:\Program Files\Winamp\Plugins
Visualisation directory is: E:\Program Files\Winamp\Plugins
DSP directory is: E:\Program Files\Winamp\Plugins
Skin directory is: E:\Program Files\Winamp\skins

Using Winamp version: 5.35 (Build 1305)
Current skin: Winamp base skin (Classic skin)
Sonic Burning Engine is not installed

<< OS Information >>

Running on: Windows XP (Service Pack 2)
Memory available: 2095032 KB


<< Input plugins >>

Nullsoft CD plug-in (CDDB2) v3.33 [in_cdda.dll]
Reference FLAC Decoder v1.1.1(with ML support) [in_flac.dll]
Nullsoft MPEG Audio Decoder 4.06 [in_mp3.dll]
AudioCoding.com MPEG-4 General Audio player: 2.1 beta compiled on Jul 9 2004 [in_mp4.dll]
.mpc Musepack plugin 0.99g [in_mpc.dll]
Nullsoft Waveform Decoder 3.13 [in_wave.dll]

<< Output plugins >>

DirectSound output v2.47 [out_ds.dll] [active]
SqrSoft® Advanced Crossfading v1.75 [out_sqr.dll]
waveOut output v2.11 [out_wave.dll]

<< Visualisation plugins >>

Nullsoft Tiny Fullscreen (v2.09) [vis_nsfs.dll]

<< DSP plugins >>

No plugins of this type are installed

<< General Purpose plugins >>

Winamp Good Night Sleep Plugin v1.0 [gen_ctrl.dll]
Nullsoft Global Hotkeys v1.32 [gen_hotkeys.dll]
Jump To File Extra v0.99.1b (Build 400) [gen_jumpex.dll]
One for Nunz v2.83 [gen_nunzio.dll]
Nullsoft Tray Control v2.0 [gen_tray.dll]
Audioscrobbler Winamp plugin v2, 0, 30, 0 [gen_wa2_scrobbler.dll]

<< Encoder plugins >>

[enc_wav.dll]
WAV Encoder v1.01

<< Summary of system components (*.w5s) >>
(These are not included in the plugin counts below)
aacPlusDecoder.w5s (356kb)
db.w5s (253kb)
jnetlib.w5s (26kb)
playlist.w5s (31kb)
tagz.w5s (21kb)
xml.w5s (88kb)

<< Summary of all dlls in the root winamp folder (*.dll) >>
(These are not included in the plugin counts below)
libsndfile.dll (222kb) [loaded]
nscrt.dll (344kb) [loaded]

<< Summary of installed plugins >>

6 Input plugins installed
3 Output plugins installed
1 Visualisation plugin installed
0 DSP plugin installed
6 General Purpose plugins installed
0 Media Library plugin installed
1 Encoder plugin installed

Total: 17 plugins installed

DJ Egg
20th June 2007, 11:56
Reference FLAC Decoder v1.1.1(with ML support) [in_flac.dll]
AudioCoding.com MPEG-4 General Audio player: 2.1 beta [in_mp4.dll]
.mpc Musepack plugin 0.99g [in_mpc.dll]
Winamp Good Night Sleep Plugin v1.0 [gen_ctrl.dll]
Audioscrobbler Winamp plugin v2, 0, 30, 0 [gen_wa2_scrobbler.dll]

Those are your 3rd-party plugins.
It could be any of those to blame.

At a guess, it'll be one of the gen plugins.

As for the 3 input plugins...

I strongly recommend that you download Winamp 5.35 Full, select 'Lite' as the Install Type on Screen 2 of the Installer Options (http://forums.winamp.com/showthread.php?threadid=199851#list), then checkmark both FLAC and MP4 under Audio File Support.

You can get the Nullsoft MPC plugin here:
http://forums.winamp.com/showthread.php?threadid=266676

The support for FLAC, MP4, and MPC provided by the Nullsoft versions of the plugins is much much better than anything that those 3rd-party plugins have to offer, especially under Winamp 5.3x (ie. support for: unicode, 24bit output, replaygain, transcoder, media library, etc etc).

Tmantiko
20th June 2007, 18:21
Thanks Egg - Reinstalled with native support for the various audio formats & reduced the # of 3rd party plug-ins. The problem is now resolved.