PDA

View Full Version : yp.shoutcast.com station IDs are wrong!!!!


Killzone_Kid
15th October 2009, 22:33
If you do the search using yp.shoutcast.com API, the results for smaller stations have wrong ids and because of that corresponding pls files are empty.

Search for 'manga'

API
http://yp.shoutcast.com/sbin/newxml.phtml?search=manga

gives this:


<station name="Radio Marimanga - Danimark - [SHOUTcast.com]" mt="audio/mpeg" id="239937" br="24" genre="shqip albanian any" ct="Vesa Luma - Edhe nje Fundvit" lc="537"/>

<station name="Radio Marimanga Danimark - [SHOUTcast.com]" mt="audio/mpeg" id="895880" br="24" genre="shqip albanian any" ct="" lc="409"/>

<station name="Radio Marimanga Danimark - [SHOUTcast.com]" mt="audio/mpeg" id="556921" br="56" genre="shqip albanian any" ct="03 Elvana Gjata - Mames" lc="144"/>


Website gives this:


manga Radio Stations
Loading...
Bitrate:All|Broadband|128|56|28
more
Station: Radio Marimanga Danimark
Now Playing:
-
Genre: shqip albania...
291 Listeners, 24 kbps, MP3

http://yp.shoutcast.com/sbin/tunein-station.pls?id=599692

Station: Radio Marimanga Danimark
Shrink
Now Playing: -
Genre: shqip albanian any
Listeners: 291
Bitrate:24 kbps
Type:MP3
more

http://yp.shoutcast.com/sbin/tunein-station.pls?id=503117

Station: Radio Marimanga - Danimark
Now Playing:
Trix - Zeshkanja
Genre: shqip albania...
145 Listeners, 56 kbps, MP3
Station: Radio Marimanga - Danimark
Shrink
Now Playing: Trix - Zeshkanja
Genre: shqip albanian any
Listeners: 145
Bitrate:56 kbps
Type:MP3
more

http://yp.shoutcast.com/sbin/tunein-station.pls?id=773153


All popular stations have correct ids and valid playlists.

<station name=".977 The Hitz Channel - [SHOUTcast.com]" mt="audio/mpeg" id="6956" br="128" genre="Pop Rock Top 40" ct="Sean Kingston - Fire Burning" lc="10353"/>

<station name=".977 The 80s Channel - [SHOUTcast.com]" mt="audio/mpeg" id="6740" br="128" genre="80s Pop Rock" ct="ProviderA - WebEx" lc="6051"/>


Station: .977 The Hitz Channel - 977...
Now Playing:
Jennifer Lopez - Je...
Genre: Pop Rock Top...
6,899 Listeners, 128 kbps, MP3


http://yp.shoutcast.com/sbin/tunein-station.pls?id=6956

Station: .977 The 80s Channel - 977M...
Now Playing:
Sheena Easton - Mor...
Genre: 80s Pop Rock
3,382 Listeners, 128 kbps, MP3

http://yp.shoutcast.com/sbin/tunein-station.pls?id=6740

medicalsounds
16th October 2009, 03:55
Same here! Please if someone with some information would be perfect!

This is high priority for me right now.... :(

Thanks!

Killzone_Kid
16th October 2009, 10:17
Someone was messing with the API because now it has [SHOUTcast.com] added to every search result which wasn't there before. As a result this API doesn't update any more and the only reason the most popular stations still work is because they do not change their IDs that often. This is my theory anyway, but it really is a shame that someone decided to improve it and broke it.

SC_faisal
16th October 2009, 13:27
Have you guys tried to shut down your DNAS, wait for it to send a rem srv and then restarted it? This will cause the old stale ID from the ID to be removed and repopulated with a new one.

The [SHOUTcast.com] added to APIs has no effect on the IDs and shouldnt matter.

f.

Killzone_Kid
16th October 2009, 13:35
Sorry my initial post was made in a haste I havent hhad a chance to investigate. After looking at the problem...

...the API is just doesn't update period. It is frozen on the god knows how old information. Even the popular stations are frozen, the IDs are right for them because they don't change often, but everything else is incorrect like the song titles and the listener count.

The website search directly from shoutcast.com works. It is the API that doesn't.

If you are using the same database for both API and website scripts then API is somehow lost access to that database and is stuck on cached information.

Sorry I wasn't too clear before.

Killzone_Kid
16th October 2009, 13:42
Try API:

http://yp.shoutcast.com/sbin/newxml.phtml?search=[yourkeyword]

Then try the same keyword at

http://www.shoutcast.com

The same station information would different on both searches, which should be the same.

medicalfix
16th October 2009, 13:53
I agree same issue here, and I have tried to do the same check... APIs are a little mess-up!

SC_faisal
16th October 2009, 14:16
Thanks for the headz up guys... Looking into it and fixing it ASAP!

f.

medicalfix
16th October 2009, 15:02
Great! Thanks so much! Please keep us posted ;)

SC_faisal
16th October 2009, 15:12
This should now be fixed... Check it out and let us know!

f.

Killzone_Kid
16th October 2009, 15:18
Yep, works like a charm ;) Thanks a lot!