View Single Post
Old 14th September 2004, 22:41   #29
doc-wagon
Junior Member
 
Join Date: Sep 2004
Posts: 1
I keep getting random crashes on editing a lot of tags from the playlist. This is since version 2.8x IIRC and still persists in WinAMP 5.04. I have yet to check 5.05 but I doubt it's fixed because its not in the release notes.
I also get this crash on different computers, so it's not my hardware or the installation that's faulty.

The problem is hard to reproduce, but here's some info on how it often triggers:
- I only use "classic" skins, so I don't know if it happens with the new skins too.
- It seems that WinAMP has to be running for some time, maybe a few hours, for the crash to happen
- The crash is after pressing "return" in the tag edit window. First it seems like it's just taking a few seconds to write the tag, but after 5 seconds or so I get the typical Windows GPF-message. The tag has not been written to disk (in fact the file has never been corrupted by the crash yet, but I wouldn't bet on that)

Here's what I normally do before the bug triggers:

It often happens after grabbing a CD, when I notice that I have a typo in one of the tag fields. So I do an "Enqueue in WinAMP" to the directory (Enqueue because WinAMP should continue to play what it's currently playing), move the playlist-cursor to the files at the bottom of the playlist, press "Alt-3", modify the tag, press return, press "down" key and repeat for the next file (I'm quite quick at that, maybe that's part of the problem?). This normally works for maybe 3 or 4 files, then it gets very slow after I press "return" to save the tag (maybe 3-5 seconds until the window closes). If this happens then I know it'll crash sooner or later (normally after 3 or 4 more files).

I hope that's enough info to reproduce (and maybe even fix ;-) this nasty bug?

Thanks
--Michael
doc-wagon is offline