View Single Post
Old 26th January 2010, 23:26   #11
melodian98
Junior Member
 
Join Date: Jun 2007
Location: Texas
Posts: 6
More on SC source not saving settings

Been following this thread for awhile, seems like there's no definite answer yet. I'm having the same problem of sc source "forgetting" its encoder settings between runs, here's my 2 cents worth: first of all, it doesn't matter whether I am admin or not. Tried it both ways, results are the same. (My "default user" has admin privelages anyhow.) I've checked the .ini files between runs, and the settings are correctly shown, so it does not appear to be a problem of insufficient privileges to write the file. As best as I can tell at the moment, the problem has *something* to do with the enc_aacplus.dll codec. Here's my reproduceable steps:

1. Removed enc_aacplus.dll (physically moved the file to a temp directory).

2. Start winamp with sc plugin enabled. All five encoders are shown as "none".

3. Set encoder #1 to type mp3 at 128 kpbs 44100 hz stereo. Close WinAmp.

4. Restart winamp, encoder #1 has retained settings as expected. Change to any other mp3 bitrate (160 kpbs for example) and setting remains "sticky" when winamp closed and restarted.

5. Closed winamp, moved aac-plus codec back into \program files\winamp\plugins. Now when winamp is restarted, encoder #1 has changed from mp3 (its last setting) to AAC+ at 48 kbps. No matter what this is changed to during this session, when I close winamp and restart it the codec type defaults back to AAC+ at 48 kbps.

6. Tried setting both codec #1 and codec #2 to mp3. When closed and restarted, both show aac+ at 48 kpbs.

7. Set codec #1 for mp3 and codec #2 for AAC+ at 32 kbps. When closed and restarted, #1 has reverted back to AAC+ at 48 kbps. #2 is still aac+ as set, but has retained 32 kbps bitrate setting.

I can't explain this. I don't know if it's the aacplus codec specifically causing the problem, or if *any* secondary encoder in the plugin dir would cause the same behavior. However, I'd be curious to see if anyone else who is having this problem with "non-sticky" settings could try to replicate the steps above and see if your results are the same. Perhaps this would give the programmers a clue as to how to fix this bug once and for all. Thanks.

update: I've found a newer version of the aacplus codec, dated 11/21/08. Same results.


------------
A few specs on my system:

AMD Athlon CPU @ 1.6 ghz
512 mB RAM
Windows XP SP2 (clean install for this test, no antivirus, bare minimum of background processes running)
Winamp 5.35 (have tried several versions, same results)
Shoutcast source 1.9.1
enc_aacplus.dll dated 9/26/06

Last edited by melodian98; 27th January 2010 at 02:22.
melodian98 is offline