View Single Post
Old 11th March 2016, 15:00   #3
Junior Member
Join Date: Mar 2016
Posts: 12
I have tried using a cmd file as below:
ExecWait '"c:\program files\[company name]\usbdriver\uninst64.cmd"
as well as
ExecWait '"c:\program files\[company name]\usbdriver\wdreg.exe -inf file.inf -silent -delete_files uninstall"'

and what always happens is that the installer deletes the files before they can run even though the delete commands come after the ExecWait commands.

Because the program I am calling always prints out its version when it starts, I tried piping the output to a file (i.e. wdreg.exe ... >>file.txt, and that doesn't help either. I did find the source for that program, and even tried commenting out the print line in it, without luck. As far as I can tell from that program, it doesn't call any other programs. As I said before, I suspect that that particular program is the issue, as start /wait doesn't work with it either. I should note that the wdreg.exe program is a console mode application.

Unfortunately, the program does not have a wait option, either. To be honest, I am not sure what NT job objects are.

I've attached a copy of my cmd file, renamed with a .txt extension, as well as a copy of the nsi file with names redacted.

Thank you very much for your help.
Attached Files
File Type: nsi InstallUSB.nsi (6.5 KB, 494 views)
File Type: txt uninst64.txt (221 Bytes, 390 views)
jwptrek is offline   Reply With Quote