View Single Post
Old 11th April 2016, 17:10   #10
Junior Member
Join Date: Mar 2016
Posts: 12
Actually, I tried it both with and without the call to cmd, and with the correct quotes without luck. I didn't check the quotes when I pasted it. I also tried calling my .cmd file, as below:

StrCpy $8 'cmd /k start "" "c:\program files\[companyname]\usbdriver\driveruninst64.cmd"'

without luck.

I did go back and try again with the correct quotes with ExecWaitjob, calling the executable, and it seems to work now. I thought I tried the current iteration, including options to the executable, with correct quotes before, but I must not have. See below:

StrCpy $8 'cmd /k start "c:\program files\[company name]\usbdriver\wdreg.exe" -inf usb64_drv.inf -silent -delete_files uninstall'
!insertmacro ExecWaitJob r8

I am just glad it appears to be fixed now. I'd have preferred calling my cmd file, as it hides things a bit better, but I will go with what works. Thanks for the help.
jwptrek is offline   Reply With Quote