View Single Post
Old 20th October 2015, 21:20   #15
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Hi Victhor,

I really appreciate the work you've put in so far updating this skin. I have enjoyed using it for the past few days and instead of waiting for the next release, I've decided to mention some of the issues I'm having.

1. When the skin is first loaded, the seek bar runs in it's highlight mode (like when you point to it). After I point to it, it then runs normally for the remainder of the session.

2. The songticker scrolling option is enabled, but long song titles are truncated instead of scrolling on both the Now Playing and PL+ cover panels. I use a rather long custom ATF string, so this cuts off most of the title on the PL+ cover panel.

This is less of an issue when running the skin fullscreen. But fullscreen makes some of my artwork look bad (those with low resolution, 300x300 or less). I've been in the process of updating all of my low-res artwork to at least 600x600 (which looks good on my system with this skin in fullscreen mode). All my artwork is embedded in my audio files and I don't use the same image for all the songs in an album, so it is taking a while to find larger images and update all my audio files that need larger images.

3. The Playlist Editor opens in a side panel (which I like) and even-though the "show playlist search" option is enabled, I don't see the search bar.

Also when I switch the SUI to the media library panel, the Playlist Editor side panel closes (it stays open when switching to all the other SUI panels).

4. The artwork reflection(s) on the Now Playing and PL+ cover panels will randomly show the wrong or a corrupted image under the main artwork image after the next song in the playlist starts. It will show the reflected artwork image of the previous song or a corrupted image of current song's artwork.

This error will correct itself eventually (sometimes after a few more songs play and sometimes it takes several more). I can also correct this error if I force a redraw of either panel by switching to another SUI panel and then switching back. So I think this is caused by a timing issue somewhere that's associated with loading the artwork for the next song. Embedded artwork may be causing Winamp to take a little longer to load the images than it takes for separate external images.

I couldn't find the logic that controls the loading these reflected images. But just guessing for the Now Playing panel, I think the "lookagain.setDelay" in the AlbumArt.m (and related AlbumArt.maki) needs to be a little larger. In the Now Playing widget (for use with other cPro skins) it is set to "1000" (like it is in this skin) for cPro 1 version skins and "2000" for cPro 2 version skins. If this panel just needs a little more time to setup the images, maybe a delay value of "1500" will be large enough. I would try this myself, but I still don't know how to compile a 'maki' file.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote