View Single Post
Old 17th October 2019, 20:10   #13
Senior Member
Join Date: Oct 2018
Posts: 148
Originally Posted by Wineroz View Post
That is correct: the culprit is the >>Winamp.File<< string

; #4



And my registry hacks stopped working; kind of

I testes them again on the same machine with the same system but put a different [backup] drive- and they worked

So much later [i.e. today] I restored my system on the main drive. And I still can execute them, but apparently the point 4 is problematic. Because I am unable to access that location


Here is what happens

After adding the file to the Registry there is a pop up saying "Not all data was successfully written to the registry. Some keys are open by the system or other process, or you have insufficient privileges to perform this operation". So by happenstance with the very first try I came up with such solution on my own

1] Open Registry

2] Navigate to that Key [i.e. the UserChoice "folder"

3] Right click and select

Permissions... > Security > Group or user names > RESTRICTED

4] Now go to to the windowed box below

Permissions... > Security > Permissions for RESTRICTED > Full Control > Allow

and check that box

5] Click Apply to expand the access

And this worked for the time being: the key of "UserChoice" from that path was unblocked for changes. So I applied them and finally saw the icon I have chosen for APE in my filemanager.


A] I was not able to repeat that for TTA. Its UserChoice key stayed locked no matter how I tampered with access rights

B] APE after double left click was no longer opening in Winamp but some other software

So for problem "A" I associated APE with Winamp by the means of

Open with > Choose another app

and selected Winamp with the "Always use this app to open . ape files". The APEs were once again played in Winamp- but I lost my icon [as the acquired the default "Winamp.File" icon]

As for problem "B". I tried this solution, but using

psexec -s -i -d regedit

command in the CMD for the software from that PSTools package. But Registry opened with that somehow shows only limited number of entries. The whole "UserChoice" key is absent in it, while the list of files is suddenly short [like a half of the height of my screen instead of the normal full heights multipled few times]. And if I go back to normal Registry and then all the entries are back. I tried adding my REG files when using this psexec tool and when using the normal Registry. I also tried "Run as administrator" option from the shell menu executed on shortcut to the [normal] Registry- but that place was still blocked

And then I tried to deal with "A" again. After some joggling / repeated executions I managed to once again see my chosen icon. But then again, the file was being opened not n Winamp. So I associated it with Winamp and lost the icon. And did that whole thing again. So I tried associating it with Media Player Classic. APEs were now opened in it but that key UserChoice was still blocked- so MPC managed to replace Winamp with itself in that blocked location of Registry, but did not unblock it for the User editing the Registry. Also associating APE with Winamp has no problem with that restricted access

How to I get rid of that blockade? And why, just why, are not all of the audio formats added to the Registry by the Winamp by default with individual names [thus avoiding that culprit "Winamp.File" generalization?] As my problems with tweaking of the Registry and lack of such problems by Winamp and Media Player Classic show- this must be changed by the developers! So that the users will not spent endless hours on trying to avoid some glitches made by Microsoft
Wineroz is offline   Reply With Quote