View Single Post
Old 10th October 2010, 02:21   #322
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
I just tried using sc_trans in windows 7 and am dismayed to find that capturedevice is broken

I set it as follows

capturedevice=Recording Mixer (kX 10k2 Audio (3550) - Generic)

as that is the name of the capture device I want to use

log shows

code:
2010-10-10 13:08:54 I msg:[captureWin32] Locating capture device
2010-10-10 13:08:54 D msg:[captureWin32] Begin audio devices
2010-10-10 13:08:54 D msg:[captureWin32] device [Microphone (VIA High Definition]
2010-10-10 13:08:54 D msg:[captureWin32] device [Front Mic (VIA High Definition ]
2010-10-10 13:08:54 D msg:[captureWin32] device [Microphone (VF0420 Live! Cam Vi]
2010-10-10 13:08:54 D msg:[captureWin32] device [Recording Mixer (kX 10k2 Audio ]
2010-10-10 13:08:54 D msg:[captureWin32] device [Stereo Mix (VIA High Definition]
2010-10-10 13:08:54 D msg:[captureWin32] End audio devices
2010-10-10 13:08:54 E msg:[captureWin32] Device [Recording Mixer (kX 10k2 Audio (3550) - Generic)] not found.



so I tried to set capturedevice=Recording Mixer (kX 10k2 Audio

still doesn't work ... because the last character in the device name that sc_trans gets from windows is a space ... no matter how I enter the name in the config file, the trailing space is ignored from the config, therefore, no match

This SHOULD be an easy fix ... if you're only getting 31 characters from windows for the device name, try to match at most 31 characters from the capturedevice entry

I can successfully capture from the 1st, 3rd and 5th device you see in the log by using the 31 characters as shown in the log ... because no trailing space in the device name

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline