View Single Post
Old 20th September 2012, 17:19   #419
big_blue
Member
 
Join Date: Jul 2011
Posts: 63
Quote:
Originally Posted by Aminifu View Post
Your sound chip should be able to handle more than 44800, but let's go with that because that is what is in the Windows control box. Your Windows box is set for 24/44800 right, not 16/44800? The enable exclusive mode is checked and the option below that is not, in the Windows control box, right?

Clear the top box beside "Slave to etc" and put 44800 in the box on the right. Check the next box down and put 44100 in the box to the right. Check the next box down and put 44800 in the box to the right. Check the box at the bottom next to "Free device etc". Those should be the only 3 boxes checked, except for the top box when you want to run in exclusive mode. The only other control is the bit depth, I suggested "24+8". You can also try "Best available".

I have my upsampling values set to 96000, 44100, and 96000. Windows is set for 24/96000.

Make these changes while a song is playing. Maiko ignores changes made when a song is not playing, on the mixer page too, except now for the delay settings (and maybe the input balance settings, SilverBird775 has not clarified whether a song needs to be playing or not for those controls).

Stop the song, then restart the song and check that all your changes are still the same. Shutdown WA, restart it and start a song, then check that all your Maiko settings are still the same.

One last thing, pertaining to how your music sounds. Now that you're using the Nullsoft plug-in again, check the WA equalizer. I suggest you start out with all the controls set to the mid line (no increase or decrease in the frequency bands). Small adjustments can be made later after everything else is working. You maybe should turn off Enhancer too until Maiko is stable. Check the control panel for the Realtek chip. Make sure all sound effects and equalizer controls are turned off. Make sure the bit depth and sampling rate is the same as you set in the Windows control box, 24/48000.

The bit depth and sampling rate should be the same in the Realtek control, the Windows control, and Maiko exclusive mode to avoid conflicts.
Thanks, I set it up like you said, but used 96000 as the sample rate instead and it sounds good. I'll look into the equalizer soon too.

Quote:
Originally Posted by SilverBird775 View Post
not clarified whether a song needs to be playing or not for those controls [balance tab]
As you please. As a general rule for a matrix\mode setup you need to start music at least once so the correct matrix will be choosed.

I can still hear pops every so often in the rear speakers when certain audio plays through them. Could it be clipping? The rears aren't set above 1 in the mixer.
They are set a LOT above 1. MAX = abs(0.95) + abs(-0.95) = 1.9 which is a massive amplification. Even when the signals are summed in antiphase it does not mean the Left & Righ channels are highly interosculated anytime. When the signals are going naturally antiphase they become inphase by matrix settings and you are getting almost double amplification and a powerful clip. Keep the line sum below 1.0.
I believe that solved the issue of the rears clipping. It was very simple, only took the actual developer to notice it, haha.

I'm not sure how the math is done here but is it advisable to use different signal values? like, for instance

.50 -.43
-.43 .50

If you have a recommendation as to setting the rears up I would be very grateful, as I like the effect of having the rears put out channel-specific sounds, however I also have to level them out with the front side speakers. If I want their sum to be around 93 (during the antiphase/inphase things) what is an optimal way to accomplish that?
big_blue is offline   Reply With Quote