View Single Post
Old 16th May 2007, 11:14   #18
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
@Cianca

Ohh, I don't look in there for bug reports. I look in the Bug Reports forum.
The only bug we knew about was the crash on sync/transfer,
not anything about a crash/hang when creating a new playlist.

I'm assuming here that your firmware must be 2.x, and therefore the Zen is PlaysForSure compatible and is using the pmp_p4s interface, because my Zen still has 1.x firmware using pmp_njb interface, and I can't reproduce the problem.

The easiest way to confirm is to disable pmp_p4s.dll and then see if your zen is still recognised. If no, then the firmware is 2.x. If yes, then the firmware is 1.x


@JacknLime

With Winamp closed, open winamp.ini in Notepad

Locate the following line under the [Winamp] section

video_gdiplus=

Is it set to video_gdiplus=0 or video_gdiplus=1 ???

1 = enabled // uses GDI+ renderer

0 = disabled (uses Hardware Overlay or DirectDraw method instead, depending on settings in Winamp > Prefs > Video)

Change it to the opposite of whatever yours is currently set to.

Save winamp.ini with your changes then restart Winamp.
Let us know if there's any difference.


Note: under Vista, winamp.ini will be found via:
%appdata%\winamp\winamp.ini

You can type %appdata%\winamp into the Explorer address bar and hit Enter
and it should resolve to one of:
c:\users\<username>\AppData\Roaming\Winamp
c:\users\<username>\AppData\Winamp


@alnis

I can't reproduce that. Anyone else?
Is 'always on top' enabled for Winamp?
Is 'always on top' enabled for that other program you've got running, or for any other programs?


@jmsallo

Oops. Yup, I can confirm that CD Playback is totally borked under Win98.
The only way I can get a CD to play is via:
The Add/Open Folder or File method, and browsing to the CD Drive.
CDDB doesn't work whatsoever.
The Rip & Burn view in the ML never detects the CD (says 'No CD')
Main Menu > Play > Audio CD doesn't work (just clears the playlist).

Hopefully this can be addressed and fixed - assuming we still even support Win9x.

In the meantime, you can use in_cdda.dll from Winamp 5.34 | mirror

Note, I'm not sure if it only behaves this way if the Sonic Engine isn't installed.
I don't have a CD burner on this old text Win9x machine, so I keep Sonic Ripping/Burning Engine unchecked in the Installer Options.
Please could you confirm whether you installed Sonic or not?
(though, as far as I know, Sonic/Burning is also broken under Win9x too).

It's basically not looking too good for Win9x users.
Alas, official support for Win9x is as good as over. Sorry.


The only issue I can reproduce under WinXP is if the CD is playing and you're in, say, the Rip & Burn view in the ML, and then switch to another view with a lot of data, eg. a large stored playlist or the Local Media > Audio view, then there's a slight glitch in playback whilst the new view is loading.
DJ Egg is offline   Reply With Quote