View Single Post
Old 5th August 2012, 04:50   #1
ralish
Junior Member
 
Join Date: Nov 2006
Posts: 4
Incorrect docked toolbar handling on some multimon configs

I'm able to reliably reproduce what appears to be a bug in Winamp's Docked Toolbar feature on certain types of multi-monitor configurations. Assume we have a multi-monitor setup consisting of a 2 x 3 grid of displays (ie. three on the bottom row, three on the top row). The size, resolution, and other properties of the displays are irrelevant as it seems to be a topology issue, so we can assume that they are all exactly the same displays in this case.

If I have Winamp placed on any of the bottom row of displays and enable the Docked Toolbar in "Top" mode, Winamp will correctly place itself at the top of the given display and autohide, however, when "hidden", it actually appears at the bottom of the display above it.

In contrast, if I have Winamp placed on any of the top row of displays and enable the same, Winamp will reposition itself to the bottom row of displays, giving the exact same effect as if I had enabled "Top" mode while Winamp was located on the bottom row of displays.

It may also be relevant that the middle display on the bottom row is the primary monitor. This has the effect of seemingly making all the displays above it exist on a negative Y axis with respect to window positioning while the two displays to the left of the primary have a negative X axis. I wonder if Winamp is assuming that a negative Y axis position is never visible? This assumption is potentially incorrect in these sorts of multimon configurations.

It would be fantastic if this could be looked into as it does make this feature unusable in these configurations.
ralish is offline   Reply With Quote