View Single Post
Old 31st August 2002, 00:38   #6
Daab
Junior Member
 
Join Date: Jun 2002
Location: Jerusalem, Israel
Posts: 19
Hi y'all,
This thread seems to combine both of my points...

First, a bug / usage mistake:

1. Installed NSIS 2a7
2. Copied "makensis.exe" and the "plugins" directory elsewhere
3. Tried to compile a script from the command-line, by running the "makensis.exe" that is outside $NSISDIR
4. Got an access violation after the compiler wrote:
Processing plugin dlls: "C:\<...the new directory...>\plugins\*.dll"

Notes:
* the DLLs I'm using in the script are naturally all in the plugins dir
* I tried both using and not using the "PluginDir" command - same results
* If it's any help, I used only absolute paths, with no whitespaces
* When I run the makensis.exe in the original installation path the compilation works

Is there some silly newbie mistake I'm not aware of?

Now secondly, I've been wanting to express my sincere and complete gratidue to all of the NSIS developers and contributors. I usually don't like to write in public forums "fluff" that doesn't serve a specific purpose, but NSIS is simply a remarkable piece of software:
* Functionality that equals any other related product
* Learning curve easier in comparison to any other commercial product
* Good reliability across many platorms (95 to XP) - again something that most of the professional installation makers cannot guarantee
* Great customization capabitilies (and keeps getting better)
* Continuous and useful support from the user community
* Absolutely free for absolutely any purpose

Great work!
Daab is offline   Reply With Quote