View Single Post
Old 30th January 2004, 18:05   #17
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,812
For Audio CD's, wnaspi32.dll is only used if "use sonic engine" is UNCHECKED in the CD Input plugin config.
Naturally, "enable digital audio extraction" also needs to be checkmarked.
You may also need to uncheck "sample input from soundcard".
Any changes to in_cdda.dll config require a winamp restart.

Re: DirectSound config
If "Allow hardware acceleration" is grayed out,
then this means that either your sound card or onboard sound chip is too old and doesn't support hardware mixing, or your (motherboard chipset / soundcard) drivers and/or DirectX need updating.

Or, if you paid a large amount of money for a so-called professional sound card, if it doesn't support hardware mixing, then I'm sorry, but you were ripped off!

In the Device tab, there is a drop-down menu which lists all the available devices.
The default device is "Primary Sound Driver".
This relates to whatever device is set as default in Windows Control Panel (Sound / Multimedia > Audio tab > Playback)

AC'97 will only be an option if your motherboard uses the AC'97 onboard sound chip.
If it doesn't, then it will list whatever other sound chip your motherboard uses, or if you've got a proper pci soundcard, then it will list the soundcard device driver instead.
Alas, I can't tell you what your sound chip is unless you tell me what your pc or motherboard model # is, and I can't tell you if you have a proper pci soundcard (instead of an onboard sound chip) unless you tell me.

If you've followed the exact instructions above, then you should definitely have gapless Audio CD playback with Winamp, for gapless mix CD's that are recorded with no gaps.




For gapless mix cd's that were ripped to MP3, then as well as adding some value to the "buffer ahead on track change" slider in out_ds config (eg. somewhere between 500 and 1500ms), you also need to checkmark "remove silence at beginning/end of track" in the "Other" tab.
The default "Cut-Off" setting of -40dB should suffice, though you can try a higher value, eg. -35dB
(note, anything higher than -30dB is NOT recommended, but you can try -25dB if you really must).

If you can still hear a gap/glitch then I've no idea why. It works perfectly for the large majority of users.
I can only assume that it is either something to do with the way you ripped the cd, or a problem with your sound drivers or config, or maybe because you've installed some shabby 3rd-party replacement mp3 plugin (eg. in_mp3pro or in_mad).

The only 3rd-party mp3 replacement plugin you can use for native gapless playback support is in_mpg123,
as this has an option in its config to "strip silence", and therefore the out_ds workaround (Other tab > Remove Silence) is not required with in_mpg123.

Though "Buffer ahead on track change" value is required no matter which method you choose.

Also note, any enabled "crossfade/fade" settings in out_ds config
will override gapless playback settings.
eg. if the crossfader is turned on in the main Winamp window > config drawer > EQ
or if any value is manually set for "on start" and "on end of song" in out_ds config > Fading tab.
ie. you need to disable these two settings (fade: on start & on end of song) if you want gapless playback to work.

Pretty simple & straightforward actually, hehe
DJ Egg is offline   Reply With Quote