View Single Post
Old 21st December 2012, 22:55   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
so since it's all screwed up with all of the versions floating about, the following is going to happen and then i need input on what will happen after that...


rather than just shipping 2.81d and it not working on Vista and higher, we're going to include 2.82 in the installer and install 2.82 on Vista and higher (as it's DEP friendlier and less prone to crashing - ignoring the preset display issues, etc) and install 2.81d on XP and before (where that version seems to behave better).

that is to alleviate the posts about it just not working (something is better than nothing).


---------------------------------------------------------------------------

and so for the future, i now have a local build of chavs 2.9 which i've been flipping through presets to get it to crash and then trying to fix those crashes there and then (i'm doing this all on Win7 x64 so the fact it runs at all is welcome).

after re-reading everything, is it even worth me trying to sort out a 2.91 based on chavs (which sadly is based on the 2.81b source code) or just put this to bed and forget about it ? i'm willing to put in the time (if only to get it to a point were we don't get crash reports about it continually) but is this something that will help (and yes i know people don't care much now) ?


from what i can see, the main things that aren't right with the chavs base are:
  • still randomly crashes (have seen it and fixed 2 issues so far)
  • issues with rand(..) as per http://forums.winamp.com/showpost.ph...27&postcount=6
  • people don't like the ui / want it changed to one of the typically used mods (if so which one ?)
  • version resource is messed up
  • not doing presets correctly compared to 2.8x ? (not sure what can be done about that)
    main example is "convolution.ape" which is incompatible with Vista an up - blocking loading of it for the time being so it gives a UI indicator in the preset editor instead of bombing out, etc
  • fullscreen mode won't hold without using compatibility mode
  • overlay mode just shows a solid colour instead of the preset
  • anything else??

[edit]
as issues are deemed 'resolved' i'll strike them through, as well as adding anything new (assuming anyone cares and reports anything).

-daz
DrO is offline   Reply With Quote