View Single Post
Old 8th July 2022, 19:01   #64
rgreen
Junior Member
 
Join Date: Jun 2022
Posts: 29
Beyond Compare generates the following report:

HTML Code:
Version Compare
Produced: 08/07/2022 17:45:34
   
Left file: C:\Gallery\bin\uninst.exe     Right file: C:\Gallery\un\uninst.exe  
19 same item(s)  
2 important difference item(s)
I don't believe they are very important.

Differences:

Data: 5,484,709 bytes (left)
Data: 5,484,709 bytes (right)

Unknown (Compiled): 08/07/2022 17:28:02 (left)
Unknown (Compiled): 08/07/2022 03:21:04 (right)

It cannot be the uninst.exe binary.

I tried renaming the folder containing 'uninst.exe' from 'bin' to 'un', and it worked as long as it pointed to 'C:\Gallery\un' in the registry.

Vice versa: renaming the folder 'un' to 'bin, ditto in the registry, it ran at 96 dpi again.

It's the file-name-folder-name combo.

Installing to 'C:\Program Files\RG\Gallery', where the uninstaller file is 'C:\Program Files\RG\Gallery\bin\uninst.exe', tosses up nothing that unusual. 'uninst.exe' executes at 144 dpi. It works.

'C:\Gallery\bin\uninst.exe' is dpi-unaware.

I have been looking at this line of code:

PHP Code:
!define TEMP $INSTDIR\bin Temporary location of encrypted archives 
changed it to:

PHP Code:
!define TEMPUS $INSTDIR\bin Temporary location of encrypted archives 
Result: 96 dpi.

I don't want to divert - even further divert - this thread, an edifying the thread, from HiDPI in NSIS. If I discover that it is an actual NSIS bug, which I seriously doubt it is, I will post in a new thread. Thanks everyone.
rgreen is offline   Reply With Quote