View Single Post
Old 7th May 2011, 09:54   #13
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 168
Quote:
Originally Posted by wanchoo View Post
I am using Windows XP Pro.

CoreAVC Video Decoder is shown as the currently used filter.
So it can't find any audio codec to use. Well I don't know what damn codec your MKV has then. All I can do is suggest the following setup, which is the one I currently use.

Firstly uninstall the ACFilter. If it isn't working for you then there is no point keeping it and it could cause problems later.

Then download the CCCP codec pack from:
http://www.cccp-project.net/download.php?type=cccp

The CCCP installation includes a copy of Media Player Classic. I would deselect this as the bundled version is no longer current anyway.

Once CCCP is installed go Start -> Programs -> Combined Community Codec Pack -> Settings and you should see that the check box for CoreAVC is enabled. If so place a tick in there. As the CoreAVC decoder is working fine for you this should ensure it remains your primary h.264 decoder.

Make sure that ALL the boxes under FFDShow Audio Decoders are ticked. Then press Next and then Apply.

In Winamp go to the Input plugins section under Preferences and remove ;M4V;MP4 from the MP4 demuxer extension list so only M4A remains. Then open the configuration box for the Directshow decoder and add them there after MKV. This will result in any video files likely to contain h.264 being sent to the external filters.

Restart Winamp and pray!

With the above settings and codecs Winamp should be able to play just about anything. Please report back on how you get on.
CJ_Man is offline   Reply With Quote