View Single Post
Old 4th May 2011, 20:31   #1
Junior Member
Join Date: May 2011
Posts: 2
Uninstall Delete $SMPrograms failing

Ok... I've seen many threads on here that almost touch on this subject, or almost give an answer, but I'm still at a loss. I am creating Start Menus just fine as follows:

CreateDirectory "$SMPROGRAMS\Folder"
CreateShortCut "$SMPROGRAMS\Folder\File.lnk" "$INSTDIR\File.exe"

However, when I run the Uninstaller, it does everything just fine EXCEPT deleting these shortcuts and the Directory. Here is my script:

Delete "$SMPROGRAMS\Folder\*.*"
RMDir /r "$SMPROGRAMS\Folder"

I've also tried:

Delete "$SMPROGRAMS\ESP Vision\File.lnk"

I don't think it is a privilege thing, since I am the only user on this computer, and I have administrative priviliges. Oh, this is Win 7 32-bit, in case that matters.

I've used almost identical scripting on another file that worked fine... albeit was on Win XP. Any ideas to help?

Last edited by WoodyOne4U; 4th May 2011 at 21:06. Reason: Remove sensitive data
WoodyOne4U is offline   Reply With Quote