View Single Post
Old 3rd August 2012, 16:45   #1
djmx2006
Junior Member
 
Join Date: Aug 2006
Posts: 3
Latency problem - but not like you are expecting (i hope)

I have used shoutcast to broadcast for many years now as a DJ and running the shoutcast server. But I have run into a problem that has confused me completely.

I have a server configured (shoutcast 1 not 2) and am able to broadcast to it fine on a specified port 8000 for example.

I (or someone else) then try and listen back to my stream and get a huge buffer which never seems to complete.

The server is running Centos 6.2 with plenty of bandwidth, There is a firewall/router in between it and the outside world (potential problem), and then internet connection to me.

From shoutcast I connect and see data passing from the DSP to the server at normal speed for a 128k stream.

Correct me if I am wrong but as I understand when a listener connects on the main port (8000 for example), the sound is then streamed back to them on 8001 (i.e. port + 1)? That is all enabled in my firewall and data does get to my player as far as I can tell (just very slowly causing the huge buffer).

I accept this is most likely to be a network problem, but from a server end is there anything I can look at to see that the data is actually sending to the client at a normal speed? If so then that eliminates it to being server config, and points towards firewall.

I am just looking for pointers for how to narrow down the issue if anyone can help
djmx2006 is offline   Reply With Quote