View Single Post
Old 18th April 2009, 08:26   #24
Daniel_Sturza
Junior Member
 
Join Date: Jan 2009
Location: Romania
Posts: 5
Winamp crash when using enqueue ...

I had this problem before ... but first the specs:
Winamp 5.5.5.2419 (clean install, no 3rd party plugins)
Language : English
Skin : Classic
OS : Windows XP SP2/English
I reproduced this "bug" on two systems:
1. Gigabyte P35-S3G/Intel Quad Core 2 Q6600 2.4GHz/2048MB RAM/Gigabyte GeForce 8500GT/Creative SB! Live Value and/or OnBoard Sound Card/DirectX 9.0c.
2. Gigabyte GA-8IPE1000-G Rev.4/Celeron 2.8GHz/2048MB RAM/
ATI RADEON 9250/Creative SB! Live Value and/or OnBoard Sound Card/DirectX 9.0c.
No antivirus installed.
No Creative software installed except the sound driver (basic installation, no additional Creative Suite/Media Center and stuff).
Doesn't matter which sound card I use (the onboard one or the Creative) on either system, the "bug" still persists.
I am playing only mp3s and flacs (the playlist is around 16k titles, default formatting titles).

Plugin : gen_jumpex.dll v1.0.4 (Build 767)

The problem :
When I press "Q" on the keyboard (with playlist being the active window) every few seconds (at least 4-5) nothing bad happens.
If I press "Q" a little bit faster (every 2-3 seconds), the selected item is added to playlist (at the end) instead of queue.
If I press "Q" even faster (as fast as I can type), I get :
"Winamp has encountered a problem and needs to close. We are sorry for the inconvenience."
Details : "AppName: winamp.exe AppVer: 5.5.5.2419 ModName: gen_jumpex.dll ModVer: 0.0.0.0 Offset: 00002fda".
On all three cases it doesn't matter if the selected item it's the same or not, nor where am I in the playlist (in the end or the beginning).

A while ago I was unable to use enqueue at all (threadid=301690) - an internal build at that time solved the problem in the sense that it didn't crash at all (winamp v5.5.4.2165 + gen_jumpex.dll v0.99.4 build 749). Later on I discovered the thing with added items on playlist instead of queue, but I was happy to be able to use Enqueue, so that was only a little annoying.

I've also tried winamp 5.5.5.2419 + gen_jumpex.dll v0.99.4 build 749 ... but the "bug" curiously persists ... so I'm not sure if it's a plugin "bug" or core "bug" or something in between ...

I've learned to be patient so this is not a "critical" bug, but you might want to look into this because the added items to playlist instead of queue thing perpetuates from gen_jumpex.dll v0.99.4 build 749 and at some point perhaps it will become "critical".
Also I have to mention that if I have reasonable amount of titles in playlist (around 1-2k), all is good, no crashes, no added items to playlist.

Thank you.
Attached Images
File Type: png winamperror.png (10.1 KB, 452 views)
Daniel_Sturza is offline