View Single Post
Old 16th June 2001, 22:58   #5
Harpoon
Junior Member
 
Join Date: Jun 2001
Posts: 3
Send a message via AIM to Harpoon
i just posted this yesterday..


irq sharing
i posted a topic a few days ago and noone helped me *cry*...
but the prob was win2k irq sharing.. nic modem sound and vid... reinstalling the ACPI driver to "standard pc" made my sound card and video card on different irq's, and now its %100.. if there is such a thing in windows...



*you video card and sound card are sharing an irq... thats why its skips this might help also.. i got it from gforcec's web site*


Q. I have Windows 2000 and all of my devices share the same IRQ, causing problems with my GeForce. How can I fix it?
This is a 'feature' of Windows 2000 - it uses ACPI in such a way that all devices share the same IRQ, usually 9 or 11.If you don't have problems, then leave it alone, but if you do get problems, use one of the procedures below (note that for Windows 2000 Microsoft recommends that you disable the PNP OS option in your BIOS before installation):

Note that some people find that disabling ACPI means they lose all power management functions.

This procedure, submitted by Steve Aucoin, will allow you to disable ACPI without reformatting:


Disable PNP OS and ACPI in your BIOS, if you can (you may not be able to, and it is not always necessary) - if the option is not available try installing the latest BIOS update for your motherboard. You can get help with finding out what BIOS you need and instructions as to how to flash it at Wim's BIOS page

Reboot. Go to Control Panel - Hardware and double click on My Computer in the hardware manager.

You'll see ACPI - get into its properties and click to install another driver. When prompted, look under the Microsoft section and install the "Standard PC" driver.

Reboot. At this point Win2k will try and reinstall all devices on your system so install any drivers you are prompted for (have them all handy) and reboot. Finalise any drivers you may be prompted for on the 2nd boot and reboot again.

With all your drivers re-installed, take a look in hardware manager - and every device should have its own IRQ.

Be warned that this method is discouraged by Microsoft - see the note at the bottom of this Knowledge Base article.

You can select not to enable ACPI when you first install Windows 2000 - During the first phase of Setup, at the Setup is inspecting your computer's hardware configuration screen, press the F5 key. You can select 'Standard PC' instead of an ACPI option.

You can also press F7 during the portion of setup that displays the message to press F6 for adding SCSI drivers. This configures Setup to not try ACPI machine types.

If for some reason the above procedures doesn't work, follow the following procedure, provided by Aaron Dierking, to disable ACPI from the outset.

Copy the i386 directory off the Windows 2000 CD onto your hard drive.

Go into the i386 directory on your HDD and find the txtsetup.sif. Open it with notepad.

Find the [ACPIOptions] section in the file. Below will be a setting for ACPIEnable - set it to 0.

Install Windows 2000 using your hard drive copy.

Back to Index

Harpoon is offline   Reply With Quote