View Single Post
Old 27th June 2015, 17:38   #6
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,766
Hi Abyss08ofEvil,

Just guessing, maybe the format profile (i.e. Base Media/Version 2) is the problem. All my mp4s' profiles are just 'base media'. There are a ton of video format variations.

Anyway, MetaFox is only for repackaging a video file as a MKV file. I only use it as a last resort, if I can't get the original video to play. Exactly what error did you get while trying to use it? I don't have Windows 8.1 and MetaFox may need to be run under Administrator mode on that OS.

It can be tricky getting DirectShow stuff to register correctly or be used if there are other installed codecs associated with the same file types. I use the "Codec Tweak Tool" to help me with those problems (http://www.videohelp.com/software/Co...l/old-versions). I like learning how stuff works, but it can be very frustrating at times.

Since the FFSox Player plug-in works for you, you probably are better off using that and not having to be bothered with correctly setting up separate codecs. Just be sure to use the configuration option for Winamp's "in_dshow.dll" plug-in to remove the video file extensions that you have set up the FFSox Player plug-in to handle. You don't want both plug-ins trying to process the same file types at the same time. You don't have to uninstall the DirectShow stuff if you want to be able to switch between the 2 methods, but you should properly enable and disable associations to prevent possible conflicts.

If you're also using the FFSox Player plug-in for non-video files, then also eliminate any possible conflicts with the other associated Winamp input plug-ins. I've only used the FFSox Player plug-in for video files and have no direct experience on how well it handles non-video files.

Good luck.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v20H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote