View Single Post
Old 30th December 2001, 00:19   #2
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
Common 'bugs' (please read BEFORE posting on this forum)

LEGACY SUPPORT

Note that many of these issues relate to older versions of Winamp.


NOTE: All confirmed non-bug posts / newbie questions will be locked / deleted / moved to techsupport. Please read this doc carefully before posting.


1. Various strange problems on systems with SB Live / SB Audigy sound card.
Creative PlayCenter setup silently installs a plug-in called gen_nomad.dll into Winamp directory; this plug-in is useless for most people and has several heavy bugs (you can call it a sabotage if you prefer it that way). If you have installed any crap from Creative recently, go to winamp/plugins and delete gen_nomad.dll file. More info here.

2. "Installer CRC invalid" error when trying to install.
If you get this error, the installer file you have downloaded is damaged; try downloading from different site (recommended: winampheaven); if you keep getting that error after redownloading, scan your system for viruses. More info here.

3. Constant high CPU usage even when not playing, problems with shutting down, etc.
Go to winamp/plugins and remove gen_mircex.dll; as far as I know, newer version of that plug-in fixes these problems.

4. Problems with playing MOD files.
Report them here.

5. MMSYSTEM errors, "Couldn't create DirectSound object", error code: 88780078 / 80070057, etc.
These are NOT caused by Winamp code; do not post them here, use tech support forum instead. All these errors are explained in TSGH. Some of them can be quickly fixed by switching between waveOut/DirectSound output plugins, or by updating sound card/chip drivers and DirectX.

6. Incorrect pitch (and other weird problems) on AC97 sound cards.
Sorry, not our bug. AC97 onboard sound chips are shit, get a real sound card instead if you can. Updating drivers and DirectX might help.

7. Output plug-ins "not working" with MIDI, WMA and CD.
For more info about converting MIDI to WAV/MP3/whatever,
for pre 2.9x - read this, for 2.9x read this.
If you want to convert WMA, you need WMA plug-in from Winamp v2.5 or older.
If you want to rip CDs with Winamp, get CDReader for pre 2.81 versions, for 2.90/1 enable digital audio extraction in in_cdda config, for 2.92 & beyond use the CD Ripper built-in to the Media Library.

8. Problems with streaming formats other than MP3.
It seems that all third-party MP3 plug-ins assume every URL beginning with "http://" to be an MPEG stream; remove any shit like MAD, mp3pro and see if you still have this problem.

9. Problems with MIDI playback.
RTFM

10. Sound coming only from front speakers.
Go to Winamp preferences / plugins / output, select DirectSound output.
More help/info here

11. Skipping, popping/crackling, freezes when seeking / starting playback etc.
Another case of poorly written soundcard drivers. Try switching output plugins (waveOut/DirectSound).

12. Incorrect time display and/or broken seeking with VBR MP3 files.
First, if you have mp3pro plugin, delete it - it has TONS of bugs. If you don't have mp3pro plugin, your MP3 files probably don't have correct Xing header; you can fix them with this program.

13. Problems with unicode filenames (filenames with international characters on NT/2k/XP).
Known issue, will be hopefully fixed in Winamp 5.x
More info here

14. Missing extensions under "All supported formats" in Open File dialog.
Windows bug. You can 'fix' it by removing input plugins you don't use and/or unassociating less important extensions in MIDI, MOD and WAV input plugin configurations (info).

Full info can be found at: (Please read these before posting here!)
The Official Winamp v2.x Bug List (full list of all confirmed v2.x bugs)
The Official 3rd-party Plugin Bug List
TSGH -> Useful Links
How to write a useful bug report

Before posting here, also make sure that you have the latest version of Winamp 5.x without any third-party plug-ins installed, also try updating your sound card and video card drivers and installing the latest DirectX - this really solves most of problems people report here. Check if other media players (eg. Windows Media Player) have the same problem; if so, it's definitely not our bug. It is strongly recommended that you post on tech support forum first before posting here unless you really know what you're talking about.

Also don't forget that Winamp has a few million users; if you think that you've found a major bug which makes Winamp totally unusable for some people, you can be sure that your system is to blame. Go to the tech support forum first.

__________________________________________________________

some misc links related to reporting bugs:

the longest not-our-bug thread ever:
http://forums.winamp.com/showthread....threadid=49692
(post your rants about creative and their crappy products there)

example of a good bug report:
http://forums.winamp.com/showthread....threadid=69333

example of a lame 'bug report':
http://forums.winamp.com/showthread....threadid=67952


[ Updated by DJ-Egg : 30/12/01 ]
[ Updated by DJ-Egg : 15/12/03 ]
peter is offline