View Single Post
Old 16th April 2018, 07:59   #1
milosz
Senior Member
 
Join Date: Apr 2006
Location: chicago
Posts: 123
sc_serv crashing, can't see why

My stream has run for a few years with few problems. However, sc_serv has been crashing lately, that is to say, the process terminates. No smoking gun in the log files. Sometimes crashes 2x per day, but then sometimes it goes a week without crashing

Here's my setup

Dedicated machine, not virtual
i3-2130 3.4 GHz, 8 GB ram
DNAS Version: 2.5.1.724
Platform: posix(linux x86) [Ubuntu 14.04.5 LTS fully up to date]

I have open files (ulimit -n, ulimit -Hn, & ulimit -sn) all set to 100000

here's sc_serv.conf

password=[password redacted]
adminpassword=[password redacted]
portbase=8000
logfile=/home/noir/apps/shoutcast/logs/sc_serv.log
w3clog=/home/noir/apps/shoutcast/logssc_w3c.log
banfile=/home/noir/apps/shoutcast/logs/sc_serv.ban
ripfile=/home/noir/apps/shoutcast/logs/sc_serv.rip
maxuser=2000
streamid_1=1
streampath_1=/noir
streammaxuser_1=1750
streampassword=[password redacted]
;streamadminpassword=[password redacted]
streamid_2=2
streampath_2=/insomnia
streammaxuser_2=250
disableicy=0
streamauthhash_1=[authhash redacted]
streamauthhash_2=[authhash redacted]


The ONLY things I see in the sc_serv logs are things like these

[timestamp] ERROR SRC 108.68.181.216:3805 sid=1] SHOUTcast 1 source connection denied for user (Îú °ÈMMS  NSPlayer/7.0.0.1956; {33715801-BAB3-9D85-24E9-03B90328270A}; Host). Bad password: 198.245.61.123Îú °`MMS 


[timestamp] ERROR [SRC 139.162.79.87:46156 sid=1] SHOUTcast 1 source connection denied. Bad password: œ+<M


Looks like someone trying to connect as source but being rejected b/c they don't have the password, and they are trying to connect some oddball port

These happen about once a minute, or maybe once every other minute, different IPs

These are coming from about 10 ~ 15 different IP addresses, most in the US, some in Canada, a sprinkling from Europe and Japan

The logs do NOT indicate that one of these occurs at the instant of the crash. There is **NO** log entry made when sc_serv crashes, so I do not know if the crashes are related to these or not.

Looks like someone trying to connect as source but being rejected. Bunch of strange non-ASCII characters in the log string that come out here on this thread as  . Are these some kind of probe? Or some kind of attack?

Any thoughts anyone? Why is 2.5.1.724 crashing where before it seemed very stable.

##############################
Please note I have tried DNAS v 2.5.5.733 some time ago, and it just crashes. My stream is 48k and 2.5.5.733 seems unable to deal with that. I've posted here about that elsewhere. So, because I can't get 2.5.5.733 to work, I am using 2.5.1.724 which has worked fine for a long time.
milosz is offline   Reply With Quote