View Single Post
Old 2nd June 2022, 03:25   #18
pkonduru
Member
 
Join Date: Jul 2015
Posts: 86
(solved) Finally!

Thanks Anders for the help!
The issue was that the nsis-3.08.zip when extracted was creating another sub-directory under which all the files were. Moving them to the right directory fixed it. For anyone looking to build NSIS 3.08 on linux, here's what I did. This is my ansible script but basically shell command that I ran on the linux box(RHEL).

docker_image_nsis_thirdparty_zip -- this refers to the actual nsis-3.08.zip file from the downloads.
docker_image_nsis_src_download_url --this refers to the nsis-3.08 src code from the downloads .
https://jaist.dl.sourceforge.net/pro...08-src.tar.bz2


COPY {{ docker_image_nsis_thirdparty_zip }} /tmp/
RUN mkdir /tmp/nsis &&\
yum install -y ca-certificates &&\
wget {{ docker_image_nsis_src_download_url }} -P /tmp/nsis/ &&\
yum install -y scons glibc-devel glibc-devel.i686 &&\
unzip /tmp/{{ docker_image_nsis_thirdparty_zip }} -d /usr/local/ &&\
mv /usr/local/3.08 /usr/local/nsis &&\
tar -xvf /tmp/nsis/{{ docker_image_nsis_src_download_url|basename }} -C /usr/local/src/ &&\
mv /usr/local/src/nsis-* /usr/local/src/nsis &&\
cd /usr/local/src/nsis &&\
echo "#define NSIS_CONFIG_LOG" >> /usr/local/src/nsis/Source/exehead/config.h &&\
scons SKIPSTUBS=all SKIPPLUGINS=all SKIPUTILS=all SKIPMISC=all NSIS_CONFIG_LOG=yes NSIS_CONFIG_CONST_DATA_PATH=no PREFIX=/usr/local/nsis/bin install-compiler &&\
ln -s /usr/local/nsis/bin/makensis /usr/local/bin/makensis &&\
yum clean all &&\
rm -rf /var/cache/yum &&\
rm -rf /tmp/*
pkonduru is offline   Reply With Quote