View Single Post
Old 7th May 2020, 20:10   #3
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 111
Quote:
Originally Posted by Aminifu View Post
That is a very old bug that has never been fixed. The default configuration for the Nullsoft MIDI Player input plug-in (in_midi.dll) can internally affect Winamp's volume level when playing other file formats after playing a midi file. There are no visible indications that the volume level was changed.

To change the configuration of the Nullsoft MIDI Player input plug-in use the Ctrl + P keyboard shortcut to open the Winamp Preferences window. Click on "Input" in the "Plug-ins" section on the left-hand side. On the right-hand side click on "Nullsoft MIDI Player" and then click the "Configure" button at the bottom. On the right-hand side of the "Device" tab of the Nullsoft MIDI Player Preferences window you should see the "Volume Control" options. Chose "None" in the selection box and clear the check-mark for the "Use as logarithmic" option. Click the "OK" button at the bottom to close this window and click the "Close" button (bottom left-hand side) to close the Winamp Preferences window. Restart Winamp and try playing a song.
Thank you for the quick answer. However, that did not fix the issue. I still see and hear the lower audio volume from Winamp with MIDI files. Do the newer Winamp prereleases and/or plugins have this MIDI audio volume fix? If it helps at all, my onboard audio from RealTek.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote