View Single Post
Old 8th April 2001, 15:24   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Weird!
I can't reproduce the bug; checking & unchecking the option works fine for me.

It's got nothing to do with Winamp.ini, I don't think there's a relevant line therein.
It's probably got more to do with a Win2k or IE5.5 security bug.

If it were possible, the easiest way to sort this would be to:
Goto : Windows Folder Options -> File Types
Scroll down for "File Folder" entry
Click "Edit"
Remove entries for Winamp (Play / Enqueue)
However, you can't do this, because Windows won't allow you to edit or remove the entries for File Folder from here . . . yes, M$ sux big time!

However, all is not lost . . .
The only way to remove these entries is via the Registry.

First make sure you have:
1. Made sure no files in the Winamp dir are Read-Only, including the dir itself.
2. Removed the checkmark for "Dir context menus" in Winamp Prefs -> FileTypes
3. Removed checkmark next to "Register files on Winamp start"
4. Disabled Winamp Agent (uncheck all 3 options in Prefs -> Agent)
5. Fully closed Winamp

Start -> Run -> Regedit -> Okay
HKEY_CLASSES_ROOT\Directory\shell
Delete the following keys:
Winamp.Enqueue
Winamp.Play
Winamp.Bookmark

Warning:
Only use Regedit to edit the Registry if you 100% know what you are doing.
Otherwise, get someone qualified & experienced to do it for you.

Let me know if this works.
Best of luck dudes!

ps.
chiphead
I'm not sure if it's possible that the MAD plugin could be causing the problem?
It's unlikely, but . . . I was wondering whether you've remembered to disabled the default Fraunhofer-based MP3 plugin again (in_mp3.dll) after upgrading to 2.74 . . . however, if I were you, I'd disable MAD & use the default plugin instead . . . it's totally awesome these days!

[Edited by DJEgg on 04-18-2001 at 08:43 PM]
DJ Egg is offline   Reply With Quote