View Single Post
Old 11th June 2006, 20:59   #1
Junior Member
Join Date: Mar 2003
Posts: 12
v5.2x "There is no disk in the drive . Please insert a disk into drive ."

After looking for a solution to my problem I found this "old" post in

Post All Winamp 5.21 Core Bug Reports In This Thread

P4 OC'd at 3.5ghz
2 GB of RAM
XFX Geforce 6800GS
ATI Radeon 7500
Primary WD HD 80 GB
Secondary WD HD 160 GB
NEC DVD Burner
Windows XP Pro SP2 w/ all updates

When I start up winamp (whether through the shortcut or by opening a song) I immediately get an error message with "Windows - No Disk" for a title. The error reads:

"There is no disk in the drive. Please insert a disk into drive ." (notice the blank space between drive and the period. Most error messages of this nature that I've googled for have a drive letter or directory path there. Just a blank for me).

I have 3 buttons for choices; Cancel, Try Again, or Continue. If I hit Cancel or Continue, it comes up again, and this happens for anywhere from 6-8 times. It is important to note that I have Alcohol 120% running with a virtual drive, an Ipod connected, a floppy drive, and I have a USB card reader with 4 slots. It is similar to a floppy drive in that each slot is portrayed by a drive, whether there is a disk/card in it or not. This is a bug in 5.2 In 5.111 this isn't a problem (that is the closest to 5.2 that I've tried). I did a full uninstall and reinstall multiple times, with numerous restarts and the problem wasn't fixed.

Most people in the forums have attributed this to a problem with a plugin. However, the only plugin I ever had was the ml_ipod plugin, and I have since removed that. I'm assuming I'm a black sheep with a stroke of bad luck, and some specific code interference with my system. I'll trust you guys to find a solution.

Thanks for all you do!

[Edit --> DJ Egg]
Sorry, but we can't reproduce this.
I can reproduce this 100%.

My setup:

AMD Athlon 64 3500+
1 GB of RAM
Geforce 6600
Primary Maxtor HD 200 GB (SATA)
Secondary Maxtor HD 80 GB (PATA)
Toshiba DVD Burner
Windows XP MCE 2005 SP2 w/ all updates (German)

While I also have Alcohol 120% installed, I am 99% certain this is related to my internal USB cardreader.
I do have a clean install of Winamp 5.23 and I tried almost everything to get rid of this bug because I initially blamed the cardreader drivers. This doesn't seem to be the case, this is an incredibly annoying bug in the new portable musicplayer plugin! Uninstalling this plugin fixes the problem.
On every startup the plugin seems to access every single empty cardslot multiple times and gives back this error message:

"There is no disk in the drive . Please insert a disk into drive ." (including the blank spaces)

You have to click cancel 8 times (2 times for each slot) for Winamp to finally startup. Every single time.

My current workaround is uninstalling the PMP plugin, but I really wish I could use it in future versions.
Gott is offline   Reply With Quote