View Single Post
Old 22nd December 2003, 09:20   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
Currently the Xfader button & slider in the (Modern/Bento) EQ is only configured to auto turn on "fade on end of song", but the two tracks definitely overlap. If they aren't for you, see below...

If you want it to also fade in on "start of song", then the Xfade configuration can be found at:

Prefs -> Plugins -> Output -> DirectSound -> config -> Fading tab.

Hi-lite "fade on start" -> checkmark "enabled" -> set a custom fade value.

_____________________________________________________________


If the Xfader isn't working, try the following:

Config drawer > EQ:
Move the xfade slider value down to 0
Turn the xfade button off

Go to: Prefs -> Plugins -> Output > DirectSound -> config:

Buffering tab:
Reset the bottom 2 sliders (prebuffer and buffer ahead on track change) to 0

Other tab:
Uncheck "remove silence"

Close Prefs -> close & restart Winamp

Now try the crossfader again in the modern skin EQ.


If everything is working, you should now be able to go back into DS config and reapply the 'buffer ahead' and 'remove silence' options, without it affecting crossfader.


Note:

1) The crossfader seems to return best results when using a value of 10 or higher, ie. by setting the xfade slider in the modern skin EQ and (optionally) the "fade on start" setting in out_ds config both to a value of somewhere between 10000ms to 20000ms.

2) To also enable manual crossfade when using next/prev commands,
you also need to adjust the following setting:

on pause/stop = enabled
use custom fade time = xxxx

where xxxx = eg. 8000 (for 8 seconds)
DJ Egg is offline   Reply With Quote