View Single Post
Old 13th November 2004, 20:01   #10
kevingpo
Junior Member
 
Join Date: Nov 2004
Posts: 42
Quote:
Originally posted by DJ Egg
The crossfader works perfectly ok.
<snip><snip>

If the Xfader isn't working, try the following:

Config drawer > EQ:
Move the xfade slider value down to 0
Turn the xfade button off

Go to: Prefs -> Plugins -> Output > DirectSound -> config:

Buffering tab:
Reset the bottom 2 sliders (prebuffer and buffer ahead on track change) to 0

Other tab:
Uncheck "remove silence"

Close Prefs -> close & restart Winamp

Now try the crossfader again in the modern skin EQ.


If everything is working, you should now be able to go back into DS config and reapply the 'buffer ahead' and 'remove silence' options, without it affecting crossfader.


Note: The crossfader seems to return best results when using a value of 10 or higher (ie. by setting the xfade value slider in the modern skin EQ to 10 or higher)
Personally, I prefer 15 to 20, heh.
Thanks to DJ Egg. Got the crossfader to work properly. There seems to be a bug or maybe not. The crossfader has be be turned on before the play of a song for it to work on that song. Even if you switch off/on the crossfader on a song, it won't work.

The initial problem:
1. This is what I did/do.
2. In Pref|Plug-ins|Output|DirectSound Output|Config
3. I usually like pressing the RESET ALL button.
4. Default values:
o Buffer length: 2000 ms
o Prebuffer: 500 ms
o Buffer-ahead: 0 ms
o Fading(on start, on first start, on end of song) disabled!

5. This also turns off the XFader button. It doesn't matter whether the XFader value is 10 sec, etc. Once you switch it on it'll be set at 0 secs (even though it shows some other value 10 secs, etc). You have to change the XFader value again (and notice it quickly sets it to 0 (from your prev. value of 10 sec for example).

6. XFader value is the "Fading" - "On End of Song" value. 10000 ms = 10 secs. Yay!

Winamp is the best MP3 player - thanks to the famous popular Crossfader!
kevingpo is offline   Reply With Quote