View Single Post
Old 30th May 2016, 19:14   #6
Worez
Member
 
Join Date: May 2016
Posts: 98
Quote:
Originally Posted by Aminifu View Post
[...]
In Winamp you can select the option for storing an entire mp3 file in memory before playback starts
[...]
Yes
Preferences > Plug-ins > Input > Nullsoft MPEG Audio Decoder > Configure > General > Full File Buffering
seems to do the trick

Quote:
Originally Posted by Koopa View Post
[...]
File buffering is only available, if the relevant decoder supports it.
I can confirm that now. So for FLACs there isn't a thing I can do?

Although I think that this problem is limited to MP3 format. Since I set that buffer for MP3 I did not get any pauses when listening to my music, which consists mostly of MP3s but also of FLACs [7.5%] and WV [1.3%]. But I can be wrong on [I may have not noticed pauses or had no torrent running in the background] that and only time will tell [more test in form of just listening to my music]


I have a question: why did I have to change buffer in Input and not in Output?

Previously I tried changing in
Options > Preferences > Plug-ins > Output > Nullsoft DirecSoud output v2.64 (d) > Configure > Buffering
all those values [from > too]
Buffer Lenght: 665 > 1305
Prebuffer on start / seek: 255 > 500
Buffer-ahead on track change: 255 > 500

but It did not help

[Also what did not help me was the change of Winamp's Priority Class from High to Realtime]
Worez is offline   Reply With Quote