Old 16th February 2012, 17:04   #1
dragonGOD
Junior Member
 
Join Date: Jun 2004
Posts: 14
Could not lock 3D noise texture

About a week ago I updated my video card drivers to Catalyst 12.1, and I just noticed that now when I try to open MilkDrop into fullscreen mode, it fails and I receive the error "Could not lock 3D noise texture". All other modes, including fake fullscreen mode seem to still work. If it makes a difference, I'm currently running two Radeon 6900's in crossfire mode. Does anyone have any ideas?
dragonGOD is offline   Reply With Quote
Old 16th February 2012, 18:11   #2
Nitorami
Major Dude
 
Join Date: Mar 2008
Location: Erlangen
Posts: 630
Send a message via ICQ to Nitorami
Oh shit, that's one of these questions... I only respond to give you some response, but I don't know the solution. There have been quite a few problems with fullscreen mode, maybe you search the forum for a hint but I doubt you'll find an answer. Milkdrop has aged, and there is not a lot of further development on it.
Maybe this got to do with Direct X ? Do you have DirectX 9 still installed... ? I think the last version was 9.0c, all higher versions starting with 10 are no longer compatible with 9.0c, but can coexist. Which means you can install 9.0c without wiping out newer versions already installed on your machine. Very useful to run older games not compatible with higher versions. But even then, I don't know whether milkdrop would use 9.0c, or rather try to run DirectX 10 in compatible mode. I am not the expert on this.
Nitorami is offline   Reply With Quote
Old 19th February 2012, 09:38   #3
tehloki
Junior Member
 
Join Date: Feb 2012
Posts: 2
disable crossfire

I get the same error, my setup is two HD4890s in crossfire, and I'm also running the 12.1 drivers. The only thing I've found so far that fixes the error is disabling crossfire before launching milkdrop. I'm getting kind of sad at how messed up crossfire is lately man.
tehloki is offline   Reply With Quote
Old 22nd February 2012, 05:13   #4
dragonGOD
Junior Member
 
Join Date: Jun 2004
Posts: 14
Yeah I was thinking it might be a Crossfire issue. Perhaps the issue will work itself out after the next Catalyst release.
dragonGOD is offline   Reply With Quote
Old 23rd March 2012, 12:48   #5
MaBoD
Junior Member
 
Join Date: Mar 2012
Posts: 1
Same here on two HD4890's on crossfire with Cat 12.2 drivers.
MaBoD is offline   Reply With Quote
Old 26th March 2012, 00:12   #6
blksith0
Junior Member
 
Join Date: Mar 2012
Posts: 7
My steps that fixed this:
1. Go to the AMD Vision Engine Control Center
2. On the left, go to Performance, AMD CrossFireX
3. Disable it. (Screen may flash, wait for it to be done)
4. Open Winamp, go to Preferences (Ctrl+P)
5. On the left, Plugins, Visualization
6. Click the Milkdrop Plugin then click Configure at the bottom
7. Click Defaults on the right of the settings window that pops up, then close out.
8. Launch the Visualizer (Ctrl+Shift+K)
9. Close out of it, you can now enable Crossfire again and hopefully it will work for you.
blksith0 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Visualizations > MilkDrop > MilkDrop Troubleshooting Forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump