Old 19th February 2014, 03:35   #1
TheBoss
Junior Member
 
Join Date: Feb 2014
Posts: 5
Genre search errors

Since the change it took a day for my station to finaly show on the directory. There's a bug in the genre listings tho, the 4 genres I have listed on my shoutcast server are not showing on page's presorted genre selections however if i do a type in genre search it appears but when I changed my server genre to just 1 it then appears in the presorted page genres so for now I'm stuck with 1 genre that'll show my station via the page sources. Hope this is getting some attention. Thx gang
TheBoss is offline   Reply With Quote
Old 19th February 2014, 06:51   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
the directory has only supported one genre for a listing and has been that way since early 2009.

the overloading of the genre field and the old site handling of that will not work with the temporary site which is currently in use. as the old site used other values in the search lookup but the temporary site is literal in the search (which resolves a number of other issues) at the expense of not allowing you to appear via multiple different searches.

so there is no bug in that respect and you will need to wait and see what happens when a permanent replacement site is provided (as per notes in the sticky threads).


and in the meantime, ensuring the genre is as best a match to the list allowed from http://forums.winamp.com/showthread.php?t=303241 and that it is the only thing in the genre string of the source software being used, then that's the best that can be currently done in-conjunction with the temporary site which is available.
DrO is offline   Reply With Quote
Old 21st February 2014, 21:50   #3
TheBoss
Junior Member
 
Join Date: Feb 2014
Posts: 5
Gone from bad to worse?

My administrator page shows yp touched & error connecting to yp back & forth. I can't find my station listed in my genre or by typing it in anymore.

What I don't get is why the same software programming that was on the old site doesn't work on the new server, that doesn't compute with me. Seems to me the only thing that would need to be done is the stations stats be redirected to your new server.

I haven't seen 1 new listener on my station all day cuz no one can find me, grrrrr
TheBoss is offline   Reply With Quote
Old 21st February 2014, 21:58   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
what is the DNAS address?

and we're just as perplexed by the issue (hence it being 11pm on a friday and still trying out things) as when the connections are coming through then it works correctly, just something is going on which is preventing some of the requests from the DNAS and it's somewhat tricky to debug when there's no reference of ones that have been reported as having the issue in any of the access logs at those times.

which is why we're now wondering if the DNS changes of the YP servers are leading to the issue (as the issue seems to have gotten worse since AOL's instances of the YP servers were stopped earlier today). as it was expected that some of the DNAS might have issues when the DNS was changed as part of the migration, but it should have only lasted for a a few days and is now going on longer than we'd have expected as a worse case.
DrO is offline   Reply With Quote
Old 22nd February 2014, 00:46   #5
DjRielru
Junior Member
 
Join Date: Feb 2014
Posts: 1
I am not listed in the correct Genre

Hello,

My apologies if this Thread is not related with my problem. I was redirected here by my SHOUTcast hosting.

I have noticed that my station does not have the correct Genre under shoutcast.com. For some reason, it changed recently which I personally didn't noticed. It has changed to "Misc". Instead of "Video Game Music". Is my problem related with the SHOUTcast Site, Directory (YP) and API Changes?

Thank you!
DjRielru is offline   Reply With Quote
Old 22nd February 2014, 08:43   #6
rene dussen
Junior Member
 
Join Date: Dec 2012
Posts: 5
Got the same issue here :-(

Hi Dr O! Since this week my number of listeners reduced. I see now that my 'The Great American Songbook' radio station only shows up when you type in this name. The send genre 'Vocal Jazz' doesn't show up anymore. It's changed into 'Misc' The SHOUTcast D.N.A.S. Status gives the correct genre name. What can I do? :-(
rene dussen is offline   Reply With Quote
Old 22nd February 2014, 14:23   #7
rene dussen
Junior Member
 
Join Date: Dec 2012
Posts: 5
thanks for looking at it!

Issue solved the right Genre is on! Thanks!!!!
rene dussen is offline   Reply With Quote
Old 23rd February 2014, 15:20   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
for those where the genre has randomly changed, you will need to restart the stream i.e. disconnect and re-connect the source for the stream. that will get it back to what it is meant to be (as long as you follow the behaviour of only setting _one_ genre from the list linked to in post #2).

the reason is we needed to do some clean-up of the genres and it was a bit overzealous in it's handling which sadly caused the genre for some stations to go to 'misc'. apologies for that issue as the processing was not meant to have done that and was only meant to fix listings where the genre was massively incorrect.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump