Old 21st December 2003, 18:32   #1
schiller
Registered User
 
Join Date: Dec 2003
Location: Swansea
Posts: 7
Crossfader not crossing

Ive searched and looked at other responses but still no resoloution. Not searched the entire forum - too much information needle in a hay stack n all that.

Crossfader fades out but not in basically. Why? Its really annoying, as you can imagine. Ive tried changing this and that in direct sound output but still nothing, ive tried to avoid the fading tab because thats fading not crossfading.

Thought it could be the buffers but i didnt have to change settings in 3 to do this so why should i in 5? i have changed one or two but no difference.

Please help me

Cheers in advance
schiller is offline   Reply With Quote
Old 21st December 2003, 23:05   #2
pure_darkness01
Junior Member
 
Join Date: Dec 2003
Posts: 5
I think the fader fades out, but anyway

It just doesn't work like Winamp3 did

windamp 3 would start playing the next song about 5 seconds before the current song finished

This new winamp does absolutely nothing

Not Happy,

Might Have To Go Back To Winamp 3 Hay?
pure_darkness01 is offline   Reply With Quote
Old 22nd December 2003, 00:17   #3
schiller
Registered User
 
Join Date: Dec 2003
Location: Swansea
Posts: 7
Im dissapointed then cos winamp 3 was really good at it.

I even knew of a couple of bars whos "DJ's" used winamp to "mix". That was fun. Ahh well better get a plugin
schiller is offline   Reply With Quote
Old 22nd December 2003, 09:20   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,784
Currently the Xfader button & slider in the (Modern/Bento) EQ is only configured to auto turn on "fade on end of song", but the two tracks definitely overlap. If they aren't for you, see below...

If you want it to also fade in on "start of song", then the Xfade configuration can be found at:

Prefs -> Plugins -> Output -> DirectSound -> config -> Fading tab.

Hi-lite "fade on start" -> checkmark "enabled" -> set a custom fade value.

_____________________________________________________________


If the Xfader isn't working, try the following:

Config drawer > EQ:
Move the xfade slider value down to 0
Turn the xfade button off

Go to: Prefs -> Plugins -> Output > DirectSound -> config:

Buffering tab:
Reset the bottom 2 sliders (prebuffer and buffer ahead on track change) to 0

Other tab:
Uncheck "remove silence"

Close Prefs -> close & restart Winamp

Now try the crossfader again in the modern skin EQ.


If everything is working, you should now be able to go back into DS config and reapply the 'buffer ahead' and 'remove silence' options, without it affecting crossfader.


Note:

1) The crossfader seems to return best results when using a value of 10 or higher, ie. by setting the xfade slider in the modern skin EQ and (optionally) the "fade on start" setting in out_ds config both to a value of somewhere between 10000ms to 20000ms.

2) To also enable manual crossfade when using next/prev commands,
you also need to adjust the following setting:

on pause/stop = enabled
use custom fade time = xxxx

where xxxx = eg. 8000 (for 8 seconds)
DJ Egg is offline   Reply With Quote
Old 22nd December 2003, 10:42   #5
schiller
Registered User
 
Join Date: Dec 2003
Location: Swansea
Posts: 7
Thanks for that DJ Egg, helps a lot, I understand now

To the uneducated like myself wa5 seems like a development of 2&3 were in fact its not... sneeky
schiller is offline   Reply With Quote
Old 27th April 2004, 10:24   #6
roy3171
Junior Member
 
Join Date: Apr 2004
Posts: 1
Hi,
This worked for me, but seemed to cut the end of first track and not playing both together. Is there a solution for this?

Thanks, Roy.
roy3171 is offline   Reply With Quote
Old 30th April 2004, 13:05   #7
schiller
Registered User
 
Join Date: Dec 2003
Location: Swansea
Posts: 7
Yes, a plug-in.

I have been using "SqrSoft Advanced Crossfading Output" which you should be able to find from the plugins category section of winamp.com or they have a website si a search might do the trick.
schiller is offline   Reply With Quote
Old 30th April 2004, 15:11   #8
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,784
Hmm... it works perfectly fine for me.
Not sure why it doesn't for you.

SqrSoft ACF can be found here:
http://www.sqrsoft.com.ar/en/
http://www.winamp.com/plugins/details.php?id=32368

Though there's also plenty of other crossfade plugins available...
DJ Egg is offline   Reply With Quote
Old 27th June 2004, 15:34   #9
Ronj
Junior Member
 
Join Date: Jun 2004
Location: Syracuse,NY
Posts: 23
Great! that works fine I'm a newbie at this. Just a matter of finding it didn't know it was under EQ. Thought it had to be there a GREAT! program.
Ronj is offline   Reply With Quote
Old 13th November 2004, 20:01   #10
kevingpo
Junior Member
 
Join Date: Nov 2004
Posts: 42
Quote:
Originally posted by DJ Egg
The crossfader works perfectly ok.
<snip><snip>

If the Xfader isn't working, try the following:

Config drawer > EQ:
Move the xfade slider value down to 0
Turn the xfade button off

Go to: Prefs -> Plugins -> Output > DirectSound -> config:

Buffering tab:
Reset the bottom 2 sliders (prebuffer and buffer ahead on track change) to 0

Other tab:
Uncheck "remove silence"

Close Prefs -> close & restart Winamp

Now try the crossfader again in the modern skin EQ.


If everything is working, you should now be able to go back into DS config and reapply the 'buffer ahead' and 'remove silence' options, without it affecting crossfader.


Note: The crossfader seems to return best results when using a value of 10 or higher (ie. by setting the xfade value slider in the modern skin EQ to 10 or higher)
Personally, I prefer 15 to 20, heh.
Thanks to DJ Egg. Got the crossfader to work properly. There seems to be a bug or maybe not. The crossfader has be be turned on before the play of a song for it to work on that song. Even if you switch off/on the crossfader on a song, it won't work.

The initial problem:
1. This is what I did/do.
2. In Pref|Plug-ins|Output|DirectSound Output|Config
3. I usually like pressing the RESET ALL button.
4. Default values:
o Buffer length: 2000 ms
o Prebuffer: 500 ms
o Buffer-ahead: 0 ms
o Fading(on start, on first start, on end of song) disabled!

5. This also turns off the XFader button. It doesn't matter whether the XFader value is 10 sec, etc. Once you switch it on it'll be set at 0 secs (even though it shows some other value 10 secs, etc). You have to change the XFader value again (and notice it quickly sets it to 0 (from your prev. value of 10 sec for example).

6. XFader value is the "Fading" - "On End of Song" value. 10000 ms = 10 secs. Yay!

Winamp is the best MP3 player - thanks to the famous popular Crossfader!
kevingpo is offline   Reply With Quote
Old 16th November 2004, 15:34   #11
d.XIII
Junior Member
 
Join Date: Nov 2004
Location: Torino - Italia
Posts: 1
Send a message via ICQ to d.XIII
Sometimes ago I passed from Winamp 3 to version 5, but unfortunately the new crossfading didn't work.

In the meantime i reinstall several time Winamp also after a different system format and crossfading still not work.

Some week ago i did a new format and misteriosly the crossfading get working fine.

Some days ago my Hard Disk crash and i had to reinstall all and the crossfading get not working again!

I navigate through the Winamp preferences and i discover the DirectSound plug in (version 2.2.10) and the crossfading works fine changing the setting manually also with the Hardware acceleration option activeted.

The problem is that the crossfading control in the config eq panel of the modern skin do nothing, i mean it don't affect the setting of the DirectSound plug in, so i have to change every time manually and it's very boring.

I think Winamp is the best MP3 player ever, so i am sure someone could help me easily.

Thanks in advance.

System: Windows XP SP2
Sound Card: SB Audigy
Winamp version: 5.05
d.XIII is offline   Reply With Quote
Old 18th November 2004, 17:06   #12
eric0668
Junior Member
 
Join Date: Nov 2004
Posts: 13
crossfading

I don't understand any of the above, but just didn't want to double thread,so I replied here. When I have crossfade checked off and like 2 or 3 seconds. It does not work like other players. It fades out , but the new song does not start until the old one ends? Is there a setting I have wrong?

I have version 5.04 in case you need to know that.

Also, I like that you have more volume than other players. however there is sacrificed quality, I played the same song on Winamp it sounded good with loud volume, but the other one was clearer and winamp had crackles any idea why?

Eric
eric0668 is offline   Reply With Quote
Old 18th November 2004, 18:27   #13
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,384
The current version of Winamp is 5.05 (at the time of this reply). Only the most current version of WA receives tech support. Try updating Winamp. If you have no luck forum that...

If I understand you post correctly want you want the fade blend the songs as one track ands and another starts. Correct?

Basically I will expand on DJ Egg's suggestion from his earlier post in this thread.
Quote:
Originally posted by DJ Egg

Currently the Xfader button & slider in the "Winamp Modern skin > config tray > EQ" is only configured to auto turn on "fade on end of song", but the two tracks definitely overlap. If they aren't for you, see below...

If you want it to also fade in on "start of song", then the Xfade configuration can be found at:

Prefs -> Plugins -> Output -> DirectSound -> config -> Fading tab.

Hi-lite "fade on start" -> checkmark "enabled" -> set a custom fade value.
1. Winamp > Ctrl+P
2. Plug-ins > double click 'DirectSound output'
3. click Fading tab
4. in the fade options box select/highlight 'on start'
5. checkmark 'Enabled' and 'Use custom fade time'
6. set a custom fade time of choice (eg 3000ms for 3 seconds)
7. close out of prefs
See attachment OnStartFade.jpg

As for the distortion problem, from the Common Issues section of the Troubleshooters Sticky...

No sound, skippy/choppy/crackly playback, high VM usage, etc.
http://forums.winamp.com/showthread....26#post1212926
http://forums.winamp.com/showthread.php?threadid=166479
Attached Images
File Type: jpg onstartfade.jpg (36.1 KB, 3422 views)

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 18th November 2004, 22:50   #14
eric0668
Junior Member
 
Join Date: Nov 2004
Posts: 13
still not cross fading

I do not mean to be one of those sarcastic or rude individuals that DJEgg corrected on one of those links above. But this player is absolutely useless. Try JetAudio. I mean, the ONLY absolutely good thing of any value is the window bar. Either the rest is of poor quality, or not user friendly. There are probably 1000 either useless plug ins out there or ones that no one except for a computer goo roo could get. I am not stupid by anymeans and am college educated. Maybe I am too analytical and organized in my thoughts, or the way they are explained and the constant use of computer terms forgetting that a lot of "commoners" will be using the player is the problem.

Anyway, I'll keep at it in hopes of liking it. I tried it and it will not fade. Maybe you all have different meaning. The songs ARE fading in and out, but they are NOT OVERLAPPING by about 1-2 seconds at the beginning and end of songs as if a dj was mixing them. Maybe this player can't do that. That's what I was speaking of, notjust fading at the beginning and end.

Second, I did the suggestions for crackling, I still get a little crackling. But probably a LITTLE less. Any more suggestions

I have a Dell 8300
512 mb ram
120 gb hard drive
2.67 ghz
SoundMax Digital Audio
Nvidia Gforce4 64 b kb ??


[Edit --> anonymous coward]
No, it's not Winamp that's useless
Increase the "fade on end" and "fade on start" values, to 10 or more.
If you can't read/understand the simple instructions or you aren't happy, then go and use that JetAudio p.o.s. you referred to - see if we care :/
eric0668 is offline   Reply With Quote
Old 16th January 2005, 02:04   #15
midnighttoker
Junior Member
 
Join Date: Aug 2003
Posts: 8
With Winamp 5.08c I am able to get tracks to crossfade when I manually am skipping them but no matter what I enable and disable, I cannot seem to get them to bleed into each within a playlist when the songs end naturally.

Do I need to get an annoying plug-in? Are there some values in the preferences I am over looking? I just downloaded one crossfader plug-in and it kept making Winamp crash, not to mention it didn't even work. Grrr. The crossfader in Winamp 3 was perfect.

[edit > JonnyMac] Moderator's note: midnighttoker accidentally replied to this thread. [/edit]
midnighttoker is offline   Reply With Quote
Old 22nd January 2005, 18:06   #16
quimrider
Junior Member
 
Join Date: Jan 2005
Posts: 1
Or you could just stick with WinAMP 3.0 where the crossfade works just fine. Besides what usefull features does WinAMP 5 offer that WinAMP 3 doesn't have?
quimrider is offline   Reply With Quote
Old 22nd January 2005, 18:37   #17
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,784
Huh? The crossfader works just fine in Winamp 5.x

Winamp3 v1.0 died over 2 years ago, and was a totally different product - now known as wasabi.player.

Winamp 5.x is the continuation of Winamp 2.x (ie. Winamp)
There's never been a Winamp 3.0

Both products have features that the other one doesn't.
But thankfully, Winamp 5.08c isn't riddled with bugs and security flaws... and most importantly, it's supported, and it's still being developed by 1st and 3rd-parties (ie. unlike Winamp3) :/

blah blah (search the forums for hundreds of other similar posts) etc.
DJ Egg is offline   Reply With Quote
Old 30th March 2006, 22:07   #18
Murph74
Junior Member
 
Join Date: Mar 2004
Posts: 13
For straight forward DJ'ing, winamp3 was foolproof- the only reason I'm crossgrading to WA5 is that 3 doesn't seem to crossfade between mono and stereo tracks. But even 5 is weird in that if you want it to stop when you hit stop, you can't have crossfading enabled it appears. It plays the buffer out. And using things like pacemaker seem to have to run the buffer too. Maybe I'm just not configuring it right, but seems like a chore opposed to WA3's out of the box functionality. I check up on Wasabi.player, and it hasn't changed much from the enduser POV since WA3 build 488d. Just my 2 cents... would love to see WA3 re-supported as an alternative for simple mp3 playing for monkeys like me.

Murph
Murph74 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump