Old 30th March 2004, 03:23   #1
weisheng
Junior Member
 
Join Date: Mar 2004
Posts: 1
Unique characters of non-English languages

Hi would like to ask is there anywhere I can make the default Modern Skin in Winamp recognise unique characters from other non-English languages, eg. "ã" from Portugese because my song titles are not appearing right.

I want to keep English as the default language though, just wondering how to add character recognition to the skin.

Hope I can get some help.

Thanks
weisheng is offline   Reply With Quote
Old 30th March 2004, 03:35   #2
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
Preferences > Skins > Modern Skins > "Font Rendering" tab.

Plenty of options to play around with there.

I assume you are referring to the song ticker in the main window. By default it is the bitmapped all uppercase LED sing looking font. To change that check "Use alternative fonts if the skin defines them" and leave "keep primary font in strings with only 7-bit characters"

If you don't like the font that it replaces it with then check "Use skin font mapper" and hit the Configure Skin Font Mapping button.

The song ticker font is player.songticker.font. For this you will have to uncheck "Use alternative fonts if the skin defines them"

And there is other stuff on that screen to play with if that doesn't meet your tastes.


Now, for the Playlist Editor in the Preferences go to the General Preferences > Playlist page. Select an alternate font to use under "Use font" and uncheck "Use skin or language pack font."
drewbar is offline   Reply With Quote
Old 17th November 2004, 05:34   #3
beaniebin
Junior Member
 
Join Date: Nov 2004
Posts: 2
Hi I've got the same problem also. Tried to use your solution but it didn't help, my chinese characters still appear as question marks. Is there any other way out?
beaniebin is offline   Reply With Quote
Old 17th November 2004, 11:09   #4
][p@H()5
Junior Member
 
Join Date: Nov 2004
Location: Russian Federaion
Posts: 12
Send a message via ICQ to ][p@H()5
Unique characters of non-English languages

Nobody knows, how symbols in smalltext.png, it like a file with a font, should be located. If who knows answer plz ..
][p@H()5 is offline   Reply With Quote
Old 9th July 2005, 08:13   #5
yaeger
Junior Member
 
Join Date: Jul 2005
Posts: 1
Preferences -> Modern Skin -> Font Rendering -> Unclick "Use FreeType internal TTF renderer"

This should hopefully let you see characters on the ticker

Let me know if this works. Tks.
yaeger is offline   Reply With Quote
Old 8th December 2005, 01:08   #6
Toraneko
Junior Member
 
Join Date: Dec 2005
Posts: 6
nope still doesn't work
Toraneko is offline   Reply With Quote
Old 10th December 2005, 01:18   #7
overseastar
Junior Member
 
Join Date: Dec 2005
Posts: 4
it didn't work for mine either
overseastar is offline   Reply With Quote
Old 10th October 2006, 00:26   #8
enmorestuff
Junior Member
 
Join Date: Oct 2006
Posts: 7
im also having this problem... i can't get russian characters to show up.
enmorestuff is offline   Reply With Quote
Old 10th October 2006, 00:43   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
http://forums.winamp.com/showthread....19#post2041219 should help i think (as long as you're using 5.3)

-daz
DrO is offline   Reply With Quote
Old 10th October 2006, 01:21   #10
enmorestuff
Junior Member
 
Join Date: Oct 2006
Posts: 7
im still a bit ocnfused on what to do.

if fiddled with some of the preferences for the skin and media library... still no luck with either. is there something i need to download?
enmorestuff is offline   Reply With Quote
Old 10th October 2006, 01:22   #11
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Did you download 5.3 yet>
And the Media Library still currently does not support Unicode.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 10th October 2006, 01:26   #12
enmorestuff
Junior Member
 
Join Date: Oct 2006
Posts: 7
oops... i think im on 5.24... will 5.3 fix the problem?

EDIT: got 5.3 - still nothing.
enmorestuff is offline   Reply With Quote
Old 10th October 2006, 02:37   #13
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,813
Winamp 5.3 Released thread
Updates
Notes

First, get the updated ml_local.dll

Fire up Winamp, go to:

1. Prefs > Media Library > Local Media
Uncheck "use library title info for playlist item formatting"

2. Prefs > General Preferences > Playlist
Uncheck "use skin or lang pack font"
Select an appropriate font from the drop-down list, eg. Arial Unicode MS

3. Prefs > Skins > Modern Skins > Font Rendering tab
You might have to uncheck "use freetype internal ttf renderer"
See the screenshot in my post here for other settings.


You should now have support for unicode titles in the Modern skin Main window and Playlist window.

For Classic skins, the relevant settings are #1 & #2 above, and:
Prefs > Skins > Classic Skins, uncheck "use skinned font for main window title display" (which should be unchecked by default, but might be still checkmarked if you upgraded from some old version).


Note, you won't be able to see unicode characters in the Local Media section of the Media Library, because as explained in the 5.3 Released Notes, it still isn't implemented*. Likewise for the text in the taskbar icon.


Update
* implemented for 5.33
DJ Egg is offline   Reply With Quote
Old 9th February 2007, 16:27   #14
desert_anime
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thank you DJ Egg for the helpful information. My Winamp player now correctly displays Japanese text everywhere. However, I was wondering if you could help me with an additional, similar problem. I recently downloaded the toaster v.0.7.8 plugin, which is great; however, it does not display any Japanese text correctly. All it shows are question marks, i.e. "????????". Therefore, I thought since you had the answer for this problem in Winamp, then maybe you would have the answer for this problem for one of its plugins "Toaster for Winamp Classic v0.7.8 [gen_toaster.dll]". I would appreciate your help greatly DJ Egg. I wait for your reply and thanks again for the Winamp help.
desert_anime is offline   Reply With Quote
Old 9th February 2007, 18:18   #15
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Most third-party plugins will need to be updated for Unicode support as well. So, might have to wait for an update on that. In the meantime, Winamp 5.33 Beta does have Unicode library support

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 11th February 2007, 01:31   #16
desert_anime
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thank you for the information Sawg. If that is in fact the case, then my next question is, do you or does anybody know a plugin like 'Toaster' that would support Japanese text or has Unicode support. I would also appreciate help with this very much, thanks again. -bye
desert_anime is offline   Reply With Quote
Old 11th February 2007, 01:37   #17
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm not aware of any of the now playing like plugins (which toaster falls into) having been updated to work with the newer unicode based apis of 5.3+ (not ideal since toaster was the most complete one out there)

-daz
DrO is offline   Reply With Quote
Old 31st March 2008, 01:23   #18
krnchunsa86
Junior Member
 
Join Date: Mar 2008
Posts: 1
unicode problems

hi,sorry to bother you folks with my problems, but for some reason on winamp, only some of my songs are in korean, while others are in unicode! its really quite bothersome and i followed all the directions to the best of my ability, and it pretty much changed nothing. If you could help me, that would be great, thank you!
Problem: Some songs are displayed correctly in korean, while others are displayed in unicode. (in shorter terms. =D)
krnchunsa86 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump