Old 19th April 2005, 02:29   #1
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Proxy setting ignored

I have Winamp v5.08e on Windows XP. The proxy setting seems to be ignored. Using ethereal I see that Winamp still tries to access the "original" address that I input in File -> Play URL (or from a playlist) instead of contacting the proxy. I.e. I'm trying to play http://foo.bar.com/file.ogg, it goes ahead and tries to contact foo.bar.com on port 80 directly and never even tries to touch the proxy I input. This goes for both a proxy that takes a username and password (i.e. myuser:pass@myproxy:8080) and a proxy that takes no username (i.e. myotherproxy:8085).

I have read the FAQ, the Help pages etc. as instructed but haven't found anything that resembles this problem. Is this a known issue, and if so, how can I go about solving it?

Thanks,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 19th April 2005, 04:15   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Hi

Could you please just confirm a couple of Winamp settings?

Winamp > Prefs (Ctrl+P) > General Preferences

Is your proxy address entered correctly in the proxy field?
And is "use proxy only for port 80 url's" checked or not?

And does the stream still actually work/play ok?

Apart from that, I'm not really sure (I don't personally use any proxy).
Anyone else?
DJ Egg is offline   Reply With Quote
Old 19th April 2005, 19:08   #3
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
I've tried both the myproxy:8085 and http://myproxy:8085/ syntax for the proxy field, neither has any effect.

The stream doesn't play, it simply says "CONNECTING..." which is natural because it's being blocked by the firewall because it's not using the proxy (which I can confirm by sniffing the network traffic).

There is no change in behavior whether or not I click the "Use proxy only for port 80 URLs".

There's also no change in behavior whether or not I include the port in the actual music URL, i.e. http://foo.bar.com/file.ogg or http://foo.bar.com:80/file.ogg both don't work.

As far as I can tell, it behaves as if it just ignores the proxy setting. There's no warning or error message that it can't connect to the proxy if that was the case, though plenty of other applications use the same proxy with no problems. There's also nothing in the network traffic that indicates that WinAmp is doing any attempt at all at contacting the proxy.

The same file (http://foo.bar.com/file.ogg) plays fine in WinAmp when I access it from a different host that's not behind a firewall, so it has nothing to do with the URL or file I'm trying to play either.

Is anyone else using the proxy successfully in the same version of WinAmp?

Thank you,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 19th April 2005, 21:35   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
No, no-one else has reported any issues.
What firewall are you using?
DJ Egg is offline   Reply With Quote
Old 19th April 2005, 21:50   #5
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Don't know for sure which firewall, it's a corporate firewall which I have no control over. I know that the proxy works fine though because I can access the URL I'm trying to play in WinAmp just fine with a web browser (IE, FireFox, Mozilla, ...) or using wget through the proxy.

So the question that I have comes down to how do I make WinAmp use the proxy? (Is there source code available somewhere so that I can help track it down?)

(Another side question is: Is there any documentation for options available when starting WinAmp on the command line? If WinAmp can play from STDIN somehow, then I could stream to it from wget for example.)

Thank you,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 19th April 2005, 22:37   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Are you sure it's not just a case of Winamp being blocked by the corporate firewall?
DJ Egg is offline   Reply With Quote
Old 19th April 2005, 23:51   #7
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
I'm not sure I understand the context of your question. Getting around the firewall is what the proxy is for. And, as I said, this (using the proxy) works fine in other applications (web browsers, wget, IM applications), they use the proxy and get to the URL and the contents of it without any problems.

WinAmp on the other hand doesn't even try to use the proxy but goes straight to the URL which is blocked by the firewall. So, how can I make WinAmp use the proxy I have told it to use in the preferences setting?

Thank you,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 20th April 2005, 23:23   #8
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Also, this can easily be verified by anyone. Set for example yahoo.com:80 as proxy, and use ethereal (from http://www.ethereal.com/download.html) to monitor network traffic and verify that no attempts are made to connect to yahoo.com:80.

Bjorn.
Bjorn S is offline   Reply With Quote
Old 22nd April 2005, 23:10   #9
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
One more bit of information - it seems the proxy setting is only ignored for .ogg extentions. .wav, .au, .mp3 etc. works well through the proxy, but if you try to play a .ogg file it just ignores the proxy setting. Any way to get around that problem on the client side without trying to fake it by renaming files on the server side?

Thanks,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 22nd April 2005, 23:41   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's been passed on to the dev team and they're aware that the in_vorbis plugin doesn't follow the proxy settings (which we found out a few hours before you're last post confirming it). this should be fixed at some point (no idea on time frame though but it should be fixed at some point)

-daz
DrO is offline   Reply With Quote
Old 22nd April 2005, 23:48   #11
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Thank you for the information! I look forward to seeing the fix come out.

Bjorn.
Bjorn S is offline   Reply With Quote
Old 22nd April 2005, 23:51   #12
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Yeah, you really should've told us that it was ogg streams only right at the start - which is why I couldn't reproduce anything - and which is why the fix now won't be in 5.09, but will have to wait until 5.1x :/
DJ Egg is offline   Reply With Quote
Old 23rd April 2005, 00:42   #13
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Well, I sort of did, if you look at all the examples I gave of things that failed. I didn't know at the time that it was isolated to .ogg only.

OTOH, it seems like a strange design to distribute proxy handling into each plugin - seems to me like that should rather be handled in some more central network-handling module?

Bjorn.
Bjorn S is offline   Reply With Quote
Old 23rd April 2005, 01:22   #14
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
yeah, I know, heh.

Actually, it's probably my fault for forgetting that in_vorbis ignored winamp's proxy setting. I think I already reported it to the old dev team a while back, but forgot to add it to the "known in_vorbis bugs" section of the "known bugs" sticky, heh.

ps. welcome to the wonderful world of winamp input plugins
DJ Egg is offline   Reply With Quote
Old 25th April 2005, 23:04   #15
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Any way I can get my hands on the improved Ogg Vorbis plugin so I won't have to wait with playing my music until 5.1 comes out? When will 5.1 come out, if you know?

Thank you,

Bjorn.
Bjorn S is offline   Reply With Quote
Old 25th April 2005, 23:08   #16
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's on the todo list so it's the standard "when it's ready" response and there's no set eta on it being done. you'll basically have to wait for a build with the fix in like the rest of us

-daz
DrO is offline   Reply With Quote
Old 2nd May 2005, 19:39   #17
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Aha! If you're still around....

Try this!

Winamp > Prefs > Plugins > Input > in_vorbis > config:
Streaming tab > "Use Winamp's proxy server settings":
Change the drop-down menu setting to "always" instead of "port 80 only" or "never".

(might require a winamp restart to take effect)
DJ Egg is offline   Reply With Quote
Old 3rd May 2005, 17:42   #18
Bjorn S
Junior Member
 
Join Date: Apr 2005
Posts: 11
Beautiful. That works like a charm. Thanks for finding that out for me! Now I feel like an *ss for not having poked around the menus and found it myself. :-)

It's probably obvious, but the "always" setting should likely be the default in future Winamp releases, no?

Bjorn.
Bjorn S is offline   Reply With Quote
Old 3rd May 2005, 18:03   #19
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Quote:
Originally posted by Bjorn S
Now I feel like an *ss for not having poked around the menus and found it myself. :-)
You're not the only one ;-)
Quote:

It's probably obvious, but the "always" setting should likely be the default in future Winamp releases, no?
Agreed.
DJ Egg is offline   Reply With Quote
Old 26th October 2005, 14:15   #20
icTaZ
Junior Member
 
Join Date: Oct 2005
Location: Prague, Czech republic
Posts: 1
proxy settings ignored if "port 80 only selected"

Hello,

similar problem like with "ogg" files persist even in Winamp 5.11 I've just downloaded.

If I check the "use proxy only for port 80 URLs' and try to connect to a stream, which includes 'host:80' port specification (yes, I know it's redundant, but tell it for example to http://di.fm/ admins :-)), Winamp tries to connect to the host directly, even it IS "port 80 URL". If I delete the ":80" from the stream URL, it works and Winamp connects thru proxy without any problem. Also if I uncheck "port 80 only" Winamp works with the proxy perfectly.

Said simply: Winamp seems not to treat "http://host:80/file" as "port 80 URL".

I verified the behavior using http://www.sysinternals.com/ TCPView TCP monitor.

As there's simple workaround (enable proxy for all URLs) I think this should be fixed. :-)

Tomas Zanka
icTaZ is offline   Reply With Quote
Old 26th October 2005, 14:39   #21
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Copied to internal bugtracker.

For future ref, please start a new thread if subject matter is (similar but) different.
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump