Old 11th October 2007, 13:31   #1
bassman99
Junior Member
 
Join Date: Oct 2007
Posts: 4
Portability: Install version 5.5 on USB-drive?

Can version 5.5, either "full" or "lite" be installed on a USB-drive and be completely portable between any computer it is plugged-into (no registry entries, etc.)?

Lite version 5.35 seems quite portable, but I'm wondering about version 5.5. In the case of version 5.3.5 (lite), portability seemed like more of an "accident" than an intentional feature, but perhaps I'm simply misreading this web-site and portability is indeed intended.

Since version 5.5 seems like an attempt to regain market-share (the new skin for the full version is *great*), perhaps it would be worth considering the growing "portable" market. It is incredible how much software is fully portable these days (including even openoffice!). Sadly, for portable audio players, XMPlay and MPlayer are the most commonly used, but not nearly as full-featured as WinAmp.

Last edited by bassman99; 11th October 2007 at 13:55.
bassman99 is offline   Reply With Quote
Old 11th October 2007, 18:12   #2
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Nothing stopping you from running Winamp 5.5 from a portable drive.

Copy the Winamp folder over to your thumb drive. Delete paths.ini, and edit winamp.ini, find no_registry=0 and set it to 1.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 12th October 2007, 12:09   #3
bassman99
Junior Member
 
Join Date: Oct 2007
Posts: 4
Quote:
Originally posted by Sawg
Nothing stopping you from running Winamp 5.5 from a portable drive.

Copy the Winamp folder over to your thumb drive. Delete paths.ini, and edit winamp.ini, find no_registry=0 and set it to 1.
I did this for WinAmp "full" (version 5.5), but I don't see a winamp.ini - and I searched my entire computer.
bassman99 is offline   Reply With Quote
Old 12th October 2007, 12:18   #4
bassman99
Junior Member
 
Join Date: Oct 2007
Posts: 4
I found winamp.ini after starting WinAmp, and made the change you suggested. WinAmp 5.5 crashes with:

"Runtime Error! Program: E:\PortableApps\Winamp_5.5\winamp.exe. The application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information"

This is the full English version of WinAmp (the one you get from the big download button), running on Windows XP on a laptop. XP has most critical patches applied (maintained by centralized IT group in business setting).
bassman99 is offline   Reply With Quote
Old 16th October 2007, 12:55   #5
bassman99
Junior Member
 
Join Date: Oct 2007
Posts: 4
Bump...
...just in case anyone else with experience running WinAmp v5.5 from a portable device.
bassman99 is offline   Reply With Quote
Old 9th December 2007, 14:21   #6
Kanec
Junior Member
 
Join Date: Dec 2007
Posts: 1
Hi... I got the same problem too. There must be a bug as WA 5.5 is trouble-free only when it is regularly installed.
Kanec is offline   Reply With Quote
Old 9th December 2007, 16:25   #7
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,867
FAQ

Installing Winamp 5.5+ to a usb stick/pen/flash drive
http://forums.winamp.com/showthread.php?threadid=279827

btw, I recommend using 5.51 (currently available as a public beta) over 5.5
DJ Egg is offline   Reply With Quote
Old 9th December 2007, 16:31   #8
Nunzio390
Nugatory Aluminator
Look it up

 
Nunzio390's Avatar
 
Join Date: Oct 2002
Location: Tharsis Ridge (Martian lowlands)
Posts: 8,588
Send a message via AIM to Nunzio390 Send a message via Yahoo to Nunzio390
Well, I don't know what you 2 guys did wrong, but no probs at all for me. I have Winamp 5.51 Beta Full running Milkdrop 2 installed on a SanDisk 4gig U3 stick right now. I take it to and from work where we don't even have workstations and instead run off blades, with no installation rights. I have no problems at all, regardless of what blade/machine I plug it in to. Winamp runs perfectly in all cases.

Don't email or PM me concerning Winamp. Instead, either start a NEW TOPIC or post a REPLY in the appropriate thread in these forums. This will also benefit others who may have a similar question or problem. But before posting, please first Search the forums and read all FAQs and all Sticky threads.

ORB Remote Broadcast

[ Automated Jukebox | Nunzio's Home | Wacky Videos | Solve the Prunella Puzzle! ]
[ LINE RIDER! | My Resume | Virtual Chess | Composite Sketch | My Niece's Band ]
[ Plugins by Joonas | DrO's Winamp Plugins and Extras | K-Jöfol ]
Nunzio390 is offline   Reply With Quote
Old 11th December 2007, 18:13   #9
Krinter
Junior Member
 
Join Date: Feb 2007
Posts: 21
I got the same problem. The strange thing is though, that it worked with 5,5 a couple of weeks and then one day I went to work and plugged my prtable hard drive in it opened in default view with no modifications or music loaded at all - like if I'd just finished a fresh install. I can't figure out what I've done. But I know that I haven't tinkered with anything since I have limited acces to deeper layers of my workstations system levels.

What's even worse is that Iøm in charge of music on this friday for our christmas party at work, and already made playlists and now I seem to have to start all over again.
Krinter is offline   Reply With Quote
Old 11th December 2007, 23:46   #10
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,625
Send a message via ICQ to J_Darnley
Keep it to one thread. I answered somewhat incompletely here:
http://forums.winamp.com/showthread....hreadid=283037

You need to remove paths.ini and set no_registry=1 in Winamp.ini

If you did this please say this in one of these threads.

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump