Old 1st January 2009, 17:32   #1
igor-com-ua
Junior Member
 
Join Date: Nov 2008
Location: Ukraine
Posts: 7
NSCRT.dll not found

I had a problem with starting of Winamp (Error in aplication. Aplication must be closed). I have reinstall Winamp and after it i have a massege "NSCRT.dll not found.."
Where I can find this file?
igor-com-ua is offline  
Old 1st January 2009, 17:51   #2
azerty2005
Junior Member
 
Join Date: Jul 2005
Location: Belgium
Posts: 20
Hi,

NSCRT.dll is normally part of winamp install, and you should find it in the winamp plugin folder. Maybe you have a faulty installer. I suppose uninstall & reinstalling winamp should fix the problem. Re-download the the latest winamp.exe and re-try. But you should wait for a developer response to be sure.
azerty2005 is offline  
Old 8th January 2009, 17:02   #3
igor-com-ua
Junior Member
 
Join Date: Nov 2008
Location: Ukraine
Posts: 7
Thank you, azarty2005. It was a problem ocurred by instaling latest version of Winamp in the folder thet included Winamp 5.13. Winamp5.13 was runing. There was an error massege but one guy decide to press "Ignore" and file winamp.exe was not updated. It was fixed by FULl erasing Winamp folder after uninstal, beacouse some files was from different version.
Sorry for bugging you.
igor-com-ua is offline  
Old 21st December 2009, 18:19   #4
bennyn
Junior Member
 
Join Date: Dec 2009
Posts: 5
Send a message via ICQ to bennyn
Hi, I've got the same problem. I tried to install Winamp 5.57 on a new and clean system. After selecting a skin and finishing the installation winamp crashed. I have tried to start it once again but then an error message appears, telling me that NSCRT.dll couldn't be found.

I'm using Windows 7 Professional (64-bit). Is there any solution?

Greetings

Benny
bennyn is offline  
Old 21st December 2009, 18:30   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
bennyn: please make sure that you're using 5.571 also nscrt.dll isn't used as of 5.57x so sounds like there is an older component present in your install. if the issue still happens then please post a relevant install specs

-daz
DrO is offline  
Old 21st December 2009, 18:34   #6
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Quote:
Originally posted by igor-com-ua
... It was fixed by FULL erasing Winamp folder after uninstal, beacouse some files was from different version.
Try this first.

[edit] Hi daz

UJ
ujay is offline  
Old 21st December 2009, 19:07   #7
bennyn
Junior Member
 
Join Date: Dec 2009
Posts: 5
Send a message via ICQ to bennyn
Hi there. Thanks for your fast replies.

I used the latest installer of Winamp from this webpage here (winamp5571_full_emusic-7plus_de-de). I had never installed any other version of Winamp before on my current system. I installed it together with Winamp Remote (which I can start). But Winamp itself crashes directly after the installation process. I already deleted the Winamp directory before trying a new installation. But this doesn't help. If I try to start Winamp (after the crash) it tells me two-times (!) that nscrt.dll is missing. After that it comes up again with the installation dialog to choose a skin.

Windows gives the following information about the program crash (sorry, but this is in German):
Quote:
Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: winamp.exe
Anwendungsversion: 5.5.7.2810
Anwendungszeitstempel: 4b2f0bcd
Fehlermodulname: ml_online.dll
Fehlermodulversion: 0.0.0.0
Fehlermodulzeitstempel: 4b2f0bdf
Ausnahmecode: c0000005
Ausnahmeoffset: 0000287b
Betriebsystemversion: 6.1.7600.2.0.0.256.48
Gebietsschema-ID: 1031
Zusatzinformation 1: 0a9e
Zusatzinformation 2: 0a9e372d3b4ad19135b953a78882e789
Zusatzinformation 3: 0a9e
Zusatzinformation 4: 0a9e372d3b4ad19135b953a78882e789
So it seems to have something to do with the ml_online.dll?

My system is this:
Quote:
PC or Motherboard make/model: Lenovo 3000 N200 0769B2G Notebook
CPU & RAM: Intel Core 2 Duo T7300, 4 GB DDR2-800 MHz
Sound card or chip: Realtek High Definition Audio
Videocard: nVidia GeForce Go 7300
Windows OS: Windows 7 Professional, 64-bit
DirectX version: DirectX 11
Winamp version: 5.571
Winamp installation type: Full
And here is my Hijack Logfile:
Quote:
Logfile of Trend Micro HijackThis v2.0.3 (BETA)
Scan saved at 20:57:33, on 21.12.2009
Platform: Unknown Windows (WinNT 6.01.3504)
MSIE: Internet Explorer v8.00 (8.00.7600.16385)
Boot mode: Normal

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page = C:\Windows\SysWOW64\blank.htm
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
F2 - REG:system.ini: UserInit=userinit.exe
O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\PROGRA~2\MICROS~1\Office14\GROOVEEX.DLL
O2 - BHO: Windows Live Anmelde-Hilfsprogramm - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: URLRedirectionBHO - {B4F3A835-0E21-4959-BA22-42B3008E02FF} - C:\PROGRA~2\MICROS~1\Office14\URLREDIR.DLL
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files (x86)\Java\jre6\bin\jp2ssv.dll
O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files (x86)\QuickTime\QTTask.exe" -atboottime
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files (x86)\iTunes\iTunesHelper.exe"
O4 - HKLM\..\Run: [WinampAgent] "C:\Program Files (x86)\Winamp\winampa.exe"
O4 - HKCU\..\Run: [Rainlendar2] C:\Program Files (x86)\Rainlendar2\Rainlendar2.exe
O4 - HKCU\..\Run: [Orb] "C:\Program Files (x86)\Winamp Remote\bin\OrbTray.exe" /background
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'LOKALER DIENST')
O4 - HKUS\S-1-5-19\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'LOKALER DIENST')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'NETZWERKDIENST')
O4 - HKUS\S-1-5-20\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'NETZWERKDIENST')
O8 - Extra context menu item: An OneNote s&enden - res://C:\PROGRA~1\MICROS~1\Office14\ONBttnIE.dll/105
O8 - Extra context menu item: Nach Microsoft E&xel exportieren - res://C:\PROGRA~1\MICROS~1\Office14\EXCEL.EXE/3000
O9 - Extra button: An OneNote senden - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: An OneNote s&enden - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra button: Verknüpfte &OneNote-Notizen - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O9 - Extra 'Tools' menuitem: Verknüpfte &OneNote-Notizen - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O13 - Gopher Prefix:
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/ge...sh/swflash.cab
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~2\COMMON~1\Skype\SKYPE4~1.DLL
O18 - Filter hijack: text/xml - {807573E5-5146-11D5-A672-00B0D022E945} - C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\MSOXMLMF.DLL
O23 - Service: @%SystemRoot%\system32\Alg.exe,-112 (ALG) - Unknown owner - C:\Windows\System32\alg.exe (file missing)
O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files (x86)\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
O23 - Service: Bonjour-Dienst (Bonjour Service) - Apple Inc. - C:\Program Files (x86)\Bonjour\mDNSResponder.exe
O23 - Service: @%SystemRoot%\system32\efssvc.dll,-100 (EFS) - Unknown owner - C:\Windows\System32\lsass.exe (file missing)
O23 - Service: ESET HTTP Server (EhttpSrv) - ESET - C:\Program Files\ESET\ESET NOD32 Antivirus\EHttpSrv.exe
O23 - Service: ESET Service (ekrn) - ESET - C:\Program Files\ESET\ESET NOD32 Antivirus\x86\ekrn.exe
O23 - Service: @%systemroot%\system32\fxsresm.dll,-118 (Fax) - Unknown owner - C:\Windows\system32\fxssvc.exe (file missing)
O23 - Service: FLEXnet Licensing Service - Acresso Software Inc. - C:\Program Files (x86)\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: FLEXnet Licensing Service 64 - Acresso Software Inc. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService64.exe
O23 - Service: Intel(R) Matrix Storage Event Monitor (IAANTMON) - Intel Corporation - C:\Program Files (x86)\Intel\Intel Matrix Storage Manager\IAANTMon.exe
O23 - Service: iPod-Dienst (iPod Service) - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: @keyiso.dll,-100 (KeyIso) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @comres.dll,-2797 (MSDTC) - Unknown owner - C:\Windows\System32\msdtc.exe (file missing)
O23 - Service: @%SystemRoot%\System32\netlogon.dll,-102 (Netlogon) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: NVIDIA Display Driver Service (nvsvc) - Unknown owner - C:\Windows\system32\nvvsvc.exe (file missing)
O23 - Service: @%systemroot%\system32\psbase.dll,-300 (ProtectedStorage) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%systemroot%\system32\Locator.exe,-2 (RpcLocator) - Unknown owner - C:\Windows\system32\locator.exe (file missing)
O23 - Service: @%SystemRoot%\system32\samsrv.dll,-1 (SamSs) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\snmptrap.exe,-3 (SNMPTRAP) - Unknown owner - C:\Windows\System32\snmptrap.exe (file missing)
O23 - Service: @%systemroot%\system32\spoolsv.exe,-1 (Spooler) - Unknown owner - C:\Windows\System32\spoolsv.exe (file missing)
O23 - Service: @%SystemRoot%\system32\sppsvc.exe,-101 (sppsvc) - Unknown owner - C:\Windows\system32\sppsvc.exe (file missing)
O23 - Service: Anzeige am Bildschirm (TPHKSVC) - Lenovo Group Limited - C:\Program Files\LENOVO\HOTKEY\TPHKSVC.exe
O23 - Service: @%SystemRoot%\system32\ui0detect.exe,-101 (UI0Detect) - Unknown owner - C:\Windows\system32\UI0Detect.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vaultsvc.dll,-1003 (VaultSvc) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vds.exe,-100 (vds) - Unknown owner - C:\Windows\System32\vds.exe (file missing)
O23 - Service: @%systemroot%\system32\vssvc.exe,-102 (VSS) - Unknown owner - C:\Windows\system32\vssvc.exe (file missing)
O23 - Service: @%systemroot%\system32\wbengine.exe,-104 (wbengine) - Unknown owner - C:\Windows\system32\wbengine.exe (file missing)
O23 - Service: @%Systemroot%\system32\wbem\wmiapsrv.exe,-110 (wmiApSrv) - Unknown owner - C:\Windows\system32\wbem\WmiApSrv.exe (file missing)
Thanks for your efforts

Benny
bennyn is offline  
Old 22nd December 2009, 16:48   #8
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Re: nscrt.dll

The only (old/3rd-party) plugins/components I know of which still use it are:

Nullsoft Musepack Decoder v1.0 Beta (winamp\plugins\in_mpc.dll) -> update available
Album Art Viewer v0.2 (winamp\plugins\gen_classicart.dll) -> v0.3 available (no nscrt dependency)
XSPF Loader (winamp\system\xspf.w5s) -> update available (no nscrt dependency)
Classic Pro skin support (winamp\system\ClassicPro.w5s) -> update available (no nscrt dependency)
AACPlus Encoder (enc_aacplus.dll) from the SHOUTcast DSP v1.9.0 installer -> info
Remote Media plugin (ml_orb.dll), as included with Winamp Remote -> update available (no nscrt dependency)*

None of those are included with the default Winamp package
* except for ml_orb
(edit: which we've later determined to be the most likely cause of the problem, see below)

As far as I know, there's nothing in the default 5.57x distribution which uses nscrt.dll

nscrt.dll is our old library when we used to build the client with VS2003.
We now use VS2008 and ship msvcr90.dll instead.

The Winamp Uninstaller will remove nscrt.dll
but it won't remove any of the above (except for enc_aacplus), because they're not included with the Winamp distribution...
DJ Egg is offline  
Old 22nd December 2009, 16:56   #9
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
For anyone who needs it...

Save nscrt.dll to the Winamp root folder
ie. the same folder where winamp.exe resides

Then also place a copy of it in the Winamp\Plugins folder
[EDIT] (which prevents some security/av programs from complaining about it being missing)

___________________________


Attached Files
File Type: dll nscrt.dll (340.0 KB, 13054 views)

Last edited by DJ Egg; 23rd March 2010 at 20:36. Reason: previously attached nscrt.dll was lost during forum upgrade
DJ Egg is offline  
Old 22nd December 2009, 20:48   #10
bennyn
Junior Member
 
Join Date: Dec 2009
Posts: 5
Send a message via ICQ to bennyn
Hi, thanks for your reply. I did what you said but now there comes up another error (see screenshot) and Winamp sill doesn't want to start.

By the way: I've got Windows 7 Professional Version 6.1 (Build 7600). HJT must be mistaken.
bennyn is offline  
Old 22nd December 2009, 22:38   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hmmm...

Is Winamp being run in compatibility mode or something?

Right-click the Winamp desktop icon
Select "Properties"
Goto the Compatibility tab
Uncheck everything!

You'll get script errors on Win7 when using modern skins
if Winamp is set to run in XP-compatibility mode.

Which skin did you select in the installer setup?

Winamp Modern has a menualign.maki, but Bento doesn't.

Or are you maybe using some 3rd-party modern skin?
In which case, which one?

If you select the Classic skin then you won't get any script errors...
Or just edit %appdata%\winamp\winamp.ini
so the skin= line is just that (blank, with no value)

I'm not sure what else to suggest, other than a proper clean install of 5.571,
with which I most certainly can't reproduce any of these errors (under Win7 or any OS).

If the problems persist, then please attach your List of Plugins.

ps. and yeah, HJT needs fixing to detect Win7F properly.
DJ Egg is offline  
Old 24th December 2009, 19:37   #12
dmguitar0
Junior Member
 
Join Date: Dec 2009
Posts: 1
Quote:
Originally posted by DJ Egg
For anyone who needs it...

Save nscrt.dll to the Winamp root folder
ie. the same folder where winamp.exe resides

Then also place a copy of it in the Winamp\Plugins folder
Thanks for providing the valid .dll for those of us with this problem to download, but the directions you've given as to where to place it contain an extraneous step and the source of the issue appears to be mistakenly blamed on the plugins mentioned earlier in the thread.

I placed it in the /Winamp/plugins directory, which did not solve the issue. However, placing it in the /Winamp folder instead DOES solve the issue. Placing it in the plugins directory is fine, but not needed. Keep in mind I am on a system running XP (SP3), and not Windows 7 or Vista.

Therefore, at least for systems running XP, I would say with confidence that the issue is not related to a plugin calling for the .dll, its related to the registration flow and the application itself needing the .dll (this is when the errors appear..) For other systems, its entirely possible this is the same issue and the same fix will work.

Thanks again, just thought it prudent to provide this information as soon as I found it, since I found it nowhere else on the forums.

-Mark Massengale
dmguitar0 is offline  
Old 24th December 2009, 21:21   #13
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Nope. It actually only really needs to be in the Winamp root folder for any (old) plugins that require it.
We only also had to place nscrt.dll in the Winamp\Plugins folder in 5.56 and a few releases before
because some security apps like ZoneAlarm and some AV programs used to moan if it wasn't there.

Attach your List of Plugins and then we can tell you which old plugin is calling/requiring nscrt.dll

I'm 99.9% certain that nothing in the default 5.571 installation uses or requires it.
DJ Egg is offline  
Old 25th December 2009, 03:34   #14
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
^
DJ Egg is offline  
Old 26th December 2009, 06:44   #15
scandragon
Junior Member
 
Join Date: Dec 2009
Posts: 2
Quote:
Originally posted by DJ Egg
Nope. It actually only really needs to be in the Winamp root folder for any (old) plugins that require it.
We only also had to place nscrt.dll in the Winamp\Plugins folder in 5.56 and a few releases before
because some security apps like ZoneAlarm and some AV programs used to moan if it wasn't there.

Attach your List of Plugins and then we can tell you which old plugin is calling/requiring nscrt.dll

I'm 99.9% certain that nothing in the default 5.571 installation uses or requires it.
I've just tried to install the latest winamp.
This is a clean XP Pro SP3 install, never had winamp installed before

The installer downloaded is winamp5571_full_bundle_emusic-7plus_en-us.exe
It can't be started due to a missing nscrt.dll

So as I see it, there is no way, this is not related to the default 5.571 installation, as I have no 3rd party plugins or skins. Only what's included in the installation.

After placing this file in winamp dir I can start the app correctly, however attempting to access preferences, it crashes..
Same thing goes when trying to play any mp3 file.

All I really need is a reliable mediaplayer for my audiobooks. I've been using media player classic for a long time, but I really like winamp..

However if winamp doesn't work from a default installation, then I can't use it.. Simple as that
scandragon is offline  
Old 26th December 2009, 07:01   #16
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Winamp 5.571 loads fine for me with no nscrt.dll present,
on WinXP sp3 32-bit and on Win7 Ultimate 64-bit.

The only 3 components from the default package that I didn't have installed were 3 of the 5 Portable Media Player plugins (pmp_ipod.dll, pmp_p4s.dll & pmp_activesync.dll), because I don't have any of those devices, so have got no need for the plugins.

I placed those 3 DLL's in the Plugins folder, and Winamp still loaded ok with no nscrt.dll

The only 4 old components (not included with 5.571) that I know of which require(d) nscrt.dll are listed in one of my posts above.

If you get the error message on a clean install of Winamp 5.571 then alas, I'm baffled.

Anyone else?

We really need to see that "List of Plugins" (see above)
DJ Egg is offline  
Old 26th December 2009, 07:10   #17
scandragon
Junior Member
 
Join Date: Dec 2009
Posts: 2
I just tried uninstalling winamp completely and reinstalled it from same installer, but this time I decided to not install Winamp Agent
This seems to do the trick, as this time I'm getting no errors at all..

But yes, I got those errors on a completely clean install on 5.571.
I do not use Zone Alarm, and seeing as Avast doesn't complain now, that wasn't the cause of the error either (as nscrt.dll was deleted when I uninstalled)
scandragon is offline  
Old 26th December 2009, 07:41   #18
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Weird.

Winamp Agent (winampa.exe) in 5.571 has no nscrt.dll dependency.
It's built in VS2008, and like nearly all other 5.571 components, only requires msvcr90.dll

nscrt.dll was the library used/required when we used to build everything with VS2003.
iirc, it was the equivalent of one of Microsoft's msvcr70.dll or msvcr71.dll.
Nothing in the 5.571 package is built with VS2003, therefore nscrt.dll or msvcr70/1.dll aren't required.

Because we can't get it to work properly when compiled with VS2008,
the AVS plugin (vis_avs.dll) is built with VC6 instead
and has an msvcrt.dll dependency (found in the windows\system32 folder, by default on all Windows OS'es).

Other old plugins/components included with Winamp that are still built with VC6 are:
dsp_sps.dll, vms_desktop.dll & read_file.dll

Other than 3rd-party libraries, such as Gracenote DLL's, Sonic Engine DLL's and lame_enc.dll, which are already compiled by said 3rd-parties and therefore can't have ever used our nscrt library, and also DrO's JTFE plugin (gen_jumpex), which I think has a VC6 msvcrt.dll dependency (?), everything else in 5.571 is built in our build system with VS2008.

So yes, I'm still baffled.

All I can think is that some older component/plugin must've somehow been in your Winamp folder before installing 5.571,
or you've installed something since installing Winamp which has placed some old component/plugin in the Winamp folder.
It's the only logical conclusion.
DJ Egg is offline  
Old 26th December 2009, 11:55   #19
Taliesyn
Junior Member
 
Join Date: Dec 2009
Posts: 3
DJEgg, I just installed the ShoutCast DSP plugin (1.9.0) and now it asks me for nscrt.dll - for info. I'm using Winamp 5.5.7.1 Pro on Win7 x64.


With kind regards,

Tali.
Taliesyn is offline  
Old 26th December 2009, 16:04   #20
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Ahh! Okay, I've looked into this...

From what I can gather, the Shoutcast DSP v1.9 plugin was built with VC6 and doesn't require nscrt.dll

It's actually the AACPlus Encoder (enc_aacplus.dll) which is included in the dsp_sc package
which was built with VS2003 and therefore uses/requires nscrt.dll

I'll add it to the list in my post above.

The dsp_sc installer needs updating.

enc_aacplus.dll either needs removing from it, or updating to the latest version
(because currently, it's overwriting the latest version from 5.57x with some old version).
DJ Egg is offline  
Old 26th December 2009, 17:09   #21
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
^
DJ Egg is offline  
Old 26th December 2009, 22:28   #22
Taliesyn
Junior Member
 
Join Date: Dec 2009
Posts: 3
Thanks - is there an easy way to get the overwritten version of enc_aacplus.dll reinstalled (i.e. without reinstalling Winamp for the nth time?!)? Can I extract it from the install package somehow, or could it be posted here?
Taliesyn is offline  
Old 26th December 2009, 23:13   #23
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
You should be able to extract it from the Winamp install EXE using 7zip (9.1x beta version recommended).

[0]\Plugins\enc_aacplus.dll --> C:\Program Files\Plugins\enc_aacplus.dll

UJ
ujay is offline  
Old 27th December 2009, 10:37   #24
Taliesyn
Junior Member
 
Join Date: Dec 2009
Posts: 3
Thanks Ujay, done that
Taliesyn is offline  
Old 1st January 2010, 21:51   #25
cepeja
Junior Member
 
Join Date: Jan 2010
Posts: 3
Hi!

I managed to put it working by copying the dll to root folder.

But now when i try to enable proo with product key, it says "invalid product key". I bought the software just 2 weeks ago!!! (and then reinstalled the Vista to Windows 7). How can i get the license key working?

Also if i press "preferences" or "Go Pro" the software crashes. Then Windows 7 proposes to use some compability mode.

Freaks that u pay afor softwares and they do not work!!!

Br, customer

Last edited by cepeja; 1st January 2010 at 22:14.
cepeja is offline  
Old 2nd January 2010, 01:41   #26
hroberts89436
Junior Member
 
Join Date: Jan 2010
Location: NV
Posts: 1
OK... I just purchased the Pro version of WINAMP 5.571. I have never heard of winamp before today, but I purchased it because a friend of mine told me it was better then media player.

I get the missing NSCRT.dll file from the very start. I downloaded it from this forum, and now when I close winamp I get this error:
Exception Processing Message c0000a3 Parameters 75b6bf7c 4 75b6bf7c 75b6bf7c. When I press cancel I get the same message again, and then I get the microsoft dr. watson please tell microsoft about this problem.

HELP!!!

I don't want to have to request a refund but that may be my only course here.


Update!!!!!
I have 2 cd drives on my computer. If I do NOT have a CD in each drive I get this error
hroberts89436 is offline  
Old 2nd January 2010, 16:10   #27
bennyn
Junior Member
 
Join Date: Dec 2009
Posts: 5
Send a message via ICQ to bennyn
Quote:
Originally posted by DJ Egg
Hmmm...

Is Winamp being run in compatibility mode or something?
Yes! That was the point. Because of the crashes I tried to run Winamp on Windows 7 in compatibility mode and forgot to reset this after installing nscrt.dll. The copying of nscrt.dll to the Winamp root dir and Winamp plugin dir has helped by the way!

Meanwhile, I use Windows XP (32-bit, SP3) again and there was the bug, too. I had to insert the dlls first before I could start Winamp without a crash. Therefore you should update your installation package (I used winamp5571_full_emusic-7plus_de-de.exe)!!
bennyn is offline  
Old 2nd January 2010, 16:17   #28
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
We won't be putting nscrt.dll back in the Winamp installer because, as I've said, it's no longer required.

Some old plugin or component is calling it.

Attach your List Of Plugins!
DJ Egg is offline  
Old 2nd January 2010, 19:18   #29
cepeja
Junior Member
 
Join Date: Jan 2010
Posts: 3
Quote:
Originally posted by DJ Egg
We won't be putting nscrt.dll back in the Winamp installer because, as I've said, it's no longer required.

Some old plugin or component is calling it.

Attach your List Of Plugins!
But this does not help at all?? I installed Winamp from clean table on clean Windows 7 with recent updates. I have not been able to call any old plugin, since the program does not even start, it crashes right after installation. And also even with this dll copied it crashes when u select any top menu.

I have used Winamp since Atari times and never seen any bugs. I hope u get solution to this and release new update. I have funded u far over 15 years!!
cepeja is offline  
Old 2nd January 2010, 21:04   #30
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Attach your List Of Plugins!

This is the important bit.

UJ
ujay is offline  
Old 2nd January 2010, 23:18   #31
bennyn
Junior Member
 
Join Date: Dec 2009
Posts: 5
Send a message via ICQ to bennyn
Quote:
Originally posted by DJ Egg
Attach your List Of Plugins! [/B]
Here it is.
bennyn is offline  
Old 3rd January 2010, 04:20   #32
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
@bennyn

Hmm, so you can't get the One For Nunz plugin to work properly?
The plugin version shows a lot more useful information
whereas the external standalone version is quite limited (it doesn't even show Windows OS).
I thought you said you could get Winamp to run ok after you'd put nscrt.dll in the Winamp folder?

Looking through your standalone version (my_plugin_list_ext.txt)
there does seem to be some discrepancies....

No elevatorps.dll listed...

Are the files: Elevator.exe and elevatorps.dll in your Winamp root folder?

If yes, then does their version number (via mouseover or file properties) say: 5.5.7.2810 ?

Note: those two files will/should only be present under Windows 7 and Vista
(ie. they aren't required and won't be installed under Win2k/XP)

Is there a "Microsoft.VC90.CRT" subfolder in your Winamp root folder? (WinXP/Vista/7)
And if yes, are the files msvcr90.dll and Microsoft.VC90.CRT.manifest inside it?

If any of those files are missing, then this would explain a lot of the problems.

Though it still doesn't explain why you get an nscrt.dll missing error.
Alas, I can't use the standalone plugin list to determine whether there's any old plugins or components present.
Only the One For Nunz plugin version shows plugin version numbers.



Can anyone...ANYONE...determine if there is any component (.exe, .dll, .w5s, .wac) included with the default 5.571 installation that is nscrt.dll dependent? And if yes, then what the hell is it?!?!?

I know I can't.
I've tested on WinXP 32-bit and Win7 Ultimate 64-bit with no nscrt.dll present and Winamp 5.571 runs perfectly okay.
DJ Egg is offline  
Old 3rd January 2010, 08:46   #33
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Winamp 5.571 on Windows 7 Ultimate 64-bit, with no nscrt.dll
DJ Egg is offline  
Old 3rd January 2010, 18:31   #34
theweasel68
Junior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 8
I have the same problem with NSCRT, plus - during installation - I get an additional error message:

During installation of the components, a problem ocurred. CD ripping/burning probably might not work. . ´-1´

WINDOWS 7 (32bit) - new installation, Winamp not installed before;
LATEST WINAMP downloaded today
theweasel68 is offline  
Old 3rd January 2010, 21:03   #35
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
the plot thickens....
DJ Egg is offline  
Old 4th January 2010, 07:38   #36
Lindoman
Junior Member
 
Join Date: Sep 2000
Posts: 23
I just tried to freshly install Winamp on a brand new drive with fresh WinXP Pro install (with all updates) and got this error. I installed Winamp Remote, unchecked the other extras on that screen. I had unchecked Winamp Agent.

The install fails when on Setup stage. Then after restarting it, the NSCRT.ddl not found error comes up and Setup comes up again and fails when completed. This repeats.

When I copy your nscrt.dll to both directories, the error doesn't come up when restarting Winamp. I can get into winamp and play music.

Then when I got to Preferences, it crashes. I open winamp again and go to Preferences, same thing.

I've been installing and uninstalling Winamp 5.56 a bunch due to another problem ( http://forums.winamp.com/showthread.php?postid=2541329 ) before this new hard drive and didn't get this error before.

I really can't use winamp the way I want without changing preferences so this sucks.

---
Got another error when trying to close it. This didn't happen the first few times:
Quote:
The instruction at "0x10001dfc" referenced memory at "0x079a59d4". The memory could not be "read". Click on OK to terminate the program
---
I have to say I've been using Winamp for a long time and I haven't had anywhere close to the problems I've been having with the recent releases. This sucks.

Last edited by Lindoman; 4th January 2010 at 07:54.
Lindoman is offline  
Old 4th January 2010, 08:12   #37
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Ding ding ding ding ding ding ding!

Ta-da!

Lindoman, you have solved the mystery! Congratulations!

Winamp 5.56 changelog:

* Misc: ml_orb now only installed as part of separate Winamp Remote package


Basically, in 5.56, we removed Remote Media from the "Choose Components" page
(which, when checkmarked, used to just install ml_orb.dll in the Winamp\Plugins dir)
and made it so ml_orb.dll only gets installed if "Winamp Remote" is checkmarked on the "Get the most out of Winamp" page.

When "Remote Media" is checkmarked, the installer checks for an existing version first,
then if a newer version is available, it downloads the package from:
http://download.nullsoft.com/winamp/...s/orbembed.exe

[Edit: 5th Jan] orbembed.exe now updated with non-nscrt.dll-dependent ml_orb.dll [/Edit]

I always uncheck everything on that page,
which is why I've never been able to reproduce the problem...

Well, from what I can gather...

The version of Winamp Remote (not ml_orb.dll, but the actual Orb Networks Remote package) is the same in 5.56 as 5.57x,
and even if the 5.57 version was newer, then it wouldn't make any difference...
because if you manually download the package from that url
and then open orbembed.exe in 7-Zip and extract ml_orb.dll from the "[0]\Plugins" folder,
you'll see that the version of ml_orb.dll says: 5.5.6.2512

D'oh!

Basically, it's still shipping with ml_orb.dll from 5.56
which is nscrt.dll-dependent!

So the problem is therefore going to occur for both upgrades and clean installs.

Hopefully we'll get that orbembed.exe installer updated at some point later today.
DJ Egg is offline  
Old 4th January 2010, 09:01   #38
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
In the meantime....

ml_orb.dll (Remote Media plugin) for Winamp 5.57x

No nscrt.dll dependency (uses msvcr90.dll instead)

(With Winamp closed, run the installer, or just extract ml_orb.dll with 7Zip to the Winamp\Plugins folder)

_____________________________
Attached Files
File Type: exe ml_orb_557x.exe (60.2 KB, 1914 views)

Last edited by DJ Egg; 20th April 2010 at 13:46. Reason: Original attachment was lost in forum upgrade. Reattaching ml_orb_557x.exe
DJ Egg is offline  
Old 4th January 2010, 09:52   #39
muppet
Junior Member
 
Join Date: May 2004
Location: Auckland, New Zealand
Posts: 40
Send a message via ICQ to muppet Send a message via AIM to muppet Send a message via MSN to muppet Send a message via Yahoo to muppet Send a message via Skype™ to muppet
Nice detective work (have been watching this thread!)
muppet is offline  
Old 4th January 2010, 23:13   #40
Lindoman
Junior Member
 
Join Date: Sep 2000
Posts: 23
Sweet, good to hear! and glad I helped since that seems like a pretty major failure to have.. easy fix maybe for a dev but a showstopper for everyday folks. Does this fix the Remote Media problem I had with 5.56 too? (Remote Media completely missing from the left side)

I'll test in the next couple of days to see if I can get Remote Media working.
Lindoman is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump