Old 31st January 2010, 00:15   #1
FlyingPenguins
Junior Member
 
Join Date: Nov 2007
Posts: 13
Song ratings cleared after changing tags

It seems that on Winamp 5.572 under Windows XP, the rating that I create for a song is removed if I were to go to "View Song Info" for the song and click "OK", regardless of whether I change any of the tags or not. (It will not occur if I click "Cancel"."

I'm not sure if this is a bug or if it's a problem on my end, but I'm going to assume it's a bug, since this problem hadn't occurred on any previous version of Winamp.
FlyingPenguins is offline   Reply With Quote
Old 31st January 2010, 03:56   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
D'oh!

Yup. Reproduced. Thanks
DJ Egg is offline   Reply With Quote
Old 1st February 2010, 15:47   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Here's the fixed ml_local.dll (v2.91)

Just download and (with Winamp closed) run the installer.
DJ Egg is offline   Reply With Quote
Old 2nd February 2010, 01:57   #4
FlyingPenguins
Junior Member
 
Join Date: Nov 2007
Posts: 13
Thanks! The problem no longer occurs.
FlyingPenguins is offline   Reply With Quote
Old 18th March 2010, 03:40   #5
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Looks like the attachment was lost during the forum upgrade...

Posting the fixed ml_local.dll v2.91 again (same instructions as above)

______________________________

[edit - DrO Sep 2011]
Removed attachment as people are installing it on newer Winamp versions and reverting other fixes.
DJ Egg is offline   Reply With Quote
Old 18th March 2010, 04:54   #6
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
looks like ALL attachments were lost! a lot of my bugs had screenshots, the threads still have the paperclip showing attachments, but in the thread no attachment!

will it be fixed?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 18th March 2010, 12:51   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
No. Looks like all attachments from the past few weeks have been lost in cyberspace. Sorry :-(
DJ Egg is offline   Reply With Quote
Old 18th March 2010, 19:05   #8
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
thats really disheartening.

so whats the status then of the bugs i filed? i never got replies to most of them.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 9th April 2010, 23:09   #9
Nikolours
Junior Member
 
Join Date: Apr 2010
Posts: 1
Helo it doesn't seems to work on W7 64 bits with winamp 5.572 what is the process to test it in the good way? Thanks
Nikolours is offline   Reply With Quote
Old 18th May 2010, 04:30   #10
wickethewok
Junior Member
 
Join Date: May 2010
Posts: 2
Thanks! This was bugging me.
wickethewok is offline   Reply With Quote
Old 22nd May 2010, 15:06   #11
kargaamel
Junior Member
 
Join Date: Mar 2010
Posts: 2
same as Nikolours I am on W7 64 bit and I don't see any changes. probably ml_local_291.exe isn't installing files to correct locations. can you give us the raw files located in the exe please?

thanks
kargaamel is offline   Reply With Quote
Old 22nd May 2010, 16:02   #12
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
The only file that the ml_local_291.exe installer contains/installs is ml_local.dll to the %ProgramFiles%\Winamp\Plugins folder.

You can use 7-Zip to manually extract ml_local.dll, if you wish...

Sorry, but the above attachment is the only version of ml_local.dll v2.91 available
and the bug is definitely fixed in that.

(latest internal version is v2.92 and includes features/code which will only work with the next release of Winamp)

You probably need to run the installer as admin (via right-click menu) so it'll have permissions to write to %ProgramFiles%\Winamp
DJ Egg is offline   Reply With Quote
Old 29th May 2010, 23:56   #13
beatsandmelody
Junior Member
 
Join Date: Jan 2010
Posts: 44
Wow,this is the first time I've had a bug that wasn't over 4 months old since someone else mentioned it...

Anyway, I will confirm running the EXE didn't do anything (I JUST spent the past couple of days migrating from XP x86 to 7 x64). There has been no change to the behavior.

Oh, I said mention I'm having a slightly different end result than the OP. For me, if I make any changes to the basic info tab, my rating automatically turns in to 5 stars.
beatsandmelody is offline   Reply With Quote
Old 8th June 2010, 02:51   #14
beatsandmelody
Junior Member
 
Join Date: Jan 2010
Posts: 44
Ok, it fixed our original problem, but now I have a new problem.

Now, when I try to edit some files, it just doesn't save the changes. I keep trying to change an album name for one of my albums, by using both CTRL + E and ALT + 3. No saved changes.

Really annoying. I don't have any 3rd party plugins.

Last edited by beatsandmelody; 8th June 2010 at 03:28.
beatsandmelody is offline   Reply With Quote
Old 15th April 2011, 07:01   #15
FlyingPenguins
Junior Member
 
Join Date: Nov 2007
Posts: 13
After being fixed in 5.58-5.60*, the bug reappears in Winamp 5.61 (this time on Windows 7 64-bit). Installing the newer version of ml_local.dll that DJ Egg posted above solved the bug once again.
FlyingPenguins is offline   Reply With Quote
Old 15th April 2011, 13:37   #16
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hmm, I can't reproduce the problem with Winamp 5.61 and ml_local v3.0
Tested with a bunch of mp3 files under Win 7 64-bit.

I really don't recommend using the old ml_local v2.91 (as attached above) with Winamp 5.6x.
DJ Egg is offline   Reply With Quote
Old 15th April 2011, 13:44   #17
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
at this point, i can't tell what bugs the guys above are seeing, or what configs they have.

for my part, i write ratings to file, and it seems rock solid on my 5.61 / win7.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th April 2011, 21:48   #18
FlyingPenguins
Junior Member
 
Join Date: Nov 2007
Posts: 13
I found the problem. Well, it's not really much of a problem, tbh...

After reinstalling Winamp, I found out that I had forgotten that I had the "save ratings to file for compatible formats" option enabled. In that case, the rating will be cleared the first time I open and close the File Info window. After readding the rating, then the new rating will be written to file, and the problem won't occur again.
FlyingPenguins is offline   Reply With Quote
Old 15th April 2011, 22:02   #19
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
Quote:
Originally Posted by FlyingPenguins View Post
I found the problem. Well, it's not really much of a problem, tbh...

After reinstalling Winamp, I found out that I had forgotten that I had the "save ratings to file for compatible formats" option enabled. In that case, the rating will be cleared the first time I open and close the File Info window. After readding the rating, then the new rating will be written to file, and the problem won't occur again.
i don't follow you... are you saying that if the rating is in the ML, but not the tag, and you open the "view file info" dialog, and don't make an edit, close the dialog by clicking ok, it will then void the rating in the ML?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th April 2011, 23:48   #20
FlyingPenguins
Junior Member
 
Join Date: Nov 2007
Posts: 13
Quote:
Originally Posted by MrSinatra View Post
i don't follow you... are you saying that if the rating is in the ML, but not the tag, and you open the "view file info" dialog, and don't make an edit, close the dialog by clicking ok, it will then void the rating in the ML?
Yes, something like that.

If there is already a Winamp-only rating set for a song, and you have "save ratings to file for compatible formats" enabled, then opening/closing the File Info window (regardless of whether you made an edit) will clear the rating.

But afterwards, once a rating for that song file is set (this time saved to the file itself), then opening/closing File Info will not clear the rating.
FlyingPenguins is offline   Reply With Quote
Old 19th April 2011, 06:49   #21
Akdor 1154
Member
 
Join Date: Jul 2005
Location: Victoria, Australia
Posts: 63
not sure if this is related, but if "ratings in tags" is enabled, when re-importing my library backup (i.e. a zip of %APPDATA%\Winamp\plugins\ml), Winamp will successfully import all ratings, then they will quickly vanish before my very eyes. Disabling the ratings in tags feature leads to normal functionality. 5.61, W7 X64.

It seems strange to me, man, strange to me, don't it seem strange to you?
That a country founded on immigration is so damn racist too;
- John Butler Trio - Home Is Where the Heart Is
Akdor 1154 is offline   Reply With Quote
Old 19th April 2011, 15:29   #22
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
imo, best practices would be to use the latest winamp, (the original posts/bugs existed and were fixed prior to winamp being able to write ratings to files), write ratings to files, and use winamp backup tool to save/restore your winamp info.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 31st August 2011, 07:00   #23
DrO
 
Join Date: Sep 2003
Posts: 27,873
if you want the full fix and ability to store ratings in the file tags then you need to upgrade to the currently supported Winamp version (5.621 at the time of this post) rather than trying to bodge an install with a now unsupported test patch dll.

-daz
DrO is offline   Reply With Quote
Old 9th September 2011, 16:06   #24
samwise801
Junior Member
 
Join Date: Jul 2007
Location: Salt Lake City, Utah
Posts: 8
Gah! I love this ml_local plugin you made -- now my ratings write to my mp3 files and not just to the Winamp database. Awesome!

But one problem has popped up since install. Any time I try to create a new or edit an existing Smart View, Winamp throws the following error:

Local Media was unable to load library ("nde.dll") which is required.
Local Media cannot continue successfully and will be turned off.

Any ideas on how to fix this? Usually this error crashes Winamp outright, and everything runs fine until I try to edit or create a Smart View. Standard playlists do not seem to be affected.

Help! Thanks!
samwise801 is offline   Reply With Quote
Old 9th September 2011, 20:15   #25
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
that shouldn't be happening, so perhaps you have a bad 3rd party plugin, or a bad install.

writing ratings is part of the official app now btw, so assuming u have written them all to file first, u might try uninstalling and reinstalling.

u might also run winamp backup tool before you do so, (search the forums).

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 10th September 2011, 11:27   #26
DrO
 
Join Date: Sep 2003
Posts: 27,873
i've removed the earlier attachment as i've a feeling people are installing that and messing up newer Winamp client installs. so samwise801 will need to re-run the Winamp installer (just incase) and then provide a plug-ins list (as per http://forums.winamp.com/showthread....161361#plugins)

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump