Old 26th December 2003, 00:29   #1
MASHtm
Junior Member
 
Join Date: Aug 2003
Posts: 9
parhelia fix for milkdrop 1.04b

Hi!

I think....it looks good and it's working the way it should...at least on my parhelia with latest 1.06beta drivers from Matrox FTP-site.

make a backup copy of vis_milk.dll...then
take the (hex)editor of your choice and change the following two bytes:
0x00002f7f from 0x00 -> 0x02
0x00002f8e from 0x02 -> 0x00

save it...and enjoy

Sidenote: Matrox proofed right. I did exactly what they said at the techforum. Since I have no access to the source it took kind of brute force There are four occurences of such code. I changed only the one occurence which fixes the waveform since milkdrop seems to work fine then (at least for my eyes).

Since I'm not sure if I'm allowed to provide a fixed dll as binary currently only the "do it yourself" version is available. Maybe rovastar can provide one at milkdrop.co.uk.

So, that's my late x-mas present to all of you proud parhelia owners

Regards, MASHtm
MASHtm is offline   Reply With Quote
Old 26th December 2003, 17:50   #2
Rovastar
Moderator
 
Join Date: Jun 2001
Location: London, England
Posts: 3,632
Send a message via AIM to Rovastar
AHa good news for the MAtrox owners

"Rules are for the guidance of wisemen and the obedience of fools"

Visuals - Morphyre www.Morphyre.com
Rovastar is offline   Reply With Quote
Old 31st December 2003, 01:07   #3
sebt
Junior Member
 
Join Date: Oct 2003
Posts: 43
What a great xmas prezzy! Thanks for keeping your eyes peeled on the matrox forum MASHtm, this fix has made me sooo happy thankyou thankyou thankyou and thankyou

- Are you absolutely certain that MD runs properly with just those two bytes fixed?

- Can you tell me the hex addresses to fix for the vis_milk.dll version 1.04? (not 1.04b)

Nb. FYI I am running this fix which appears to work just fine with the current 26-Sept Parhelia drivers 1.05.0.107. A friend of mine tested it with older 1.04.x drivers and that works too.

Woohoo!

Seb
sebt is offline   Reply With Quote
Old 1st January 2004, 03:34   #4
Rovastar
Moderator
 
Join Date: Jun 2001
Location: London, England
Posts: 3,632
Send a message via AIM to Rovastar
Cool F**k Matrox if you have a fix post the dll here

Lucky you caught me when drunk

"Rules are for the guidance of wisemen and the obedience of fools"

Visuals - Morphyre www.Morphyre.com
Rovastar is offline   Reply With Quote
Old 5th January 2004, 10:06   #5
MASHtm
Junior Member
 
Join Date: Aug 2003
Posts: 9
MK 1.04 should work if you change
0x00003b8e: 00->02
0x00003b9d: 02->00

Regards, MASHtm
MASHtm is offline   Reply With Quote
Old 23rd January 2004, 03:55   #6
sebt
Junior Member
 
Join Date: Oct 2003
Posts: 43
MASHtm you are the man, thanks dude
sebt is offline   Reply With Quote
Old 7th February 2004, 14:30   #7
MASHtm
Junior Member
 
Join Date: Aug 2003
Posts: 9
That's interesting....

Winamp people are flaming matrox people even after it is clear that matrox is not responsible for milkdrop failure on parhelia. They even provided a solution I proofed right providing a fix myself.

Today I recognize an updated release of winamp with ... guess yourself ... the same buggy milkdrop as ever.

I'm not sure anymore who are the bad guys now.

Regards, MASH
MASHtm is offline   Reply With Quote
Old 9th February 2004, 12:48   #8
Rovastar
Moderator
 
Join Date: Jun 2001
Location: London, England
Posts: 3,632
Send a message via AIM to Rovastar
Opps I meant that if Matrox aren't goign to let you post the fix then post it here. I have not seen the problem so I do not know if it can be fixed/who/what has the problem.

"Rules are for the guidance of wisemen and the obedience of fools"

Visuals - Morphyre www.Morphyre.com
Rovastar is offline   Reply With Quote
Old 12th February 2004, 14:56   #9
Mind Rubbers
Junior Member
 
Join Date: Feb 2004
Location: England
Posts: 1
Hi there, well done for getting such an awesome visualisation running. Sorry to be a pest but MASHtm mentioned that there are four occurences of such code for milkdrop 1.04b. If you know them, would you mind letting me know? I have only recently switched to the Parhelia having used an nVidea card successfully for quite some time. I have noticed that compared to on the nvidea it looks as though there are one or two little variables which arn't working on the Parhelia. It's only cosmetic but that is the point of Milkdrop isn't it? If you don't mind posting this code I am up for giving it a try as it may be these bits of code which are stopping it from running perfectly. However, I only just figured how to use a hex editor so I may be talking crap!

Cheers, Steve.
Mind Rubbers is offline   Reply With Quote
Old 24th June 2004, 10:15   #10
Phischphood
Junior Member
 
Join Date: Jun 2004
Location: Hampshire, UK
Posts: 7
Um I'm stupid, what the *&^%*£ is matrox and parhelia??? Milkdrop doesn't work for me, and I can't find the line in vis_milk.dll that you're talking about damnit. I would be extremely grateful if someone could give me an explanation/ some help without assuming i know stuff i don't know. Thanks anyway.
Phischphood is offline   Reply With Quote
Old 24th June 2004, 14:35   #11
Rovastar
Moderator
 
Join Date: Jun 2001
Location: London, England
Posts: 3,632
Send a message via AIM to Rovastar
MAtrox is a make of graphics card and the Parheila is one of their cards. The problem occurs for all the MAtrox range it seems and is it appears a bug with MilKDrop

"Rules are for the guidance of wisemen and the obedience of fools"

Visuals - Morphyre www.Morphyre.com
Rovastar is offline   Reply With Quote
Old 25th June 2004, 10:12   #12
Phischphood
Junior Member
 
Join Date: Jun 2004
Location: Hampshire, UK
Posts: 7
thanks rovastar, I don't have that graphics card, and it still doesn't work, but my graphics card is terrible (SiS 650 with 64mb ram)so that probably is the reason, I need a new graphics card
Phischphood is offline   Reply With Quote
Old 26th June 2004, 12:49   #13
JSMain
Junior Member
 
Join Date: Jun 2003
Posts: 37
I believe that's what my laptop has as well! (SIS650)
I'll have to check it on my ATI Radeon AIW
JSMain is offline   Reply With Quote
Old 22nd July 2004, 20:33   #14
JSMain
Junior Member
 
Join Date: Jun 2003
Posts: 37
I'm not sure where to find the 1.04b version, but I have the 1.04 version, and as the fixed DLL has not been posted, I will do so for version 1.04 only.

http://forums.otspeersupport.com/ind...=post&id=47269

This file alteration did fix my problem with 1.04!

Yeah!
JSMain is offline   Reply With Quote
Old 22nd July 2004, 20:36   #15
JSMain
Junior Member
 
Join Date: Jun 2003
Posts: 37
BTW, this fixed both my ATI all in wonder 7200, and my SIS650 video chipset issues.

I'm really curious about 1.04B!
JSMain is offline   Reply With Quote
Old 23rd July 2004, 15:57   #16
JSMain
Junior Member
 
Join Date: Jun 2003
Posts: 37
Oops! Just realized I said AIW 7200 radeon instead of Matrox G450! I have never actually had the time to try it on my AIW as yet.
JSMain is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Visualizations > MilkDrop > MilkDrop Troubleshooting Forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump