Old 26th August 2007, 13:31   #1
VortX
Member
 
VortX's Avatar
 
Join Date: May 2006
Location: Santurtzi, Euskadi (Spain)
Posts: 57
m4a lyrics support / transcoding

m4a lyrics support
will this ever be implemented? I mean, are there any workarounds?
because, nowadays, it's the only thing that makes me keep on using iTunes and not switching completely to "ml_ipod"

transcoding
I have checked "Transcode compatible files above 135 kbps", but when adding 128 kbps m4a files (encoded with iTunes) to my iPod, they get trancoded too, even if Winamp Media Library reports them to be 128 (which obviously is less than 135 )
VortX is offline   Reply With Quote
Old 3rd September 2007, 21:43   #2
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
For lyrics: Put an "[LY]" into the comment field before transfer to the iPod. Then the lyrics should show up, even for m4a.

For the transcoding issue: Set traceflags to 4 (see http://mlipod.sourceforge.net/wiki/Hidden_settings), then transfer one of these tracks, attach the last 30 lines of the main debuglog...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 3rd September 2007, 23:12   #3
fatcerberus1
Major Dude
 
fatcerberus1's Avatar
 
Join Date: Mar 2007
Location: United States
Posts: 806
Actually traceflags is a non-hidden setting as of 3.01. You can find it under Winamp Prefs -> iPod Support -> Advanced; enter "4" in the Trace flags text field.

Windows 7 Beta
iPod touch (Second Generation), 8GB
Winamp 5.55 with ml_iPod 3.08
fatcerberus1 is offline   Reply With Quote
Old 4th September 2007, 00:19   #4
Bilbo9955
Senior Member
 
Join Date: Jan 2007
Posts: 223
Wiki states that only mp3 lyrics are handled and no mention of [LY]
Bilbo9955 is offline   Reply With Quote
Old 4th September 2007, 13:59   #5
VortX
Member
 
VortX's Avatar
 
Join Date: May 2006
Location: Santurtzi, Euskadi (Spain)
Posts: 57
About lyrics, yes, I read the FAQ, Wiki, and them came across the "[LY]" workaround while browsing the changelog. however, I already use the comment field in many files.
But thanks for the BEFORE! I just put [LY] AFTER transcoding, so no lyrics were shown
anyway, no big deal, I don't use lyrics in the iPod too often. just requesting a feature, to make ml_ipod more complete.

about transcoding, which is more important to me. I want to transcode all incompatible files and also compatible files above 135 Kbps to m4a, so I have both options checked and "135" in the "above" box.
I have attached logs from transfers of various files: m4a@128, mp3@128 and mp3@256. But i think the problem is in this line

Quote:
[15:37:46] mustTranscode=1, reason: bitrate=0 mx=135
It seems that bitrates are not read properly from Winamp. Well, that's what I think

If this helps, I'm using a 2GB iPod Nano, 2nd Generation.
Attached Files
File Type: zip mlipod.zip (9.9 KB, 425 views)

Windows 7
Winamp 5.58
VortX is offline   Reply With Quote
Old 4th September 2007, 20:56   #6
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
You can put the [LY] anywhere in the comment field, so you can combine it with your other info.

And yes, you spotted it, the problem is the reported bitrate of 0. This is what Winamp gives us No chance to work around that Winamp bug (I guess it is one)

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 5th September 2007, 08:50   #7
VortX
Member
 
VortX's Avatar
 
Join Date: May 2006
Location: Santurtzi, Euskadi (Spain)
Posts: 57
I'm using the latest beta, v5.36 build 1504. Maybe it's a problem with this beta, because as far as I know, the Media Library has changed a lot. Will you report the bug to the Winamp developers?

Thanks for your help and keep up the good work!

Windows 7
Winamp 5.58
VortX is offline   Reply With Quote
Old 11th September 2007, 21:03   #8
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Don't have the time at the moment. If you use the beta, you are on the betalist already, so you can do it yourself...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 16th September 2009, 19:14   #9
nickharambee
Junior Member
 
Join Date: Sep 2009
Posts: 5
i am using winamp version 5.56 to convert Apple Lossless files to AAC on transfer to my iPod Classic. I would like the lyrics to be transferred too, so i have tried adding [LY] to the comments field, but when I do I get the error message on the iPod lyrics screen "Lyrics detected but unable to retrieve".

is there anything else i could do to get this working, or any other way of getting the lyrics onto my iPod?

thanks

nick
nickharambee is offline   Reply With Quote
Old 17th September 2009, 10:39   #10
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
If the lyrics are stored inside the Apple Lossless files and they are not inside the transcoded AAC, it#s a transcoder issue - not related to ml_ipod. Try to transcode to your HD (SendTo->Format converter) and see if the generated files have the lyrics inside. If not, report it to the Winamp devs.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 17th September 2009, 17:43   #11
nickharambee
Junior Member
 
Join Date: Sep 2009
Posts: 5
hi abu

thanks for the advice. i double-checked that lyrics are embedded in the apple lossless files using Tag&Rename, and they are.

then i just tried converting a track to AAC in Winamp as you suggested and the lyrics were not embedded in the new AAC files.

just to make sure that the issue is with the transcoding, I then copied and pasted the lyrics from one Apple Lossless file into an AAC file in Tag&Rename and also added [LY] to the comments field, and when i then transferred the file to the iPod using ml_ipod, having disabled the transcoding option, all worked fine and i could see the lyrics on the iPod.

So, I will report the issue to Winamp. Presumably I just post it in the Bug Reports section of the forum?

Also, do you know of a way of viewing embedded lyrics in Winamp (I am aware of plugins that automatically download lyrics, but only want to see embedded lyrics)?

thanks

nick
nickharambee is offline   Reply With Quote
Old 17th September 2009, 19:59   #12
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
I don't know if there is a way for embedded lyrics in Winamp, as I don't use that. Sorry.

If you post the bug report, don't mention ml_ipod, only refer to the transcoder.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump