Old 21st October 2009, 02:16   #1
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
No Play or Enqueue in Windows 7 context menu

I've searched and searched for a couple of days now and I can't find a solution for this. I can't figure out how to get 'Play in Winamp' and 'Enqueue in Winamp' on Windows 7's right click context menu when selecting a file of group of files.

The options for Winamp exist for folders, but not for files. WMP is configured for files, and I can't seem to change that.

In Winamp's settings:

'General Preferences > Files Types > Shell Options > Windows Explorer Menu Control > Folder Context Menu'

I can enable or disable settings there and successfully add or remove the items from the folder context menu.

But I can't get any of the options for files to appear on the context menu for files in the 'File Context Menu' settings:

'General Preferences > Files Types > Shell Options > Windows Explorer Menu Control > Folder Context Menu'

Has anyone found a solution for this?

Thx
TS
TakuSkan is offline   Reply With Quote
Old 21st October 2009, 07:07   #2
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
I set up Media Player Classic HomeCinema [MPC-Homecinema.1.3.1249.0.(x86)] and successfully set its preferences to enable context menu options for playing and enqueuing in Windows 7's 'Windows Explorer'.

Looking in Regedit I found it made the following entries:
code:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\mplayerc.mp3]
@="MP3 Format Sound"
"PreviousRegistration"="Winamp.File.MP3"

[HKEY_CLASSES_ROOT\mplayerc.mp3\shell]

[HKEY_CLASSES_ROOT\mplayerc.mp3\shell\enqueue]
@="Add to MPC Playlist"

[HKEY_CLASSES_ROOT\mplayerc.mp3\shell\enqueue\command]
@="\"C:\\Program Files\\MPC-Homecinema\\mpc-hc.exe\" /add \"%1\""

[HKEY_CLASSES_ROOT\mplayerc.mp3\shell\open]
@="Play with MPC"

[HKEY_CLASSES_ROOT\mplayerc.mp3\shell\open\command]
@="\"C:\\Program Files\\MPC-Homecinema\\mpc-hc.exe\" \"%1\""


Earlier today I managed to add registry entries for getting Enqueue and Play for FooBar2000 on the context menu for folders with some help over at Hydrogen.

As I wrote, Winamp does appear in the Window 7's context menu for folders, but not for files.

I see there are the following entries in registry to enable this for files, but can't seem to modify anything there to get things working:

code:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Winamp.File.MP3]
@="MPEG Layer 3 Audio File"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\DefaultIcon]
@="C:\\Program Files\\Winamp\\winamp.exe,1"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell]
@="Enqueue"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Enqueue]
@="&Enqueue in Winamp"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Enqueue\command]
@="\"C:\\Program Files\\Winamp\\winamp.exe\" /ADD \"%1\""

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Enqueue\DropTarget]
"Clsid"="{77A366BA-2BE4-4a1e-9263-7734AA3E99A2}"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\open]
@=""

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\open\command]
@="\"C:\\Program Files\\Winamp\\winamp.exe\" \"%1\""

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\open\DropTarget]
"Clsid"="{46986115-84D6-459c-8F95-52DD653E532E}"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Play]
@="&Play in Winamp"

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Play\command]
@="\"C:\\Program Files\\Winamp\\winamp.exe\" \"%1\""

[HKEY_CLASSES_ROOT\Winamp.File.MP3\shell\Play\DropTarget]
"Clsid"="{46986115-84D6-459c-8F95-52DD653E532E}"


Thanks for any suggestions.

TS

Last edited by TakuSkan; 21st October 2009 at 07:32.
TakuSkan is offline   Reply With Quote
Old 11th November 2009, 16:22   #3
LCadaver
Junior Member
 
Join Date: Nov 2009
Posts: 2
I'm in the same boat... I used the "enqueue" context option constantly under XP. Anyone?
LCadaver is offline   Reply With Quote
Old 11th November 2009, 19:20   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,827
Although Windows 7 isn't properly supported until the next Winamp release...

Close Winamp
Right-click the Winamp desktop icon and select "Run as administrator"
Go into Winamp -> Prefs -> File Types
Select which extensions to be associated with Winamp
Uncheck "Restore file associations at Winamp startup"
Then go to the Shell Options page and set that up to taste
Then go to some other Prefs page, eg. Playlist or Playback
Close Prefs
Close and reopen Winamp (in normal mode, not admin mode)
DJ Egg is offline   Reply With Quote
Old 12th November 2009, 02:12   #5
LCadaver
Junior Member
 
Join Date: Nov 2009
Posts: 2
Aha! Excellent, (or "Egg-cellent"... sorry, it's just so easy) it worked perfectly!

Thank you DJ Egg!
LCadaver is offline   Reply With Quote
Old 12th November 2009, 03:31   #6
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by DJ Egg
Although Windows 7 isn't properly supported until the next Winamp release...

Close Winamp
Right-click the Winamp desktop icon and select "Run as administrator"
Go into Winamp -> Prefs -> File Types
Select which extensions to be associated with Winamp
Uncheck "Restore file associations at Winamp startup"
Then go to the Shell Options page and set that up to taste
Then go to some other Prefs page, eg. Playlist or Playback
Close Prefs
Close and reopen Winamp (in normal mode, not admin mode)
Well I'm glad it worked for LCadaver. But the way I've got things set up in Windows 7, it doesn't work for me.

I don't have any audio files associations set to Winamp. I keep then set to MPC which loads like lightning for all the testing I do.

I did have "Restore file associations at Winamp startup" set, though with none set that option was basically moot. However I did disable it for the test.

I also already had the Shell Options set to Play, Enqueue and Add files in the Context Menu for both files and folders.

It's interesting you suggested moving to another setting area in Preferences after setting the Shell Options, and THEN closing Winamp. I usually find Winamp sets the options as soon as you click on one. But you're the authority DJEgg, and probably have good reason in some instances to do that, so I followed your instructions there.

But I still didn't get Winamp to appear in the Context Menu for files.

I tried a few variations of doing basically the same procedure, as I've had success doing so with other problems in Windows. Things like disabling options, closing the app, then opening the app and resetting them. But nothing I did had any affect.

However right after I first posted this topic, I got a workaround over in the Hydrogen forums involving an unsupported registry hack. Anyone interested can have a look at this link.

That registry hack was for FooBar2000. But you can see that I successfully applied it to Winamp too if you read down that thread a bit.

TS
TakuSkan is offline   Reply With Quote
Old 12th November 2009, 09:55   #7
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,827
Hmmm...

So you've not got any filetypes associated with Winamp in Winamp -> Prefs -> File Types?

The shell context menus only appear for extensions associated with Winamp,
which would explain why it wasn't working for you.

HKEY_CLASSES_ROOT\* is for all files.
We don't touch that key.
DJ Egg is offline   Reply With Quote
Old 13th November 2009, 07:12   #8
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by DJ Egg

So you've not got any filetypes associated with Winamp in Winamp -> Prefs -> File Types?

The shell context menus only appear for extensions associated with Winamp,which would explain why it wasn't working for you.
Oh... I forgot to write that the 1st thing I did when I tried you're solution DJ was to enable Winamp association with .MP3 files in Winamp's preferences. Then disabled "Restore file associations at Winamp startup". Moved over to context menu settings which were already set. Moved to another area of preferences, and closed Winamp.

After opening it again, I checked the Windows context menu for enqueuing files, but no joy.

Enabling and disabling associations from within Winamp does nothing.

I don't know if this is how older Windows OSs required this, but I just ran a few tests and found that I can get Winamp to appear on Win7's context menu by enabling file associations via the context menu's 'Open with' > 'Choose default program' menus. After that's set for a given file type, all the context menu settings I made from within Winamp do show up on its menu for both files and folders.

Quote:
HKEY_CLASSES_ROOT\* is for all files.
We don't touch that key. [/B]
Yes... therefore the warning I got at Hydrogen. I like to keep MPC set as the default program to open media files. So I'll leave that reg hack in place and just try to remember not to open some file or folder that Winamp or FooBar2000 doesn't support.

TS
TakuSkan is offline   Reply With Quote
Old 23rd November 2009, 08:04   #9
Ringthane
Junior Member
 
Join Date: May 2009
Posts: 5
@DJ Egg,

Dude..... Many Thanks for the fix. The Win7 context menu problem has been bugging me since the OS upgrade. What a pain in the rear. You think that with ALL the collaborating M$ was doing for Win7 that Nullsoft would have thier act together. Very sad. Anywho man thanks a mil.

Peace.
Ringthane is offline   Reply With Quote
Old 23rd November 2009, 17:26   #10
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,827
@Ringthane

It's all fixed for our next release.

Note that Winamp 5.56 was released a fair few months before Windows 7 officially was....

In 5.57 (or whatever version # comes next), you won't need to run Winamp in admin mode for Prefs -> File Types (or any other Prefs page which requires registry write access, eg. Prefs -> Winamp Pro -> Enter Reg Key) to work. You will get the UAC prompt, like you do with other programs...

That being said, it was also part-broken for 5.56 under Vista as well, heh.
DJ Egg is offline   Reply With Quote
Old 24th November 2009, 19:26   #11
Ringthane
Junior Member
 
Join Date: May 2009
Posts: 5
@DJ Egg,
Thanks for the info on the next update.

FYI: I bought my current computer in Sept. and so ofcourse it came with Vista. The thing is, Winamp worked with no problems on Vista. Which is why I was so erked that I was having this context menu problem with Winamp on Win7.

Peace.
Ringthane is offline   Reply With Quote
Old 25th November 2009, 19:29   #12
TypeSK
Junior Member
 
TypeSK's Avatar
 
Join Date: Feb 2002
Posts: 43
I had this issue, but i couldn't get the file associations to associate with winamp? I would select all, opening winamp normally and as administrator. i had to go to default programs and set the file associations for each file extension manually?
TypeSK is offline   Reply With Quote
Old 4th December 2009, 07:27   #13
incith
Junior Member
 
Join Date: Aug 2006
Location: Canada
Posts: 8
This (free) program was able to help me solve my context menu issues: http://defaultprogramseditor.com/ (google for default programs editor)

With it, you will want to choose the option File Type Settings, and then click "Delete an extension" at the bottom. Delete mp3 and any others that are not working for you. Restart winamp. Rejoice!
incith is offline   Reply With Quote
Old 31st December 2009, 09:30   #14
Ringthane
Junior Member
 
Join Date: May 2009
Posts: 5
Quote:
Originally posted by incith
This (free) program was able to help me solve my context menu issues: http://defaultprogramseditor.com/ (google for default programs editor)

With it, you will want to choose the option File Type Settings, and then click "Delete an extension" at the bottom. Delete mp3 and any others that are not working for you. Restart winamp. Rejoice!
@incith
Thanks for the nice tip. DJ's fix worked.... sorta. I had only tested DJ's solution with Flac files. Later I discovered that it did not solve the problem with mp3's. Your tip has successfully resolved the issue.

@DJ Egg.
Unfortunately, the 5.57 update did NOT fix the context menu issue, at least not for me. Still, I appreciate your efforts.

Peace to all and have a Happy New Year !!!!!!!!
Ringthane is offline   Reply With Quote
Old 1st February 2010, 22:24   #15
Ringthane
Junior Member
 
Join Date: May 2009
Posts: 5
Update:
I still had problems with this issue. Although the posted fixes listed above work, for me the solutions were not permanent. I realized that this was not really an issue with WinAmp but rather that the fault lies with Windows Media Player. WMP keeped hijacking my default player preferences. So my absolutely permanent fix was to UNINSTALL WMP. And it works like a charm. No more problems.

Instructions:
Click on Start Menu > Control Panel > Programs > Turn Windows Features On and Off.
This will give yu the following pop-up window:



Uncheck the boxes for Windows Media Player and Windows Media Center. Next click ok. Click yes/ok if you are prompted with a warning about other features or dependency issues. When the uninstall is complete you will be prompted to restart your computer. Click the reboot button. After rebooting you may still need to follow DJ's instructions to reset the context menu, however, I did not.

Hope this helps anyone that is fed up with M$ policy of "It's My Way or the Highway".

Peace.
Ringthane is offline   Reply With Quote
Old 7th February 2015, 05:09   #16
petrica05
Junior Member
 
Join Date: Feb 2015
Posts: 1
non of this worked for me

I had to unninstall winamp , reinstall it , right click on icon - run as administrator
then go to options - preferences shell options (under file types)
check the first two checkboxes (add enqueue... and set enqueue... )
then click on playlist than click Close.
Exit winamp. Than it worked for me on win 7 x64 pro.
petrica05 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump