Old 6th May 2004, 04:01   #1
DrO
 
Join Date: Sep 2003
Posts: 27,873
Winamp Update

Read Me Now
Download Patch

Need i say anymore, no i don't think so other than enjoy!

-daz
DrO is offline  
Old 6th May 2004, 04:04   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
More info

master beta tester at work

lol



Note: this OFFICIAL patch is for Winamp 5.03
It doesn't upgrade older versions (5.0, 5.01. 5.02) to 5.03.
ie. You need to install 5.03 and then the patch.
This also applies to 5.03c
(the only change from 5.03a to 5.03c is the added emusic trial promo)
ie. this pre-5.04 patch is NOT included with ANY 5.03 build.

The patch will be obsolete only when 5.04 is publically released.
DJ Egg is offline  
Old 6th May 2004, 12:16   #3
inthegray
Major Dude
 
inthegray's Avatar
 
Join Date: Sep 2003
Posts: 704
Send a message via AIM to inthegray
good work, dro and egg.

dro, why not mention it in the releases section? (hint)
inthegray is offline  
Old 6th May 2004, 12:34   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
inthegray: i don't know what you mean, it was already in there

-daz
DrO is offline  
Old 6th May 2004, 13:02   #5
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
excuse me DrO.... the option in winamp that notify me if exist a newer winamp version.... why don't work???

For Ex.= If i have winamp version 5.03 on load (and internet logged) must appear a window "Winamp 5.03a released such as GetRight does"

thanx

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 6th May 2004, 13:05   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
Cianca: it's a website issue that doesn't seem to have been fixed yet (it currently indicates that the newest winamp is 2.80a)

-daz
DrO is offline  
Old 6th May 2004, 13:07   #7
inthegray
Major Dude
 
inthegray's Avatar
 
Join Date: Sep 2003
Posts: 704
Send a message via AIM to inthegray
i haven't seen that work in a whiiiillllleeee....
inthegray is offline  
Old 6th May 2004, 13:10   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by inthegray
i haven't seen that work in a whiiiillllleeee....
yeah, 2.8 was a good 2+ years back now i think.

Cianca: http://forums.winamp.com/showthread....hreadid=178279 has more info on things

-daz
DrO is offline  
Old 6th May 2004, 13:12   #9
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
I'm Gonna Kill DJ EGG!!!!

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 6th May 2004, 13:18   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by Cianca
I'm Gonna Kill DJ EGG!!!!
? what has DJ Egg done for you to say that?

-daz
DrO is offline  
Old 6th May 2004, 13:21   #11
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
mahuahahaahaa i'm joking....

DJ EGG or another Winamp's Developer or Winamp Forum boss

you want to suggest me a name???

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 6th May 2004, 13:31   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
Cianca: blame Cheezychops, he sucks (and a quick check of GD will prove that)

and now back on to topic plzkthx

-daz
DrO is offline  
Old 6th May 2004, 13:39   #13
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
[OFF TOPIC]
Is so simple.......... I'm gonna KILL WILL!!!

...excuse me good work good guy[/end OFF TOPIC]

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 6th May 2004, 13:45   #14
inthegray
Major Dude
 
inthegray's Avatar
 
Join Date: Sep 2003
Posts: 704
Send a message via AIM to inthegray
dro, any possibility that this could be a plug-in for winamp, instead of a standalone? maybe have it check on startup if it's been updated, and bring up a window to notify the user, or maybe do something else... it's a crazy idea and probably unworkable, but i just thought i'd throw it out there.
inthegray is offline  
Old 6th May 2004, 13:49   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
inthegray: why re-invent the wheel? yeah it could be done as a plugin but all that's needed is an update on the winamp.com site from what i can gather. let's hope they do fix it (but i'm not holding my breathe... )

-daz
DrO is offline  
Old 6th May 2004, 13:58   #16
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
@DrO, so if i dl this, ill know when 5.04 is coming out, right?
billyvnilly is offline  
Old 6th May 2004, 14:02   #17
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by billyvnilly
@DrO, so if i dl this, ill know when 5.04 is coming out, right?
nice try, it's just an interim update to put winamp to 5.03b or something like that

when 5.04 is ready then it'll be released.

-daz
DrO is offline  
Old 7th May 2004, 21:20   #18
D&B
Banned
 
Join Date: Mar 2001
Posts: 1,027
Thanks.
D&B is offline  
Old 8th May 2004, 22:51   #19
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
thanks!
it did fix the media library delay (when starting a lot of songs at a time) as well!
i felt so lucky when noticing that!
siebe83 is offline  
Old 9th May 2004, 06:56   #20
nierke
Senior Member
 
nierke's Avatar
 
Join Date: Nov 2001
Location: Lithuania
Posts: 295
I don't know if it is a bug or not, but after instaling this patch, then I try to add a directory to new playlist, winamp just close... no error message or smth.. any idea whats happened?

...:::nierke:::...
nierke is offline  
Old 9th May 2004, 11:44   #21
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Can't reproduce it here. We're gonna need more info than that.

Adding dir via Playlist -> Add -> Add Folder?
or via: Explorer context menus -> Enqueue in Winamp?

Happens with all folders?
What file types are in this folder?
All mp3? A mix of mp3, wma, video, other?

Windows OS?
Any 3rd-party/extra plugins installed?
Any info in EventViewer / Dr Watson?
DJ Egg is offline  
Old 9th May 2004, 14:59   #22
nierke
Senior Member
 
nierke's Avatar
 
Join Date: Nov 2001
Location: Lithuania
Posts: 295
Windows XP Pro
PIII 533Mhz
RAM 256Mb
Video 64MB GeForse 4 MX 420

I tried to reinstall winamp, I deleted everything what was left after uninstall, but it didn't help, no plugins installed after reinstaling winamp :]

It happend only with my music dir, there is ~2500 files, also there is few wma files, others are mp3.

I'm adding dir via Playlist -> Add -> Add Folder.


...:::nierke:::...
nierke is offline  
Old 9th May 2004, 22:50   #23
glop
Senior Member
 
Join Date: Dec 2002
Location: Paris
Posts: 454
Quote:
mms://vip6.yacast.fr/encodernrj
mms://vipbu.yacast.fr/encodernrj
mms://viptvr2.yacast.net/tvr_europe2
mms://vip6.yacast.fr/encodernostalgie
mms://vipbu.yacast.fr/encodernostalgie
can't be read after the patch installed...why !!
glop is offline  
Old 10th May 2004, 00:13   #24
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
@glop

Those mms:// streams won't play in Windows Media Player either.
So I assume that the problem is at the station end somewhere,
and it's just a coincidence that you installed the patch at around the same time.
Looks like you'll need to take up the issue with the station instead.

[edit] Scrap that. Issue has been reproduced here. Please do not crosspost [/edit]

btw, to get mms:// streams to play in Winamp,
you need to add /.wma to the end of the url.
With the patch, this now makes in_dshow.dll pass the streams on to in_wm.dll
so it now works exactly the same as it did in Winamp 2.8x and earlier.

eg.

mms://80.250.164.219/7button64k/.wma (64kbps)
mms://alternantes.tvr.ipercast.net/live/alternantes.tvr/direct.wma?site/.wma (96kbps)
mms://wmbcast.npr.na-central.speedera.net/wmbcast.npr.na-central/wmbcast_npr_na-central_mar132003_0735_32897/.wma (8kbps)
mms://radioio.wm.llnwd.net/radioio-hi/.wma (128kbps)
http://wma.str3am.com/xpndotorg/.wma
etc

@nierke
I'm not sure what's going on there.
Are all the files in the root dir of your music folder, or in subfolders?
Try adding subfolders separately, until you find the file(s) which is/are causing the crash...
DJ Egg is offline  
Old 10th May 2004, 00:22   #25
glop
Senior Member
 
Join Date: Dec 2002
Location: Paris
Posts: 454
DJ Egg > yeah i know. this stream match only when you sea the player of the radio...so ..protected stream exists ?
( replacing mms:// by http:// > same trouble, add /.WMA same trouble (mms or http)
glop is offline  
Old 10th May 2004, 01:48   #26
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
If you are using Play > URL make sure you don't include any extra spaces after the stream address. This confuses Winamp into thinking it's an Mp3 and gives [HTTP/1.0 400 Bad Request] or [could not connect]

(edit)
Looks like this is caused by Winamp not recognizing the extension and defaulting to Mp3. Changing the default extension to wma fixes it. ((Ctrl+P) > Playlist). First time I've ever used this option
(/edit)

PS. Thought this was fixed Egg.

UJ

Last edited by ujay; 10th May 2004 at 02:27.
ujay is offline  
Old 10th May 2004, 04:14   #27
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Well done ujay. I would've never thought of that in a million years.
btw, mms://vip6.yacast.fr/encodernrj (and all the other ones) play with in_dshow.dll for me...
but am I correct in saying that you don't have in_dshow
and in_wm.dll is handling the streams for you
(when you change "extension for unknown filetypes" to wma)?

btw, it appears to be fixed for just about all mms://.../.wma streams, except for these :/

[edit] Hmm, well it worked with in_dshow the first time I tried, but not the second time.
Now it's just entering the eternal looping buffer again.
Bleh. Weird! [/edit]
DJ Egg is offline  
Old 10th May 2004, 07:03   #28
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Correct Egg - no in_dshow.dll.

Hope I was clear in the last post, this was a fix for a space added to the stream address, not a fix for the connection problem Best fix is not to put the space there in the first place.

UJ
ujay is offline  
Old 10th May 2004, 08:38   #29
nierke
Senior Member
 
nierke's Avatar
 
Join Date: Nov 2001
Location: Lithuania
Posts: 295
Quote:
Originally posted by DJ Egg


@nierke
I'm not sure what's going on there.
Are all the files in the root dir of your music folder, or in subfolders?
Try adding subfolders separately, until you find the file(s) which is/are causing the crash...
ok found that dir, there were ~20 files of 0 kilobytes, I'm not sure why but it makes winamp crash after installing this patch.

...:::nierke:::...
nierke is offline  
Old 10th May 2004, 08:44   #30
nierke
Senior Member
 
nierke's Avatar
 
Join Date: Nov 2001
Location: Lithuania
Posts: 295
Maybe there is connection with this:

Quote:
-Corrupt id3v2 tags causing Winamp to use large amount of memory.(also fixes issue with inaccurate bitrate calculation on some mp3's)

...:::nierke:::...
nierke is offline  
Old 20th May 2004, 10:38   #31
soljarag
Member
 
Join Date: May 2003
Posts: 92
yay!!!! you guys fixed the delay in ML now winamp kicks ass again
soljarag is offline  
Old 28th May 2004, 06:06   #32
nierke
Senior Member
 
nierke's Avatar
 
Join Date: Nov 2001
Location: Lithuania
Posts: 295
Where are everybody gone?

...:::nierke:::...
nierke is offline  
Old 28th May 2004, 17:21   #33
starship50
Junior Member
 
Join Date: May 2004
Location: outer space
Posts: 17
is the update for version 5.03? i downloaded it. i have version 5.03.
starship50 is offline  
Old 28th May 2004, 17:24   #34
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by starship50
is the update for version 5.03? i downloaded it. i have version 5.03.
yes, it's intended for 5.03 though most parts will work when run on the older 5.0x releases

-daz
DrO is offline  
Old 28th May 2004, 17:31   #35
starship50
Junior Member
 
Join Date: May 2004
Location: outer space
Posts: 17
thanks. i downloaded version 5.03 first then i downloaded the update. so far i have not had any problems. i'm using the invicta skin. i like all the colors that it has.
starship50 is offline  
Old 2nd June 2004, 16:15   #36
kevinraven
Junior Member
 
Join Date: Jun 2004
Posts: 7
I am trying to connect to mms://195.109.181.143/funx/.wma but it doesn't work for me. I am using file/play url for this, not sure if that's the correct way of doing it. I can listed to that station through by browser by going to http://www.funx.nl/stream.asp but I would like to listend to it through Winamp. Is there any way of getting it to work?

I am using Winamp v 5.03a and I did not download the update by the way. I don't think the update is necessary for this?

Is it possible to delete the url history, I mean the urls that appear in the dropdown menu of Open Url?

Cheers,

Kevin.
kevinraven is offline  
Old 2nd June 2004, 17:00   #37
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
mms://195.109.181.143/funx/.wma working o.k. here.

Download the patch and try, some of the new work concerns WMA files.

To clear the URL history :
Go to 'Winamp.ini' (in your main Winamp folder) and open it in 'Notepad'.
Scroll through to the RecentURL entries and delete them. Save and close.

(edit) Make sure you do this while Winamp is closed. (/edit)

UJ

Last edited by ujay; 2nd June 2004 at 17:17.
ujay is offline  
Old 2nd June 2004, 17:16   #38
kevinraven
Junior Member
 
Join Date: Jun 2004
Posts: 7
It's working after I installed the patch. Great!

Thanks,

Kevin.
kevinraven is offline  
Old 3rd June 2004, 20:19   #39
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Was there an update to the update, just noticed the latest d/l is not the same length as the one I installed.
Or is there no operational difference.

UJ
ujay is offline  
Old 3rd June 2004, 20:26   #40
DrO
 
Join Date: Sep 2003
Posts: 27,873
there was a slight update (hence the different date)

"new in_wm.dll with correct version #, and a minor bug fix by Christophe, but no-one knows what it was"

-daz
DrO is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump