Old 2nd August 2005, 06:13   #1
beanboy89
(Major Dude)
isn't very custom
 
beanboy89's Avatar
 
Join Date: Nov 2003
Location: Pennsylvania, USA
Posts: 2,004
Audio CD skips at beginning of track

I have noticed that if I play an audio CD with Winamp, within the first second of any track on the CD, the audio stops for about a second, then continues playing as normal. At first, I thought the problem was caused by the fact I was playing the CD in a DVD-RW drive, but then I tried to play the CD in a secondary, CD-only drive, the same problem occurs. I also tried the CD in WMP(yuck), but no skips. Any way to cause the CD to play the track without skipping at the beginning?

I did see some possibly relevant threads in a search, even a thread linked to in TSGH, but all were old, and I found little (helpful)information.

System specs:
HP Pavilion a1050y
Pentium 4 3.0 GHz
512 MB RAM
Windows XP Home SP2
Winamp 5.094 Full; clean install
beanboy89 is offline   Reply With Quote
Old 2nd August 2005, 09:34   #2
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,226
Hey beanboy!

Try unchecking this option:
Prefs (Ctrl+P) > Input > double-click Nullsoft CD/LineIn plug-in > 'Use Sonic engine when possible'

And then make Winamp use wnaspi32.dll for Digital Audio Extraction instead.

You can also try the DirectSound output tweaks (although those suggestions are not specifically related to CD playback).

If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 2nd August 2005, 11:27   #3
SVTADAM
Junior Member
 
Join Date: Aug 2005
Posts: 9
i noticed this happening to mine as well. I will have to check on the settings later today. Hopefully this fixes it.
SVTADAM is offline   Reply With Quote
Old 2nd August 2005, 15:57   #4
beanboy89
(Major Dude)
isn't very custom
 
beanboy89's Avatar
 
Join Date: Nov 2003
Location: Pennsylvania, USA
Posts: 2,004
Thanks siebe!

Unchecking the Prefs (Ctrl+P) > Input > double-click Nullsoft CD/LineIn plug-in > 'Use Sonic engine when possible' seemed to work great.
beanboy89 is offline   Reply With Quote
Old 3rd August 2005, 17:00   #5
Greg09
Junior Member
 
Join Date: Aug 2005
Posts: 1
Re: Audio CD skips at beginning of track

HELP!I've read this and I have no idea how to do reset any of the options like wnaspi32.dll and unchecking other things. I guess what I'm trying to say is that I don't have the knowledge to make these changes without step by step instructions. Like where do I start?

Hey beanboy!

Try unchecking this option:
Prefs (Ctrl+P) > Input > double-click Nullsoft CD/LineIn plug-in > 'Use Sonic engine when possible'

And then make Winamp use wnaspi32.dll for Digital Audio Extraction instead.

You can also try the DirectSound output tweaks (although those suggestions are not specifically related to CD playback).

[QUOTE]Originally posted by beanboy89
[B]I have noticed that if I play an audio CD with Winamp, within the first second of any track on the CD, the audio stops for about a second, then continues playing as normal. At first, I thought the problem was caused by the fact I was playing the CD in a DVD-RW drive, but then I tried to play the CD in a secondary, CD-only drive, the same problem occurs. I also tried the CD in WMP(yuck), but no skips. Any way to cause the CD to play the track without skipping at the beginning?

I did see some possibly relevant threads in a search, even a thread linked to in TSGH, but all were old, and I found little (helpful)information.
Greg09 is offline   Reply With Quote
Old 3rd August 2005, 17:29   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
First, note that this Known Bug is fixed for the next release
(it was a buffer config mismatch issue with Sonic Engine vs DirectSound Output).

Until then, the step-by-step instructions are:

1. Tell us what your Windows OS is!
These are the instructions for Win2k/XP/2003
If using Win9x/ME then the instructions are different.

2. In Winamp, go to: Prefs (Ctrl+P) > Plugins > Input > in_cdda.dll > config:
Keep "Use Digital Audio Extraction" checkmarked
Uncheck "Use Sonic Engine"
Close Prefs
Close Winamp

3. Place wnaspi32.dll in the Winamp root folder

4. Reopen Winamp...
DJ Egg is offline   Reply With Quote
Old 30th August 2007, 15:42   #7
neyel8r
Junior Member
 
Join Date: Feb 2006
Posts: 5
Quote:
Originally posted by siebe83
Try unchecking this option:
Prefs (Ctrl+P) > Input > double-click Nullsoft CD/LineIn plug-in > 'Use Sonic engine when possible'
thx 4 this info, it worked!
neyel8r is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump