Old 10th March 2006, 11:08   #1
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,436
Winamp 5.21 Released

Winamp 5.21

Winamp 5.21 Full emusic plus
Winamp 5.21 Pro (asks for key during install)
Winamp 5.21 Lite

Whats new:
* New: [jnetlib] HTTP compression support
* Improved: [installer] multi-user profile migration
* Fixed: [ml_wire] memory leak
* Fixed: [pmp_p4s] DRMclien.dll error
* Fixed: [gen_ff] skin info display in preferences
* Fixed: [in_mp3] Wordwrap disabled in Info Editor Comments field
* Fixed: [in_wm] Minor bug fixes
* Fixed: Keyboard shortcuts don't work from video window
* Fixed: [in_vorbis] No Artist metadata in stream titles
* Fixed: [in_dshow] floating point audio
* Fixed: ml_ipod and pmp_ipod conflict
* Updated: Coding Technology AAC+ Decoder 7.2.5


Please do not post any issues in this thread which require Tech Support
(eg. unreproducable crashes, slow load times, strange error messages, etc).
Please post them in a new thread in the Tech Support forum,
and remember to include all relevant info.


______________________________________________
Old Winamp 5.2 Released thread

CraigF is offline   Reply With Quote
Old 10th March 2006, 11:08   #2
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,436
If you are using ml_ipod, and still see pmp_ipod loaded in the portables config dialog, please re-download and reinstall Winamp. This should prevent the inferior itunes database code in ml_ipod from shredding your ipod database when used alongside pmp_ipod.

Note that the initial upload of 5.21 did not include this hotfix.

CraigF is offline   Reply With Quote
Old 10th March 2006, 13:07   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
Undocumented
_________________________________________________________

New Feature:
Year column in Local Media > Audio > Album pane (top right pane)

_________________________________________________________


Re: Fixed: [in_dshow] floating point audio

As referenced in the known bugs list, in_wave v3.0 still doesn't support embedded mp3 in riff-wav's, nor some codecs like dsp truespeech.

As from v5.21, in_dshow can now support all wav files, including 32-bit float point.
However, the automation process for this method has not yet been implemented, but should be finalized in a forthcoming release.

Sure, you can still use the old in_wave 2.x from 5.13 (see known bugs thread for link), but if you need support for 32-bit float point wav's and/or multi-user profile support (neither of which are supported by old in_wave), then for now you can manually setup Winamp as follows:

Prefs > Plugins > Input:

Waveform Decoder v3.0 (in_wave.dll) > config
Deselect WAV from the extension list

DirectShow Decoder (in_dshow.dll) > config
Add ;WAV to the end of the list of extensions

To make the library recognize WAV's as audio instead of video:

Note, the 2 steps below are no longer required as from 5.25

Right click Local Media > Audio
Select "Edit View"
Change the Query in the Advanced Editor tab as follows:
(type = 0) OR (filename ends wav)

Right click Local Media > Video
Select "Edit View"
Change the Query in the Advanced Editor tab as follows:
(type = 1) AND !(filename ends wav)


Again, I reiterate that this entire process should be automated in a forthcoming release (eg. 5.24), and when it is, you'll then be able to change the audio & video views back to the default queries.

Also note that kbps display in the main window shows as 0, and File Info in the DirectShow Info Viewer (Alt+3) doesn't show any relevant WAV info (samplerate/frequency/bitrate/etc). Again, all these issues will hopefully be addressed/resolved in a forthcoming release.


FAQ:

Q: What method does in_dshow use for WAV playback?
A: Wave Parser and ACM Wrapper


Of course, if you don't have any problems with WAV playback (ie. you don't need support for mp3-layered wav or dsp truespeech etc) then you can just ignore all this and continue to use in_wave v3.0 as before.

_____________________________________________


Online Services

You may have noticed in 5.2 that 'bookmark' appeared in the right-click menu for sc-radio/tv items, but didn't work, ie. it just enqueued the streams instead. This is fixed in 5.21 and the new ml_online.dll now supports 'bookmark' from the right click menu. Yay!

5.21 now also supports http compression, which should help to speed up the 'loading' process.

There will be more serverside fixes/changes applied over the next few days, eg. Speeding up of the re-rendering process (on sort & resize), and Shift+click for multi-selection.

Please do not report that Shift+click is working like Ctrl+click and that Ctrl+click doesn't do anything. We know about this issue. The Media Library is somehow eating both the Del and Ctrl keys, so for now we've had to use Shift+click instead. Again, these issues will hopefully all be addressed in a forthcoming release.

_________________________________________________


Re: Improved: [installer] multi-user profile migration

Installer Options > Screen 4 (multi-user settings)

In 5.2, if you selected "separate settings per user" then you weren't given an option to import the current user settings when upgrading.

If you selected this option in 5.2 then there will now be a paths.ini file in the Program Files\Winamp root folder, and the "use existing settings" installer option will be automatically selected. If there's no paths.ini then this option will be grayed-out.

If you are selecting the "separate settings per user" option for the first time,
then to import settings from a previous installation,
checkmark "copy settings to the new place".
By default, this will copy your settings & library database from
Program Files\Winamp to %appdata%\Winamp
though you can manually change the source & destination paths if needs be.

__________________________________________


Re: Portable Media Player support / iPod support

If you were previously using the 3rd-party ml_ipod plugin...
then if ml_ipod is still present, and you checkmark support for native pmp_ipod support in the installer, then pmp_ipod will not load, and winamp 5.21 will continue to use ml_ipod as before.

If you want to try/use the new pmp_ipod component, then you will need to delete/disable ml_ipod.dll BEFORE installing 5.21

The reasons for this are that if both ml_ipod and pmp_ipod plugins are present and active then there will certainly be conflicts (as was the case in 5.2).

____________________________________________


Oh, and there's initial support for ssl/https streams,
but only for ssl vorbis streams for now, heh.
mp3 support and other formats hopefully coming later.

____________________________________________


Other than that, 5.21 is mainly a bug fix release.

Build 5.2.1.497
DJ Egg is offline   Reply With Quote
Old 10th March 2006, 13:34   #4
Trent187
Junior Member
 
Join Date: Jan 2004
Posts: 44
<space for lease>

Always good to see an update. Thanks!

Also, I've noticed since 5.2 was released, when I load my songs into my playlist all at once (2,100 or so), that it only takes 10 seconds to load all the data (I have it set to load all tags at once). Before 5.2, it took like 2 minutes. Was there some kind of fix for this that was done? Thanks again!
Trent187 is offline   Reply With Quote
Old 10th March 2006, 18:56   #5
George Worley
Junior Member
 
Join Date: Jun 2002
Posts: 35
Where is 5.21?

What is still on the download servers is still 5.2.


George
George Worley is offline   Reply With Quote
Old 10th March 2006, 19:11   #6
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,436
See the second post. new builds are incoming.

CraigF is offline   Reply With Quote
Old 10th March 2006, 19:35   #7
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,436
new builds now posted.

CraigF is offline   Reply With Quote
Old 10th March 2006, 19:44   #8
DualCORE
Junior Member
 
Join Date: Feb 2006
Location: UK
Posts: 2
thanks
DualCORE is offline   Reply With Quote
Old 10th March 2006, 20:26   #9
shakey_snake
Forum Domo
 
shakey_snake's Avatar
 
Join Date: Jan 2004
Location: Everyone, get over here for the picture!
Posts: 4,334
can't... download...


elevatorladyelevatorladyelevatorladyelevatorladyelevatorladylevitateme
shakey_snake is offline   Reply With Quote
Old 10th March 2006, 20:44   #10
Enzifer
Junior Member
 
Join Date: Aug 2004
Posts: 8
I can't download too...
Enzifer is offline   Reply With Quote
Old 10th March 2006, 20:48   #11
redeemer
Junior Member
 
redeemer's Avatar
 
Join Date: Aug 2004
Posts: 5
same here =/
redeemer is offline   Reply With Quote
Old 10th March 2006, 20:59   #12
blo
Empire Builder v2
 
Join Date: Mar 2006
Location: Bethesda, MD
Posts: 70
Try again....should be good to go from here on out.
blo is offline   Reply With Quote
Old 10th March 2006, 23:28   #13
Maktaka
Junior Member
 
Maktaka's Avatar
 
Join Date: Oct 2002
Posts: 17
I didn't see any mention of Shoutcast bookmarking making its return. Is this feature still MIA?
Maktaka is offline   Reply With Quote
Old 11th March 2006, 00:42   #14
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
Yes, as referenced in my post above, the bookmark feature is back in 5.21
(well, it actually appeared first in 5.2 a couple of days ago, but didn't work)
DJ Egg is offline   Reply With Quote
Old 11th March 2006, 00:44   #15
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,386
5.12 ??
[edit] never-mind

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 11th March 2006, 00:47   #16
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
bleh
DJ Egg is offline   Reply With Quote
Old 11th March 2006, 08:52   #17
SadEye
Junior Member
 
SadEye's Avatar
 
Join Date: Aug 2003
Location: Shangri-La
Posts: 45
still WA 5.2.0.473?

Don't part with your illusions,
When they are gone you may still exist,
But you have ceased to live.
SadEye is offline   Reply With Quote
Old 11th March 2006, 10:10   #18
cppman
Member
 
cppman's Avatar
 
Join Date: Aug 2002
Posts: 84
Station Info Borked

The station info gets messed up if playing a stream from a bookmark or playlist instead of station browser or whatever its called.

Reproduction:
Play a station from the ML.
Close winamp
Open winamp
Play the station from the playlist
Open the station info window
Its empty
cppman is offline   Reply With Quote
Old 11th March 2006, 14:12   #19
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,076
@ ccpman - That's the expected behaviour.

If you notice, when you load a station from the ML it is first converted from a tunein_ID(how the ML references stations) to a URL(how the Playlist references stations) before being played.

If you later play it from a Playlist then the SI window no longer has the tune_inID available and nothing will show in the SI.

If you want to save a station and keep the tune_inID then use right click > Bookmark from the ML.

UJ
ujay is offline   Reply With Quote
Old 11th March 2006, 14:54   #20
BoyNG
Member
 
BoyNG's Avatar
 
Join Date: Feb 2006
Location: Russian Federation
Posts: 60
Send a message via ICQ to BoyNG

What's wrong with gen_ff.dll?
I translate Modern skin to Russian (tooltips), but now im get message (error in XML data: container closed but group still open, closing group)
In the previous version it was difficult enough to pick up Russian symbols, but now it is not so possible!

Please Help!

(sorry for ugly English)
BoyNG is offline   Reply With Quote
Old 11th March 2006, 21:31   #21
pEar 242
Member
 
pEar 242's Avatar
 
Join Date: Feb 2006
Location: Moscow, Korolev
Posts: 97
Yes, there is such problem.
(I'm Russian BoyNG!!!!!!!!!!)
pEar 242 is offline   Reply With Quote
Old 12th March 2006, 00:04   #22
gordol
Member
 
Join Date: Oct 2004
Posts: 93
Does this fix the problems with pmp_ipod fracking up the syncing to an iPod?
gordol is offline   Reply With Quote
Old 12th March 2006, 00:55   #23
cppman
Member
 
cppman's Avatar
 
Join Date: Aug 2002
Posts: 84
Ah, ok. I don't really care about the station info that much actually, but from a user standpoint it seems like a big inconsistancy. It really shouldn't matter where you bookmark something from.
cppman is offline   Reply With Quote
Old 12th March 2006, 04:27   #24
acidash
Junior Member
 
Join Date: Mar 2006
Posts: 1
id tag unicode support?
acidash is offline   Reply With Quote
Old 12th March 2006, 06:13   #25
BoyNG
Member
 
BoyNG's Avatar
 
Join Date: Feb 2006
Location: Russian Federation
Posts: 60
Send a message via ICQ to BoyNG
Quote:
Originally posted by pEar 242
Yes, there is such problem.
(I'm Russian BoyNG!!!!!!!!!!)
YESSSS!!!
Im found answer on this problem!
In XML use UTF encoding or add
<?xml version="1.0" encoding="windows-1251"?>
for WinCyr encoding!
BoyNG is offline   Reply With Quote
Old 12th March 2006, 10:22   #26
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,194
Send a message via AIM to MrSinatra
Quote:
Originally posted by DJ Egg
Undocumented

5.21 now also supports http compression, which should help to speed up the 'loading' process.

There will be more serverside fixes/changes applied over the next few days, eg. Speeding up of the re-rendering process (on sort & resize), and Shift+click for multi-selection.
does this feature only apply to video?

i stream my FM station using 5.2, and i want to know if this is areason for me to upgrade, or if there is another reason in the release to do so.

many thx, -mdw

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 12th March 2006, 11:41   #27
pEar 242
Member
 
pEar 242's Avatar
 
Join Date: Feb 2006
Location: Moscow, Korolev
Posts: 97
Quote:
Originally posted by BoyNG
YESSSS!!!
Im found answer on this problem!
In XML use UTF encoding or add
<?xml version="1.0" encoding="windows-1251"?>
for WinCyr encoding!

I wish to translate Nullsoft Media Player V3.1, but I cannot make it. I receive an error.
Whether require *.maki scripts changes or I that that not so I do.
In..... Skins\Skin Name\skin.xml

<?xml version = "1.0" encoding = "UTF-8" standalone = "yes"?>
<WasabiXML version = "1.2">

It does not work.

Or...
________
<?xml version = "1.0" encoding="windows-1251"?>
<WasabiXML version = "1.2">

This same does not work.
Whether everyone skin can it?

Please, explain on an example.
pEar 242 is offline   Reply With Quote
Old 12th March 2006, 12:08   #28
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
@MrSinatra
http compression basically means that the pages for Online Services will now download and appear quicker than they did before we had http compression. It's got nothing to do with the actual audio/video streams, just the listings.

@acidash
Yes, id3v2 unicode support was implemented in 5.2

@gordol
Not sure what you meant, but I think the answer is yes.
There was some fix for duplicate files being uploaded when using sync/autofill.
The other fix was to make sure the native pmp_ipod plugin doesn't load if the old 3rd-party ml_ipod plugin is present, to avoid conflicts between the two plugins (ie. it's best to make sure only one of the two plugins is present first, not both).

@cppman
Station Info will only work properly if you load the stream via the shoutcast.com/sbin/tunein-station.pls url, not if you load it via the direct ip:port url, because that's just the way that it works.
DJ Egg is offline   Reply With Quote
Old 12th March 2006, 17:14   #29
gordol
Member
 
Join Date: Oct 2004
Posts: 93
Quote:
Originally posted by DJ Egg
@gordol
Not sure what you meant, but I think the answer is yes.
See the this thread:
forums.winamp.com/showthread.php?s=&threadid=239011
Quote:

There was some fix for duplicate files being uploaded when using sync/autofill.
I, for one, don't use autofill.
Quote:

The other fix was to make sure the native pmp_ipod plugin doesn't load if the old 3rd-party ml_ipod plugin is present, to avoid conflicts between the two plugins (ie. it's best to make sure only one of the two plugins is present first, not both).
As shown in the linked thread, I did a wipe and reinstall of 5.2 without the native pmp plugin and installed ml_ipod, and it still didn't work.
gordol is offline   Reply With Quote
Old 12th March 2006, 18:23   #30
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
Sorry. No idea. 5.2 or ml_ipod aren't supported (5.21 and pmp_ipod are). Anyone else?
DJ Egg is offline   Reply With Quote
Old 12th March 2006, 23:17   #31
ott598487
Junior Member
 
Join Date: Feb 2006
Posts: 5
Shoutcast Browser now much better

Thanks for making the SC browser usable again!
ott598487 is offline   Reply With Quote
Old 13th March 2006, 05:57   #32
gordol
Member
 
Join Date: Oct 2004
Posts: 93
Quote:
Originally posted by DJ Egg
Sorry. No idea. 5.2 or ml_ipod aren't supported (5.21 and pmp_ipod are). Anyone else?
You misinderstood. I don't care if it's ml_ipod or pmp_ipod. pmp_ipod is broken in 5.2 and I couldn't get ml_ipod to work in 5.2 instead so I reverted to 5.13.

Does pmp_ipod work right in 5.21 or not? IOW, can I upgrade, or do I stay with the older version of Winamp?
gordol is offline   Reply With Quote
Old 13th March 2006, 11:51   #33
stuckinasquare3
Member
 
Join Date: Feb 2006
Posts: 74
heres a dumb question...which one to i d/l?
stuckinasquare3 is offline   Reply With Quote
Old 13th March 2006, 13:46   #34
bemymonkey
Senior Member
 
bemymonkey's Avatar
 
Join Date: Dec 2004
Location: Germany
Posts: 461
Awesome, thanks for fixing the video-window keyboard shortcut bugs... Go Winamp!

Weeeeeeeeeeee
bemymonkey is offline   Reply With Quote
Old 14th March 2006, 03:14   #35
cruxial
Junior Member
 
Join Date: Feb 2006
Posts: 3
I'm very disappointed with the latest update of winamp. First of all I can't play wav files. It is not listed under associated file types. What happened?!? I had to manually enter it under in_wave.dll but even then it doesn't stay there. Also, my favorite dsp plug-in doesn't work with the new version! Pitch fork loads and then it produces error at 216 or something like that. Then I have to un-install the damn thing and and re-install it, which doesn't go very smoothly. Finally, the songs skip when I'm playing video games. What an awful update! From someone who has been using Winamp since day one, I can't comprehend how a new build with bug fixes can come out so bad. Is there a way I can download an older version?
cruxial is offline   Reply With Quote
Old 14th March 2006, 03:24   #36
gordol
Member
 
Join Date: Oct 2004
Posts: 93
Quote:
Originally posted by cruxial
Is there a way I can download an older version?
This is exactly the reason why I archive everyting I download and keep, at least until settling into a new version. Never know when you might need it again.
gordol is offline   Reply With Quote
Old 14th March 2006, 04:36   #37
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 838
that's odd, i had no such problems with wav filetypes not being present in the list, etc. i suggest you uninstall winamp and reinstall 5.21

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 14th March 2006, 08:32   #38
bemymonkey
Senior Member
 
bemymonkey's Avatar
 
Join Date: Dec 2004
Location: Germany
Posts: 461
Quote:
Originally posted by cruxial
Is there a way I can download an older version?
Try Googling for "old winamp versions"... don't think we're allowed to post links to other winamp sites on here because that would fall under advertising ...

Weeeeeeeeeeee
bemymonkey is offline   Reply With Quote
Old 14th March 2006, 09:56   #39
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
gen_ff.dll error:

you cannot load xml/colorthemes/*.xml files anymore

<include file="xml/colorthemes/*.xml"> included all xml files in this directory! this doesn't work with winamp5.12

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline   Reply With Quote
Old 14th March 2006, 13:57   #40
hawke
Junior Member
 
Join Date: Jan 2006
Posts: 32
cruxial,I have the same problem with you.
Some of wav files not all can't play in Winamp 5.21.
All of wav files can play in Winamp 5.13.
so I don't like use Winamp 5.21.
hawke is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump