Old 19th September 2007, 13:42   #1
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Who has a 3G nano? Please help in development!

I need help to implement cover art for the new nano. Could anybody with such a device please make it empty, then transfer exactly one song to it with iTunes (a song that has cover art). Then zip the whole X:\iPod_Control\Artwork folder and send it to me (post it here, or PM). That will help to figure out the neded format.

Thanks.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 4th October 2007, 10:20   #2
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
Hi Abu,

First off, many thanks for you hard work to provide the community with an alternative to itunes (we need it!).

I've done as you requested, if you need any more help then let me know.

Marco.
Attached Files
File Type: 7z artwork.7z (87.8 KB, 224 views)
mad-marco is offline   Reply With Quote
Old 4th October 2007, 11:30   #3
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Thanks, I had a quick look.
These are exactly the same sizes as on the classic. So it should be easy to add the nano to the list of supported devices.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE

Last edited by abu; 4th October 2007 at 11:49.
abu is offline   Reply With Quote
Old 4th October 2007, 13:16   #4
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
You can test with 3.01p06 now, that should work with the nano.

If you could make another test for me. Almost the same: Transfer exactly one photo (not cover) to the nano with iTunes. Then zip the whole Photos folder from the iPod. Thanks.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 5th October 2007, 13:23   #5
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
Hi Abu,

I don't know how you do it, but it worked!

I installed a fresh copy of Winamp 5.5 Beta 1600 (I know that this isn't a supported version, but I wanted to check out the native iPod support which doesn't work btw).

Uninstalled native ipod support
Install ml_ipod 3.01 then installed 3.01 p7
Ticked Enable cover art support for this device
Connected my nano

Initially it didn't work (no cover art), but I figured that the database was well trashed by now with all the messing about so I reset the device and erased all the data. After connecting the nano back to the pc and firing up Winamp I copied a single mp3 which worked fine. I then copied about 500 mp3's and so far it looks to be working ok. Cover flow works OK, the screen-saver scrolling cover-art works ok, track to track cover-art works OK.

Many thanks for you work, I am a very happy iPod nano 3G owner! I'll post the photos folder for you shortly.

Marco
mad-marco is offline   Reply With Quote
Old 5th October 2007, 13:42   #6
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
Hi Abu,

I can't upload the photo photo, it's 340k using 7zip and 100k is the limit. Any other way to get it to you?

FYI I have been trying to break the cover art, copy mp3s using winamp, then copy a few from itunes, then copy a few from winamp etc. It all seem to be very robust.

Marco
mad-marco is offline   Reply With Quote
Old 5th October 2007, 14:33   #7
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Use stashbox.org.

You managed to connect it to iTunes AFTER you loaded some stuff with ml_iPod? That's even better than the classic, where iTunes refuses to work after ml_iPod has touched the database...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 5th October 2007, 14:52   #8
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
You need to make sure that itunes is set to manual mode, not to automatically synchronise and all looks ok.

I have a potentially stupid question, can you copy audiobooks into the ipod using ml_ipod? I've converted an audiobook to w4b format, which when copied using itunes will go into the audiobooks menu on the ipod. This is good because I can then resume the audiobook from where i left off. When copying using ml_ipod it ends up with the music. Am I being a bit thick?

Marco
mad-marco is offline   Reply With Quote
Old 5th October 2007, 14:58   #9
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Read the Wiki page on audiobooks. It all works by genre in ml_iPod...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 6th October 2007, 07:43   #10
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Marco, please see http://forums.winamp.com/showthread....93#post2250293

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 23rd October 2007, 10:08   #11
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
Hi Abu,

Sorry for not posting a reply for such a long time, I had to go away with work and then was on holiday

Also sorry for the dumb question. RTFM, I hear you... I tried the audiobook support and it worked great. Much easier than the itunes method of converting the mp3's to w4b and the resume still works fine!

I've had no significant problems to report, I used my nano loads over the last couple of weeks of travelling and couldn't be happier. I've still to convert a movie to test on it, but to be honest it's not a feature that I'm that interested in. My WM6 SmartPhone has a better screen for that kind of thing.

Here is the photo folder that you asked for using the image on the thread you linked to. Hope that it helps out.
Attached Files
File Type: 7z photos.7z (3.2 KB, 219 views)
mad-marco is offline   Reply With Quote
Old 23rd October 2007, 10:09   #12
mad-marco
Junior Member
 
Join Date: Oct 2007
Posts: 6
P.S. The photo sync works great, I've transfered 20 or so photos onto my nano no problem.
mad-marco is offline   Reply With Quote
Old 23rd October 2007, 18:45   #13
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Good to know. Someone else sent a zip already, that's how I could fix it.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 6th November 2007, 09:34   #14
fritzcm
Junior Member
 
Join Date: Nov 2007
Location: United States
Posts: 13
Hi,

Just to give some reviews... I'm using;

iPod Nano Video 3rd Gen (8GB) V1.02 PC
Winamp 5.5
AudioScrobbler for Winamp v1.1.10 (Build 634)
ml_ipod 3.01p12

Music
- I have no problems with uploading 900+ mp3s.
- Uploads are fast.
- Cover Flow Album Art works.
- Sample cover arts scroll while browsing in the menu.
- Playing a song shows the album cover art as well.

Videos
- Videos are uploaded fast.
- Music Videos also appear in music/mp3 list. This is a nice feature but is there a way to avoid this?
!- The videos don't have sample shots or screenshots.
!- I use the comment tags to sort the videos to: Music Videos [MV], TV Shows [TV], and Movies [M]. Putting them into folders doesn't seem to work.

Photos
- Photos are uploaded quite well.
- Sample photos scroll while browsing in the menu.

Podcasts
- Works well. I have TikiBarTV uploaded.

Others
- Smart Playlists works well with mp3s and videos.
- Play count and last played info from ipod is synced to Winamp but last.fm doesn't seem to be updated. AudioScrobbler.log.txt doesn't show that info is sent over. Only music played from the Media Library gets posted to last.fm

That's it for now. I hope it helps further development. And I also hope it shows people that there's an alternative to iTunes.
fritzcm is offline   Reply With Quote
Old 6th November 2007, 12:09   #15
fatcerberus1
Major Dude
 
fatcerberus1's Avatar
 
Join Date: Mar 2007
Location: United States
Posts: 806
Regarding music videos showing up in audio menus: Unfortunately, this is by design and hardcoded in the firmware, so there's no way to turn this feature off.

As for the video folders not working: Are any of your video folders by chance subfolders of another video folder? This won't work. Video folders are searched recursively, so if your other folders are subfolders of the movie folder (for example), all your videos will be marked as movies before the TV show & music TV show folder specs are even checked. Of course, if this isn't how you're doing it, there's no reason video folders shouldn't work...

Windows 7 Beta
iPod touch (Second Generation), 8GB
Winamp 5.55 with ml_iPod 3.08
fatcerberus1 is offline   Reply With Quote
Old 14th November 2007, 00:28   #16
fritzcm
Junior Member
 
Join Date: Nov 2007
Location: United States
Posts: 13
Thanks for the info about the music videos.

The video folders are actually working. What doesn't work is the screenshots of the videos. When I used iTunes, there were screenshots. But when I used ml_ipod, I lose all video screenshots.
fritzcm is offline   Reply With Quote
Old 14th November 2007, 11:12   #17
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
What screenshots?

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 14th November 2007, 14:41   #18
fatcerberus1
Major Dude
 
fatcerberus1's Avatar
 
Join Date: Mar 2007
Location: United States
Posts: 806
I think he means the video screenshots in the right-side panel.

If you search around, fritzcm, you'll see that this doesn't work because ml_iPod has no way to extract frames from the video. For now, there's a workaround: use the cover art feature and either take screenshots of the movies yourself, or use the DVD cover art (if it's a movie). This way you'll at least have something on the side panel, anyway.

Windows 7 Beta
iPod touch (Second Generation), 8GB
Winamp 5.55 with ml_iPod 3.08
fatcerberus1 is offline   Reply With Quote
Old 29th November 2007, 06:03   #19
fritzcm
Junior Member
 
Join Date: Nov 2007
Location: United States
Posts: 13
Yup, fatcerberus1 is correct. I meant the video screenshots in the right-side panel.

Thanks for the suggestion. I'll try that out.

By the way, the latest version of ml_iPod 3.02 works great!
fritzcm is offline   Reply With Quote
Old 29th November 2007, 14:44   #20
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Regarding your last.fm issue: There are quite some people who have this working. You MUST use the audioscrobbler plugin that comes bundled with ml_iPod 3.02, though. Nothing else will work.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 29th November 2007, 16:38   #21
fritzcm
Junior Member
 
Join Date: Nov 2007
Location: United States
Posts: 13
ml_iPod 3.02 now works with last.fm.

The previous version 3.01 didn't work properly. It only sent in the played music from Winamp but it didn't send the played music from iPod.

With the 3.02, it sends both played music to last.fm.

Thanks again for the great plugin! So far, I haven't seen any problems.
fritzcm is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump