Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 10th October 2007, 16:22   #1
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Winamp 5.5: strange crash, somehow related to TFMX playback

Hello,

I'm using TFMX Player 1.25 by Peter Pawlowski and it always worked great. Now, with Winamp 5.5 (I used Winamp 5.35 until yesterday), there is a strange error (actually Winamp 5.5 crashes), when the interpolation method in the TFMX Player is set to "cubic":
code:
Microsoft Visual C++ Runtime Library

Program: C:\Programme\Winamp5\winamp.exe

R6025
- pure virtual function call


The plugin always worked great in previous versions of Winamp.

Info:
  • Windows XP Pro SP2 (updated to the latest patch)
  • Sound card drivers and DirectX up-to-date
  • Pentium 4 HT@2.8GHz, Abit IC7-Max3, 2 GB RAM, Creative Labs Audigy 4 Pro, MSI 7800GS AGP
  • DirectSound output (out_ds.dll) used
Regards,
derJörg
derJörg is offline   Reply With Quote
Old 10th October 2007, 18:26   #2
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Looks like it is a third-party plugin. Those aren't supported and you will need to contact the author for support.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 10th October 2007, 19:48   #3
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

...I know that third party plugins are not supported here.

The plugin didn't change for a long time. Now, that a new version of Winamp arrives, Winamp crashes. It's possible that some of the changes for the new version introduced an incompatibility in Winamp.

Besides, the author of the plugin is the author of foobar2000, who had been working for Nullsoft some time ago. Maybe it's a good idea to write him an eMail, too...

Regards,
derJörg
derJörg is offline   Reply With Quote
Old 10th October 2007, 20:05   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
with the issue, there was/is a case with in_usf/64th note that maybe the same... one thing to do is to disable the built in main window visualiser (that resolved the in_usf issue as a workaround). if that works with the tfmx plugin then it will be the newer spectrum vis code at fault - i know we ran out of time to look into the issue fully with in_usf before 5.5 final and that's the only thing with the plugin that might cause a crash as nothing else was altered with the in_* api otherwise

as for contacting peter, i think with how things were, i really doubt he'd find any reason to want to update the plugin (assuming the code still even exists) especially considering how bad the split was to cause the development of fb2k

-daz
DrO is offline   Reply With Quote
Old 10th October 2007, 21:22   #5
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

...I tried TFMX playback without any visualization and Winamp still crashes, but I found a detail which might help spot the cause of the crash: sometimes a short piece of the TFMX module can be heard before Winamp crashes (about half a second or so).

I tried all three output plugins and the result is always the same. Other plugins are not active (except the standard gen_ and ml_ plugins).

/me running further tests...

Ha! After some testing I found a difference: with the Classic skin everything runs fine! The errors appears reproducably with the 5.5 Modern skin and both new Bento skins.

Regards,
derJörg
derJörg is offline   Reply With Quote
Old 11th October 2007, 06:28   #6
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
...err...one additional note: everything works fine with the Classic skin as long as the built-in visualizer is turned off. I forgot to mention that in my previous posting...

Regards,
derJörg
derJörg is offline   Reply With Quote
Old 11th October 2007, 08:16   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
ah so it is the same issue as i thought then if it's all working fine with classic+vis off

-daz
DrO is offline   Reply With Quote
Old 12th October 2007, 07:10   #8
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

...will it be fixed in one of the next versions? Can it be fixed at all?

Regards,
derJörg
derJörg is offline   Reply With Quote
Old 12th October 2007, 07:55   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
no idea at the moment, i've not spoken to the lead dev on this matter (we're all having a little breather after the last few weeks hard slog with getting 5.5 out the door) so as soon as i know i/someone will try and post back.

-daz
DrO is offline   Reply With Quote
Old 12th October 2007, 18:23   #10
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

...thank you very much. I'm patiently looking forward to the next piece of information...

Regards,
derJörg
derJörg is offline   Reply With Quote
Old 13th October 2007, 23:42   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
can you upload one of the files you've been working with since the few i managed to find to test with work fine both with the existing 5.5 winamp.exe and one that i've altered to resolve in_usf and in_vqf which were experiencing the same issue, thanks

-daz
DrO is offline   Reply With Quote
Old 15th October 2007, 12:45   #12
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

...yes, of course...

The attached .zip archive contains my currently used TFMX plugin and one TFMX file (from the game Apidya).

Regards,
derJörg
Attached Files
File Type: zip tfmx test files.zip (68.5 KB, 454 views)
derJörg is offline   Reply With Quote
Old 20th October 2007, 11:12   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
just tried it with the test winamp.exe i have and the one from 5.5 and neither crashed with the file (though now that we know what the bug was it's possible it may not show up on all installs due to differences in where things are loaded in the winamp process space). pm sent btw

-daz
DrO is offline   Reply With Quote
Old 20th October 2007, 21:47   #14
derJörg
Junior Member
 
derJörg's Avatar
 
Join Date: Oct 2007
Location: Germany
Posts: 22
Hello,

I'm looking forward to the next release of Winamp.

Regards,
derJörg
derJörg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump