Go Back   Winamp & SHOUTcast Forums > International Connection > International Connection

Reply
Thread Tools Search this Thread Display Modes
Old 25th October 2013, 20:31   #1
kapyderi
Junior Member
 
Join Date: Oct 2013
Posts: 3
¿Que criterio sigue el winamp a la hora de cargar una lista de reproducción?

Hola buenas tardes.

A ver si alguien sabe el motivo de que al cargar una lista por primera vez en winamp pone el orden que quiere, pues creo que es por los frames del metadato, pero seguro no estoy y el nombre deberia seguir una pauta numerica que yo le he puesto delante.

Estoy preguntando en este foro, porque en el coche tambien me sigue el mismo orden y eso que he destripado todos los tags tanto en version 1 como en version2 (me refiero a las etiquetas del mp3) y siguen haciendo lo mismo.

Si alguien me puede iluminar se lo agradeceria, ya que es bastante molesto que no siga el orden que yo le he puesto.

PD.: Se que se puede utilizar sort para cambiar los ordenes, pero yo quisiera saber cual es el criterio en la primera carga de la lista ya que en el coche no me da la opción de poder ordenar. xDDD

Gracias y saludos desde Murcia!!!
kapyderi is offline   Reply With Quote
Old 27th October 2013, 03:15   #2
kapyderi
Junior Member
 
Join Date: Oct 2013
Posts: 3
Me contesto (o eso creo) a mi mismo

Creo que esto le va a servir a mucha gente que no sabe porque falla el tema del orden de las pistas.

De casualidad y despues de varias horas intentando encontrar la logica de la lista, creo que ya he dado con el problema

Expongo... (Es una teoria porque no tengo un pendrive a mano que pueda formatear para ver si es correcto lo que digo, si alguien lo puede hacer que comente).

Cuando se copia en un disco duro/pendrive/memoria, etc. un mp3, se le asigna en el disco una zona que no tiene porque estar ordenada según se vayan introduciendo mas mp3, por lo que si el Track1 lo graba en el sector 127 y el Track2 en el sector 183 y el Track3 en el sector 50 (son ejemplos) al coger la lista el winamp ordenara según vaya encontrando los Track seleccionados, por lo que la logica dice que si no se activa el ordenamiento automatico en preferencias, cogera el orden Track3,Track1,Track2.

Como lo descubri...sencillo, renombre un archivo y vi que ya no estaba en la posición que le habia puesto winamp y cambio de posicion, luego lo volvi a hacer y lo mismo, iban cambiando de sitio, ya que se iba metiendo en diferentes sectores del disco o es lo que pensaba, luego arrastre toda la carpeta a otro disco duro y voila, todo el desorden habia cambiado y lo cargue 10 veces y vi que cogia siempre el mismo "desorden", tras esto pienso que hay que hacer lo siguiente.

Grabar una copia de seguridad del pendrive en el disco duro.
Formatear en fat32 (es el más estandar aun con sus limitaciones) el pendrive.
Volcar la copia de seguridad en el orden correcto de las canciones.

Creo que con esos pasos todo deberia funcionar de maravilla, pero no lo puedo probar hasta el lunes que pueda liberar algun "pincho".

Si estoy en lo correcto valdrá la pena el haber perdido tantas horas creando un programa en c++/qt para etiquetar mp3/ogg que me va a servir para mi Proyecto Derix.

Saludos y gracias por haber leido como minimo mi post!!!
kapyderi is offline   Reply With Quote
Old 27th October 2013, 21:06   #3
kapyderi
Junior Member
 
Join Date: Oct 2013
Posts: 3
Funciona sin tener que formatear

Verificado...funciona!!!!

Solo hay que hacer una backup de los datos del pincho y vaciar despues el pincho completamente, luego queda volver a volcar las canciones arrastrando desde la primera cancion que este en la lista y al copiar ya sigue el orden secuencial de los sectores y por lo tanto en orden de entrada asignado por winamp.

Saludos!!!
kapyderi is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > International Connection > International Connection

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump